aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/jama/Makefile4
-rw-r--r--math/miracl/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/math/jama/Makefile b/math/jama/Makefile
index 975229207bef..0fdeb4c32750 100644
--- a/math/jama/Makefile
+++ b/math/jama/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt \
unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt
-USES= zip:infozip
+USES= zip
NO_BUILD= yes
do-install:
@@ -27,7 +27,7 @@ do-install:
${UNZIP_CMD} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
-d ${STAGEDIR}${PREFIX}/include/tnt
${MKDIR} ${WRKDIR}/doc ${STAGEDIR}${DOCSDIR}
- ${UNZIP_CMD} -o ${DISTDIR}/${DIST_SUBDIR}/jama102doc \
+ ${UNZIP_CMD} -o ${DISTDIR}/${DIST_SUBDIR}/jama102doc.zip \
-d ${WRKDIR}/doc
(cd ${WRKDIR}/doc/doxygen && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
diff --git a/math/miracl/Makefile b/math/miracl/Makefile
index 85a4008670f2..f2b6989c56bf 100644
--- a/math/miracl/Makefile
+++ b/math/miracl/Makefile
@@ -24,10 +24,10 @@ LICENSE_PERMS_COMMERCIAL= dist-mirror dist-sell pkg-mirror pkg-sell no-auto-acce
ONLY_FOR_ARCHS= i386 amd64
-USES= zip:infozip
+USES= zip
USE_LDCONFIG= yes
-EXTRACT_BEFORE_ARGS= -j -aa -L -q
+EXTRACT_BEFORE_ARGS= -j -L -q
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
PLIST_FILES= lib/libmiracl.a \