aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fltk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fltk/Makefile')
-rw-r--r--x11-toolkits/fltk/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index b38fd3e89eb7..f568a86b11e3 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -12,8 +12,10 @@ COMMENT= Cross-platform C++ graphical user interface toolkit
LICENSE= LGPL20
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+OPTIONS_DEFINE= DOCS
+
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_LDCONFIG= yes
USE_XORG= xft
@@ -31,16 +33,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
-MAN1= fltk-config.1 fluid.1
-MAN3= fltk.3
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-patch:
prefix="${PREFIX}" ; plength=$$(($${#prefix}+10)) ; \
${REINPLACE_CMD} -e "\|/etc/fltk|{s||${PREFIX}&|;s|10|$${plength}|;}" \
${WRKSRC}/src/Fl_Preferences.cxx
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
cd ${WRKSRC}/documentation && ${MAKE} docinstall
cd ${WRKSRC}/test && ${MAKE} install