aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk/Makefile12
-rw-r--r--x11-toolkits/fltk/files/patch-fluid_Fl_Type.h16
-rw-r--r--x11-toolkits/fltk/pkg-plist3
3 files changed, 25 insertions, 6 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index b38fd3e89eb7..f568a86b11e3 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -12,8 +12,10 @@ COMMENT= Cross-platform C++ graphical user interface toolkit
LICENSE= LGPL20
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+OPTIONS_DEFINE= DOCS
+
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_LDCONFIG= yes
USE_XORG= xft
@@ -31,16 +33,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
-MAN1= fltk-config.1 fluid.1
-MAN3= fltk.3
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-patch:
prefix="${PREFIX}" ; plength=$$(($${#prefix}+10)) ; \
${REINPLACE_CMD} -e "\|/etc/fltk|{s||${PREFIX}&|;s|10|$${plength}|;}" \
${WRKSRC}/src/Fl_Preferences.cxx
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
cd ${WRKSRC}/documentation && ${MAKE} docinstall
cd ${WRKSRC}/test && ${MAKE} install
diff --git a/x11-toolkits/fltk/files/patch-fluid_Fl_Type.h b/x11-toolkits/fltk/files/patch-fluid_Fl_Type.h
new file mode 100644
index 000000000000..d258b711bf9e
--- /dev/null
+++ b/x11-toolkits/fltk/files/patch-fluid_Fl_Type.h
@@ -0,0 +1,16 @@
+--- fluid/Fl_Type.h.orig 2013-10-15 09:58:05.000000000 +0200
++++ fluid/Fl_Type.h 2013-10-15 10:01:26.000000000 +0200
+@@ -33,10 +33,12 @@
+
+ void set_modflag(int mf);
+
++Fl_Widget *make_type_browser(int,int,int,int,const char *l=0);
++
+ class Fl_Type {
+
+ friend class Widget_Browser;
+- friend Fl_Widget *make_type_browser(int,int,int,int,const char *l=0);
++ friend Fl_Widget *make_type_browser(int,int,int,int,const char *l);
+ friend class Fl_Window_Type;
+ virtual void setlabel(const char *); // virtual part of label(char*)
+
diff --git a/x11-toolkits/fltk/pkg-plist b/x11-toolkits/fltk/pkg-plist
index 88266fa9dd9f..5f5300dc3374 100644
--- a/x11-toolkits/fltk/pkg-plist
+++ b/x11-toolkits/fltk/pkg-plist
@@ -158,4 +158,7 @@ lib/libfltk_images.a
lib/libfltk_images.so
lib/libfltk_images.so.1
lib/libfltk_images.so.1.3
+man/man1/fltk-config.1.gz
+man/man1/fluid.1.gz
+man/man3/fltk.3.gz
@dirrm include/FL