aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-01-22 23:44:24 +0800
committerijliao <ijliao@FreeBSD.org>2001-01-22 23:44:24 +0800
commit0176224f58b4daec86990de167ab7d6cee184a33 (patch)
tree9d3a99d46b2d72de80e8f38abf1de3e3d8878304
parent65f7ee5b06fe557fcb68cb3f37506a5eee25a3e6 (diff)
downloadfreebsd-ports-graphics-0176224f58b4daec86990de167ab7d6cee184a33.tar.gz
freebsd-ports-graphics-0176224f58b4daec86990de167ab7d6cee184a33.tar.zst
freebsd-ports-graphics-0176224f58b4daec86990de167ab7d6cee184a33.zip
add sxm, another implementation of scheme
-rw-r--r--lang/Makefile1
-rw-r--r--lang/sxm/Makefile24
-rw-r--r--lang/sxm/distinfo1
-rw-r--r--lang/sxm/pkg-comment1
-rw-r--r--lang/sxm/pkg-descr14
-rw-r--r--lang/sxm/pkg-plist2
6 files changed, 43 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 6e63ae6ca74..5144c06a982 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -129,6 +129,7 @@
SUBDIR += sr
SUBDIR += starlogo
SUBDIR += swi-pl
+ SUBDIR += sxm
SUBDIR += t3x
SUBDIR += tcl80
SUBDIR += tcl81-thread
diff --git a/lang/sxm/Makefile b/lang/sxm/Makefile
new file mode 100644
index 00000000000..00676d4877a
--- /dev/null
+++ b/lang/sxm/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# New ports collection makefile for: sxm
+# Date created: Jan 8, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sxm
+PORTVERSION= 1.0
+CATEGORIES= lang
+MASTER_SITES= http://www.malgil.com/sxm/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_GMAKE= yes
+ALL_TARGET= all image Formlist
+
+MAN1= sxm.1 sxi.1
+
+post-extract:
+ @${PERL} -pi -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/lang/sxm/distinfo b/lang/sxm/distinfo
new file mode 100644
index 00000000000..643c9b0d5b3
--- /dev/null
+++ b/lang/sxm/distinfo
@@ -0,0 +1 @@
+MD5 (sxm-1.0.tar.gz) = 9fa9b81e348bd65bb1b2989a29df4aaf
diff --git a/lang/sxm/pkg-comment b/lang/sxm/pkg-comment
new file mode 100644
index 00000000000..7c4df2331ed
--- /dev/null
+++ b/lang/sxm/pkg-comment
@@ -0,0 +1 @@
+Another implementation of Scheme
diff --git a/lang/sxm/pkg-descr b/lang/sxm/pkg-descr
new file mode 100644
index 00000000000..a3d661264be
--- /dev/null
+++ b/lang/sxm/pkg-descr
@@ -0,0 +1,14 @@
+SXM (a.k.a. CXEMA) is a portable implementation of the Scheme
+Programming language. It conforms to IEEE/ANSI standard of Scheme
+and supports all features of the R5RS Report on Scheme. In addition,
+SXM supports numerous features of Chez Scheme v6.0 and SRFIs 0, 6, 8,
+11, and 16. SXM is derived from David Michael Betz's XScheme. Due to
+the loss of compatibility with the original (object system has been
+dropped) and significant amount of modifications and additions (SXM
+is 4 times bigger), I decided to treat it as a separate project with
+its own name.
+
+WWW: http://www.malgil.com/sxm/
+
+-- Ying-Chieh Liao
+ ijliao@FreeBSD.org
diff --git a/lang/sxm/pkg-plist b/lang/sxm/pkg-plist
new file mode 100644
index 00000000000..34156910f64
--- /dev/null
+++ b/lang/sxm/pkg-plist
@@ -0,0 +1,2 @@
+bin/sxi
+bin/sxm