aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-11-15 07:40:22 +0800
committerleeym <leeym@FreeBSD.org>2004-11-15 07:40:22 +0800
commit15730d26f67e47398bb8d83ce0ddacc6bad65130 (patch)
treea542d26440248873fa4b9fd8586126a3c9e4e385
parent7733bc18bf0faf18a487568bf507bd95a680cc12 (diff)
downloadfreebsd-ports-graphics-15730d26f67e47398bb8d83ce0ddacc6bad65130.tar.gz
freebsd-ports-graphics-15730d26f67e47398bb8d83ce0ddacc6bad65130.tar.zst
freebsd-ports-graphics-15730d26f67e47398bb8d83ce0ddacc6bad65130.zip
- use Net::NNTP from p5-Net instead of system perl
- add optional dependency of PGP::Sign - update URL in pkg-descr Reviewed by: Don Croyle <croyle@gelemna.org>
-rw-r--r--news/p5-News-Article/Makefile16
-rw-r--r--news/p5-News-Article/pkg-descr2
2 files changed, 15 insertions, 3 deletions
diff --git a/news/p5-News-Article/Makefile b/news/p5-News-Article/Makefile
index 2d2fd8a91ed..b2f92c787e2 100644
--- a/news/p5-News-Article/Makefile
+++ b/news/p5-News-Article/Makefile
@@ -7,7 +7,7 @@
PORTNAME= News-Article
PORTVERSION= 1.27
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= News
@@ -16,9 +16,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Object for handling Usenet articles in mail or news form
+BUILD_DEPENDS= ${SITE_PERL}/Net/NNTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${SITE_PERL}/Net/NNTP.pm:${PORTSDIR}/net/p5-Net
+
PERL_CONFIGURE= yes
MAN3= News::Article.3 News::AutoReply.3 News::FormArticle.3 \
News::FormReply.3
-.include <bsd.port.mk>
+OPTIONS= PGP_SIGN "PGP::Sign support for header signing" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_PGP_SIGN)
+BUILD_DEPENDS+= ${SITE_PERL}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+RUN_DEPENDS+= ${SITE_PERL}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/news/p5-News-Article/pkg-descr b/news/p5-News-Article/pkg-descr
index cef0c8da570..61bc8d43548 100644
--- a/news/p5-News-Article/pkg-descr
+++ b/news/p5-News-Article/pkg-descr
@@ -2,4 +2,4 @@ This module allows for creating articles from scratch, or reading them
from various data sources; various header manipulations, and posting
via NNTP or mailing via a sendmail-workalike.
-WWW: http://search.cpan.org/dist/News-Article/
+WWW: http://www.erlenstar.demon.co.uk/perl/