aboutsummaryrefslogtreecommitdiffstats
path: root/audio/goobox
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /audio/goobox
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-graphics-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-graphics-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-graphics-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'audio/goobox')
-rw-r--r--audio/goobox/Makefile4
-rw-r--r--audio/goobox/files/patch-src_main.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index d64af3c1fe6..aa429d30c49 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= goobox
PORTVERSION= 1.9.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -38,7 +38,7 @@ OPTIONS= NOTIFY "Enable libnotify support" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+= --enable-notification
.else
CONFIGURE_ARGS+= --disable-notification
diff --git a/audio/goobox/files/patch-src_main.c b/audio/goobox/files/patch-src_main.c
new file mode 100644
index 00000000000..aabcd8b783c
--- /dev/null
+++ b/audio/goobox/files/patch-src_main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2011-08-15 20:09:01.000000000 +0200
++++ src/main.c 2011-08-15 20:09:22.000000000 +0200
+@@ -698,7 +698,7 @@ system_notify (GooWindow *window,
+ }
+
+ if (notification == NULL) {
+- notification = notify_notification_new (title, msg, "goobox", NULL);
++ notification = notify_notification_new (title, msg, "goobox");
+ notify_notification_set_urgency (notification, NOTIFY_URGENCY_LOW);
+ notify_notification_add_action (notification,
+ GTK_STOCK_MEDIA_NEXT,