aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gsound/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-07-03 04:03:06 +0800
committerkwm <kwm@FreeBSD.org>2015-07-03 04:03:06 +0800
commitd6caac6942578c45d22e561fff8fe7e3db184623 (patch)
tree10430743c0e9fa70d4de62da687d622e623f43f4 /audio/gsound/Makefile
parent210504ac41225afd905f175f9248512e9b0bde2d (diff)
downloadfreebsd-ports-graphics-d6caac6942578c45d22e561fff8fe7e3db184623.tar.gz
freebsd-ports-graphics-d6caac6942578c45d22e561fff8fe7e3db184623.tar.zst
freebsd-ports-graphics-d6caac6942578c45d22e561fff8fe7e3db184623.zip
Add gsound.
GSound is based on libcanberra to play system sounds. Obtained from: GNOME dev repo.
Diffstat (limited to 'audio/gsound/Makefile')
-rw-r--r--audio/gsound/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/audio/gsound/Makefile b/audio/gsound/Makefile
new file mode 100644
index 00000000000..f38d771e924
--- /dev/null
+++ b/audio/gsound/Makefile
@@ -0,0 +1,20 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gsound
+PORTVERSION= 1.0.1
+CATEGORIES= audio
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GObject library for playing system sounds
+
+BUILD_DEPENDS= vala:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libcanberra.so:${PORTSDIR}/audio/libcanberra
+
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= glib20 introspection:build
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>