aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql84-server
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2014-03-21 16:15:26 +0800
committergirgen <girgen@FreeBSD.org>2014-03-21 16:15:26 +0800
commitc463983e13f640d5ab1f4c30e2e5a2bb0c8165ae (patch)
tree5784c90fb8b046a61ebdfd58acb06301370705a7 /databases/postgresql84-server
parent0916b3f464a8419e91ce34f0611b5604869ba0f1 (diff)
downloadfreebsd-ports-graphics-c463983e13f640d5ab1f4c30e2e5a2bb0c8165ae.tar.gz
freebsd-ports-graphics-c463983e13f640d5ab1f4c30e2e5a2bb0c8165ae.tar.zst
freebsd-ports-graphics-c463983e13f640d5ab1f4c30e2e5a2bb0c8165ae.zip
Fix mistake with ossp-uuid: don't use --with-ossp-uuid, since it will need
the ossp library present, and then we never use it.
Diffstat (limited to 'databases/postgresql84-server')
-rw-r--r--databases/postgresql84-server/files/patch-contrib-uuid10
1 files changed, 10 insertions, 0 deletions
diff --git a/databases/postgresql84-server/files/patch-contrib-uuid b/databases/postgresql84-server/files/patch-contrib-uuid
index a1b312cc240..832076fd6dc 100644
--- a/databases/postgresql84-server/files/patch-contrib-uuid
+++ b/databases/postgresql84-server/files/patch-contrib-uuid
@@ -369,3 +369,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
+--- contrib/Makefile.orig 2014-03-21 09:09:12.000000000 +0100
++++ contrib/Makefile 2014-03-21 09:09:28.000000000 +0100
+@@ -39,6 +39,7 @@
+ tablefunc \
+ test_parser \
+ tsearch2 \
++ uuid-ossp \
+ vacuumlo
+
+ ifeq ($(with_openssl),yes)