aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvsplot/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-01 00:15:02 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-01 00:15:02 +0800
commit93e45f1d5a1215a5c31672d4cb05689a822a7a28 (patch)
tree4534116a34ffa575408f34fbdc94469fe43e525a /devel/cvsplot/Makefile
parentddbbb8ad786c11f0ed16b7107e6c8336ec51f340 (diff)
downloadfreebsd-ports-graphics-93e45f1d5a1215a5c31672d4cb05689a822a7a28.tar.gz
freebsd-ports-graphics-93e45f1d5a1215a5c31672d4cb05689a822a7a28.tar.zst
freebsd-ports-graphics-93e45f1d5a1215a5c31672d4cb05689a822a7a28.zip
add cvsplot 1.6.1
A perl script which analyses the history of a CVS-managed project
Diffstat (limited to 'devel/cvsplot/Makefile')
-rw-r--r--devel/cvsplot/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/cvsplot/Makefile b/devel/cvsplot/Makefile
new file mode 100644
index 00000000000..a448120bf54
--- /dev/null
+++ b/devel/cvsplot/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: cvsplot
+# Date created: May 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsplot
+PORTVERSION= 1.6.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ gnuplot:${PORTSDIR}/math/gnuplot
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^#!/usr/bin/perl -w,#!/usr/bin/env perl -w,g" ${WRKSRC}/cvsplot.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cvsplot.pl ${PREFIX}/bin/cvsplot
+
+.include <bsd.port.mk>