aboutsummaryrefslogtreecommitdiffstats
path: root/devel/nspr
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-11-01 10:40:29 +0800
committermarcus <marcus@FreeBSD.org>2006-11-01 10:40:29 +0800
commit6a07ff0a9b70a7578feaa2c58d8593c51196c256 (patch)
tree8cd25fe81ceccc96174bd92a494c1262e0b78f5a /devel/nspr
parent749e420e34fc7d26e8fb16d913d5b1390072b853 (diff)
downloadfreebsd-ports-graphics-6a07ff0a9b70a7578feaa2c58d8593c51196c256.tar.gz
freebsd-ports-graphics-6a07ff0a9b70a7578feaa2c58d8593c51196c256.tar.zst
freebsd-ports-graphics-6a07ff0a9b70a7578feaa2c58d8593c51196c256.zip
Work around the improperly defined libc stub for pthread_cond_wait(3)
which exists in FreeBSD prior August 7, 2006. Basically, on these versions of FreeBSD, we will call _pthread_cond_wait directly. This isn't perfect, but it will alow Firefox 2.0 to work on 6.1 and 5.5 without people needing to patch libc. Tested by: ahze and others
Diffstat (limited to 'devel/nspr')
-rw-r--r--devel/nspr/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
index 8be1e447276..0a306869cec 100644
--- a/devel/nspr/Makefile
+++ b/devel/nspr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nspr
PORTVERSION= 4.6.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= nspr/releases/v${PORTVERSION}/src
@@ -28,6 +29,15 @@ MAKE_ENV= DIST=${WRKSRC}/dist
LIBS= libnspr4.so.1 libplc4.so.1 libplds4.so.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 601104
+post-patch:
+ @${REINPLACE_CMD} -e 's|pthread_cond_wait|_pthread_cond_wait|g' \
+ ${WRKSRC}/../pr/src/md/unix/pthreads_user.c \
+ ${WRKSRC}/../pr/src/pthreads/ptsynch.c
+.endif
+
do-install:
${MKDIR} ${PREFIX}/include/nspr
${TAR} -C ${WRKSRC}/dist/include --dereference -cf - . | \
@@ -68,4 +78,4 @@ post-build:
#
#.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>