aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 14:55:09 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 14:55:09 +0800
commitfc0b672eec30461e3e62a828e5cb5946ad570a9f (patch)
tree6bc9cd6650f78e602d8c81c1a9c3543e6bd87533 /devel
parentbd313c62c5fb804bfd1afb5e1e3daece0bc83317 (diff)
downloadfreebsd-ports-graphics-fc0b672eec30461e3e62a828e5cb5946ad570a9f.tar.gz
freebsd-ports-graphics-fc0b672eec30461e3e62a828e5cb5946ad570a9f.tar.zst
freebsd-ports-graphics-fc0b672eec30461e3e62a828e5cb5946ad570a9f.zip
Support staging
Diffstat (limited to 'devel')
-rw-r--r--devel/eventxx/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/devel/eventxx/Makefile b/devel/eventxx/Makefile
index 3d6ec163728..8b71876193f 100644
--- a/devel/eventxx/Makefile
+++ b/devel/eventxx/Makefile
@@ -12,25 +12,22 @@ MASTER_SITE_SUBDIR= gahr
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ wrapper for libevent
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= EXAMPLES
+
post-extract:
@${REINPLACE_CMD} -e 's|-I..|-I.. -I${LOCALBASE}/include -L${LOCALBASE}/lib|g' \
${WRKSRC}/test/Makefile
do-install:
- @${INSTALL_DATA} ${WRKSRC}/eventxx ${PREFIX}/include
-
-post-install:
-.if !defined(NOPORTEXAMPLES)
- @${INSTALL} -d ${EXAMPLESDIR}
- @cd ${WRKSRC}/test && ${COPYTREE_SHARE} \*.cpp ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/test/Makefile ${EXAMPLESDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/eventxx ${STAGEDIR}${PREFIX}/include
+ ${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/test && ${COPYTREE_SHARE} \*.cpp ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/Makefile ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>