aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/eventxx/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/devel/eventxx/Makefile b/devel/eventxx/Makefile
index 3d6ec163728..8b71876193f 100644
--- a/devel/eventxx/Makefile
+++ b/devel/eventxx/Makefile
@@ -12,25 +12,22 @@ MASTER_SITE_SUBDIR= gahr
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ wrapper for libevent
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= EXAMPLES
+
post-extract:
@${REINPLACE_CMD} -e 's|-I..|-I.. -I${LOCALBASE}/include -L${LOCALBASE}/lib|g' \
${WRKSRC}/test/Makefile
do-install:
- @${INSTALL_DATA} ${WRKSRC}/eventxx ${PREFIX}/include
-
-post-install:
-.if !defined(NOPORTEXAMPLES)
- @${INSTALL} -d ${EXAMPLESDIR}
- @cd ${WRKSRC}/test && ${COPYTREE_SHARE} \*.cpp ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/test/Makefile ${EXAMPLESDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/eventxx ${STAGEDIR}${PREFIX}/include
+ ${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/test && ${COPYTREE_SHARE} \*.cpp ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/Makefile ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>