aboutsummaryrefslogtreecommitdiffstats
path: root/editors/glimmer/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-10-23 16:14:50 +0800
committersobomax <sobomax@FreeBSD.org>2000-10-23 16:14:50 +0800
commit5db5c54b12f4f3c03fd166a790d17453568cd2c6 (patch)
tree40669c805bee44b7b537dd53a91008ca216f7725 /editors/glimmer/Makefile
parent1ab194a3f934c463fad6385d9428397993ae39f8 (diff)
downloadfreebsd-ports-graphics-5db5c54b12f4f3c03fd166a790d17453568cd2c6.tar.gz
freebsd-ports-graphics-5db5c54b12f4f3c03fd166a790d17453568cd2c6.tar.zst
freebsd-ports-graphics-5db5c54b12f4f3c03fd166a790d17453568cd2c6.zip
Attempt to fix breakage when building on ssl-enabled systems (add -lcrypto if
/usr/lib/libcrypto.a exists). Also add -lutil for glimmer which seems required to build it with Python2.0. Submitted by: bento
Diffstat (limited to 'editors/glimmer/Makefile')
-rw-r--r--editors/glimmer/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/editors/glimmer/Makefile b/editors/glimmer/Makefile
index d0d7f8d5fca..2b6eab24ff4 100644
--- a/editors/glimmer/Makefile
+++ b/editors/glimmer/Makefile
@@ -20,10 +20,14 @@ USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+PYTHON_LIBS= -lutil -lreadline -lcrypt -lpython
+.if exists(/usr/lib/libcrypto.a)
+PYTHON_LIBS+= -lcrypto
+.endif
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
- s|-lpython|-lreadline -lcrypt -lpython|g ; \
+ s|-lpython|${PYTHON_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \