aboutsummaryrefslogtreecommitdiffstats
path: root/editors/glimmer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/glimmer/Makefile')
-rw-r--r--editors/glimmer/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/editors/glimmer/Makefile b/editors/glimmer/Makefile
index d0d7f8d5fca..2b6eab24ff4 100644
--- a/editors/glimmer/Makefile
+++ b/editors/glimmer/Makefile
@@ -20,10 +20,14 @@ USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+PYTHON_LIBS= -lutil -lreadline -lcrypt -lpython
+.if exists(/usr/lib/libcrypto.a)
+PYTHON_LIBS+= -lcrypto
+.endif
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
- s|-lpython|-lreadline -lcrypt -lpython|g ; \
+ s|-lpython|${PYTHON_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \