aboutsummaryrefslogtreecommitdiffstats
path: root/editors/openoffice.org-1.0
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-08-17 18:48:18 +0800
committermbr <mbr@FreeBSD.org>2002-08-17 18:48:18 +0800
commitb0edbc301b40d74e68b437419d1075c84f32d5c3 (patch)
tree8912323071ad0905772d0cbf8fc5a294ac9331b3 /editors/openoffice.org-1.0
parent12623f4c416e2ab6c5af57469059c76495dfe1ff (diff)
downloadfreebsd-ports-graphics-b0edbc301b40d74e68b437419d1075c84f32d5c3.tar.gz
freebsd-ports-graphics-b0edbc301b40d74e68b437419d1075c84f32d5c3.tar.zst
freebsd-ports-graphics-b0edbc301b40d74e68b437419d1075c84f32d5c3.zip
Respect CFLAGS and USE_GCC for mozilla build. Needed
to build mozilla with the same gcc as OO.org
Diffstat (limited to 'editors/openoffice.org-1.0')
-rw-r--r--editors/openoffice.org-1.0/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 393128b9808..284eaaa6ed7 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -330,7 +330,11 @@ mozilla:
-e 's|--enable-strip||' \
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
- @cd ${WRKDIR}/mozilla && ${MAKE} build
+.if defined(USE_GCC)
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@${WRKDIR}/zipmoz.sh ${WRKDIR}/mozilla/work/mozilla/dist FREEBSDGCCI ${WRKDIR}