aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-10-28 23:28:27 +0800
committerchinsan <chinsan@FreeBSD.org>2008-10-28 23:28:27 +0800
commit6acd3a6e8149794cf1b90de80ddc395b4f26dd35 (patch)
treeabf505cfbf04652b6c7172bd34caefdcfc7b4672 /graphics
parenta65b1722481e0dca0353f0caf7039b9b2fc4d811 (diff)
downloadfreebsd-ports-graphics-6acd3a6e8149794cf1b90de80ddc395b4f26dd35.tar.gz
freebsd-ports-graphics-6acd3a6e8149794cf1b90de80ddc395b4f26dd35.tar.zst
freebsd-ports-graphics-6acd3a6e8149794cf1b90de80ddc395b4f26dd35.zip
- Add Knob for CUPS support
PR: ports/128366 Submitted by: Carlos Santos <unixmania at gmail _dot_ com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/epdfview/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index 746ecc6aab3..ea23dfe99ea 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= epdfview
PORTVERSION= 0.1.6
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics print gnome
MASTER_SITES= http://trac.emma-soft.com/epdfview/chrome/site/releases/ \
LOCAL/chinsan
@@ -27,6 +27,18 @@ USE_GNOME= gtk20 intlhack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+OPTIONS= CUPS "Use cups printing system" off \
+ NLS "Native language support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CUPS)
+CONFIGURE_ARGS+=--with-cups
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+.else
+CONFIGURE_ARGS+=--without-cups
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -43,4 +55,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/data/${PORTNAME}.desktop ${PREFIX}/share/applications/
@-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>