aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/epdfview/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index 746ecc6aab3..ea23dfe99ea 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= epdfview
PORTVERSION= 0.1.6
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics print gnome
MASTER_SITES= http://trac.emma-soft.com/epdfview/chrome/site/releases/ \
LOCAL/chinsan
@@ -27,6 +27,18 @@ USE_GNOME= gtk20 intlhack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+OPTIONS= CUPS "Use cups printing system" off \
+ NLS "Native language support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CUPS)
+CONFIGURE_ARGS+=--with-cups
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+.else
+CONFIGURE_ARGS+=--without-cups
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -43,4 +55,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/data/${PORTNAME}.desktop ${PREFIX}/share/applications/
@-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>