aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-07-09 15:40:56 +0800
committerperky <perky@FreeBSD.org>2003-07-09 15:40:56 +0800
commitbafc96909db22a1537ce66c565825c7a3ca8a2cf (patch)
tree5ad0250b8208a83e885d02ec04c7a0001b9b7dd4 /lang/python
parent645881e3b635888e9a690675c6daa48d63cd7320 (diff)
downloadfreebsd-ports-graphics-bafc96909db22a1537ce66c565825c7a3ca8a2cf.tar.gz
freebsd-ports-graphics-bafc96909db22a1537ce66c565825c7a3ca8a2cf.tar.zst
freebsd-ports-graphics-bafc96909db22a1537ce66c565825c7a3ca8a2cf.zip
Set per-thread stack size to 0x20000 (default) or 0x100000
(WITH_HUGE_STACK_SIZE=yes). This will enable python2.2 to run Zope and its products. Requested by: dwhite Reviewed by: dwhite
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 9452e873bea..31dfb94e9e8 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -35,6 +35,11 @@ PYTHON_NO_DEPENDS= yes
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
+.if !defined(WANT_HUGE_STACK_SIZE)
+CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
+.else
+CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
+.endif
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads