aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-18 18:39:04 +0800
committermarino <marino@FreeBSD.org>2015-03-18 18:39:04 +0800
commit6ae3328b62a3a27ee7490246b48e057e7b5de734 (patch)
tree7b2c486b406069a4064684b7c8774dfb76572e0c /lang
parent2a7cedb5dc497c03f12559f8e886da8bf0bf863e (diff)
downloadfreebsd-ports-graphics-6ae3328b62a3a27ee7490246b48e057e7b5de734.tar.gz
freebsd-ports-graphics-6ae3328b62a3a27ee7490246b48e057e7b5de734.tar.zst
freebsd-ports-graphics-6ae3328b62a3a27ee7490246b48e057e7b5de734.zip
lang/gcc5: Support DragonFly's gcc50 base compiler in specific scenario
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc5/Makefile.DragonFly8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/gcc5/Makefile.DragonFly b/lang/gcc5/Makefile.DragonFly
index 78bc57da0ad..5342d32b33f 100644
--- a/lang/gcc5/Makefile.DragonFly
+++ b/lang/gcc5/Makefile.DragonFly
@@ -1,3 +1,11 @@
# $FreeBSD$
OPTIONS_EXCLUDE= JAVA
+
+# The following modification to CXXFLAGS is needed in the case of DragonFly
+# 4.1+ building lang/gcc5 with the gcc50 base compiler when the system
+# libraries were built by the gcc47 base compiler. The sys.mk file
+# automatically adds -D_GLIBCXX_USE_CXX11_ABI=0 to CXXFLAGS in that case,
+# which will break the build.
+
+CXXFLAGS:= ${CXXFLAGS:N-D_GLIBCXX_USE_CXX11_ABI*}