aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc5/Makefile.DragonFly8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/gcc5/Makefile.DragonFly b/lang/gcc5/Makefile.DragonFly
index 78bc57da0ad..5342d32b33f 100644
--- a/lang/gcc5/Makefile.DragonFly
+++ b/lang/gcc5/Makefile.DragonFly
@@ -1,3 +1,11 @@
# $FreeBSD$
OPTIONS_EXCLUDE= JAVA
+
+# The following modification to CXXFLAGS is needed in the case of DragonFly
+# 4.1+ building lang/gcc5 with the gcc50 base compiler when the system
+# libraries were built by the gcc47 base compiler. The sys.mk file
+# automatically adds -D_GLIBCXX_USE_CXX11_ABI=0 to CXXFLAGS in that case,
+# which will break the build.
+
+CXXFLAGS:= ${CXXFLAGS:N-D_GLIBCXX_USE_CXX11_ABI*}