aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-03-08 15:32:27 +0800
committerale <ale@FreeBSD.org>2007-03-08 15:32:27 +0800
commit7934292f0c4b71262d66bdbac8b7ee8b6043d244 (patch)
tree10ec2f3cc5545a2a562d24e9f0b9cd7bb31c0778 /lang
parent775c06a47dc2f39595973e8c8c006f5f8c6dd099 (diff)
downloadfreebsd-ports-graphics-7934292f0c4b71262d66bdbac8b7ee8b6043d244.tar.gz
freebsd-ports-graphics-7934292f0c4b71262d66bdbac8b7ee8b6043d244.tar.zst
freebsd-ports-graphics-7934292f0c4b71262d66bdbac8b7ee8b6043d244.zip
Add spl dependency to pdo, mysqli and sqlite extensions.
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext9
-rw-r--r--lang/php53/Makefile.ext9
2 files changed, 18 insertions, 0 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 7974a05a816..ef351bb664c 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -65,6 +65,9 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -198,6 +201,9 @@ CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 41
BROKEN_WITH_MYSQL= 323 40
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "ncurses"
@@ -395,6 +401,9 @@ USE_PHP= session
USE_PHP_BUILD= yes
PHP_HEADER_DIRS=libsqlite/src
+USE_PHP= spl
+USE_PHP_BUILD= yes
+
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 7974a05a816..ef351bb664c 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -65,6 +65,9 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -198,6 +201,9 @@ CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 41
BROKEN_WITH_MYSQL= 323 40
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "ncurses"
@@ -395,6 +401,9 @@ USE_PHP= session
USE_PHP_BUILD= yes
PHP_HEADER_DIRS=libsqlite/src
+USE_PHP= spl
+USE_PHP_BUILD= yes
+
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif