aboutsummaryrefslogtreecommitdiffstats
path: root/mail/nmh
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>1998-01-06 03:11:14 +0800
committermarkm <markm@FreeBSD.org>1998-01-06 03:11:14 +0800
commit3d32523f9add10cfda227cacbb9bd9827445911a (patch)
treef21cc32bcaae7f55f3e1e26a7cf9075012ececa4 /mail/nmh
parenteab52ce2db3af433512016618105453bf70c15f1 (diff)
downloadfreebsd-ports-graphics-3d32523f9add10cfda227cacbb9bd9827445911a.tar.gz
freebsd-ports-graphics-3d32523f9add10cfda227cacbb9bd9827445911a.tar.zst
freebsd-ports-graphics-3d32523f9add10cfda227cacbb9bd9827445911a.zip
Update to version 0.19.
(lots of bug fixes, plus the port's locking is fixed, and inc will honour a mode 775 /var/mail). Also pacify portlint. Submitted by: Scott Blachowicz (partially)
Diffstat (limited to 'mail/nmh')
-rw-r--r--mail/nmh/Makefile16
-rw-r--r--mail/nmh/distinfo2
-rw-r--r--mail/nmh/files/patch-aa19
-rw-r--r--mail/nmh/files/patch-ab107
-rw-r--r--mail/nmh/files/patch-ac37
-rw-r--r--mail/nmh/pkg-install2
-rw-r--r--mail/nmh/pkg-plist1
7 files changed, 106 insertions, 78 deletions
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index f85cf9fd5b0..a46d9c2f7fc 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -1,20 +1,20 @@
# New ports collection makefile for: nmh
-# Version required: 0.18
+# Version required: 0.19
# Date created: 26 July 1997
# Whom: Scott Blachowicz <Scott.Blachowicz@seaslug.org>
#
-# $Id: Makefile,v 1.2 1997/08/04 06:51:28 markm Exp $
+# $Id: Makefile,v 1.3 1997/12/28 12:37:37 markm Exp $
#
-DISTNAME= nmh-0.18
+DISTNAME= nmh-0.19
CATEGORIES= mail
MASTER_SITES= ftp://ftp.math.gatech.edu/pub/nmh/
MAINTAINER= Scott.Blachowicz@seaslug.org
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --libexecdir=$(PREFIX)/libexec/nmh \
- --sysconfdir=$(PREFIX)/etc/nmh --enable-nmh-pop
+CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/nmh \
+ --sysconfdir=${PREFIX}/etc/nmh --enable-nmh-pop
MAN1= ali.1 anno.1 burst.1 comp.1 dist.1 flist.1 folder.1 forw.1 inc.1 \
mark.1 mh-chart.1 mhl.1 mhmail.1 mhn.1 mhparam.1 mhpath.1 msgchk.1 msh.1 \
@@ -30,9 +30,11 @@ MAN8= ap.8 conflict.8 dp.8 fmtdump.8 install-mh.8 mh-mts.8 post.8
# Since we patch the autoconf files as well as their outputs, avoid attempt
# to regenerate header input files with 'autoheader' by Makefile.
post-patch:
- ${ECHO} > ${WRKSRC}/stamp-h.in
+ @${TOUCH} ${WRKSRC}/stamp-h.in
post-install:
- @PKG_PREFIX='${PREFIX}' ./pkg/INSTALL
+ @PKG_PREFIX='${PREFIX}' ${PKGDIR}/INSTALL
+ chgrp mail ${PREFIX}/bin/inc
+ chmod g+s ${PREFIX}/bin/inc
.include <bsd.port.mk>
diff --git a/mail/nmh/distinfo b/mail/nmh/distinfo
index cab499a5d7e..3a0f94ae269 100644
--- a/mail/nmh/distinfo
+++ b/mail/nmh/distinfo
@@ -1 +1 @@
-MD5 (nmh-0.18.tar.gz) = b989391b0a181bc2586525d09840512f
+MD5 (nmh-0.19.tar.gz) = ca5ffcd38c56b4311b56f04bf55fc18b
diff --git a/mail/nmh/files/patch-aa b/mail/nmh/files/patch-aa
index 10205d9ff33..da4e1f9c101 100644
--- a/mail/nmh/files/patch-aa
+++ b/mail/nmh/files/patch-aa
@@ -1,5 +1,5 @@
---- ../nmh-0.18.ORIG/acconfig.h Mon Dec 1 07:52:31 1997
-+++ acconfig.h Sun Dec 28 14:22:34 1997
+--- ../nmh-0.19.ORIG/acconfig.h Mon Dec 1 07:52:31 1997
++++ acconfig.h Mon Jan 5 20:03:43 1998
@@ -36,9 +36,9 @@
* OpenBSD 2.x
* BSD/OS 2.x
@@ -7,12 +7,21 @@
-/* #define BIND 1 */
-/* #define BSD42 1 */
-/* #define BSD44 1 */
-+#define BIND 1 /**/
-+#define BSD42 1 /**/
-+#define BSD44 1 /**/
++#define BIND 1
++#define BSD42 1
++#define BSD44 1
/*
* SCO 4.x
+@@ -58,7 +58,7 @@
+ * group and add the setgid bit to `inc' manually after
+ * installation.
+ */
+-/* #define MAILGROUP 1 */
++#define MAILGROUP 1
+
+ /*
+ * Turn on locale (setlocale) support
@@ -71,10 +71,10 @@
* other programs which may modify your maildrops.
* Currently you can only use one type.
diff --git a/mail/nmh/files/patch-ab b/mail/nmh/files/patch-ab
index 5ad654517ab..e88ff7a0946 100644
--- a/mail/nmh/files/patch-ab
+++ b/mail/nmh/files/patch-ab
@@ -1,61 +1,39 @@
-diff -udr ../nmh-0.18.ORIG/Makefile.in ./Makefile.in
---- ../nmh-0.18.ORIG/Makefile.in Sat Jul 26 06:38:35 1997
-+++ ./Makefile.in Sun Dec 28 12:23:55 1997
-@@ -66,6 +66,7 @@
+diff -udr ../nmh-0.19.ORIG/Makefile.in ./Makefile.in
+--- ../nmh-0.19.ORIG/Makefile.in Sat Jul 26 06:38:35 1997
++++ ./Makefile.in Mon Jan 5 20:29:42 1998
+@@ -26,7 +26,7 @@
+ bindir = @bindir@
+
+ # location of support binaries and scripts
+-libdir = @libdir@
++libexecdir = @libexecdir@
+
+ # location of nmh configuration and formats files
+ etcdir = @sysconfdir@
+@@ -59,12 +59,13 @@
+ MAKEDEFS = CC='$(CC)' CPPFLAGS='$(CPPFLAGS)' DEFS='$(DEFS)' \
+ CFLAGS='$(CFLAGS)' LDFLAGS='$(LDFLAGS)' LIBS='$(LIBS)' \
+ prefix='$(prefix)' exec_prefix='$(exec_prefix)' bindir='$(bindir)' \
+-etcdir='$(etcdir)' libdir='$(libdir)' mandir='$(mandir)' \
++etcdir='$(etcdir)' libexecdir='$(libexecdir)' mandir='$(mandir)' \
+ mailspool='$(mailspool)' sendmailpath='$(sendmailpath)' \
+ default_editor='$(default_editor)' default_pager='$(default_pager)'
+
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
- INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_DATA = @INSTALL_DATA@
.SUFFIXES:
-
-diff -udr ../nmh-0.18.ORIG/configure ./configure
---- ../nmh-0.18.ORIG/configure Thu Dec 18 03:31:57 1997
-+++ ./configure Sun Dec 28 12:23:55 1997
-@@ -968,6 +968,8 @@
- test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
-
- test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
-+
-+test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 555'
- # Extract the first word of "ranlib", so it can be a program name with args.
- set dummy ranlib; ac_word=$2
- echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-@@ -3450,6 +3452,7 @@
- s%@SET_MAKE@%$SET_MAKE%g
- s%@INSTALL_PROGRAM@%$INSTALL_PROGRAM%g
- s%@INSTALL_DATA@%$INSTALL_DATA%g
-+s%@INSTALL_SCRIPT@%$INSTALL_SCRIPT%g
- s%@RANLIB@%$RANLIB%g
- s%@AWK@%$AWK%g
- s%@LEX@%$LEX%g
-@@ -3692,7 +3695,7 @@
-
- eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
- eval "nmhsysconf=${sysconfdir}"; eval "nmhsysconf2=${nmhsysconf}"
--eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
-+eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
- eval "nmhman=${mandir}"
-
- echo "
-@@ -3705,7 +3708,7 @@
- linker flags : ${LDFLAGS}
- source code location : ${srcdir}
- binary install path : ${nmhbin2}
--libary install path : ${nmhlib2}
-+libexec install path : ${nmhlib2}
- config files install path : ${nmhsysconf2}
- man page install path : ${nmhman}"
- echo ""
-diff -udr ../nmh-0.18.ORIG/configure.in ./configure.in
---- ../nmh-0.18.ORIG/configure.in Wed Dec 17 01:18:12 1997
-+++ ./configure.in Sun Dec 28 12:23:55 1997
+diff -udr ../nmh-0.19.ORIG/configure.in ./configure.in
+--- ../nmh-0.19.ORIG/configure.in Wed Dec 17 01:18:12 1997
++++ ./configure.in Mon Jan 5 20:20:08 1998
@@ -400,7 +400,7 @@
eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
eval "nmhsysconf=${sysconfdir}"; eval "nmhsysconf2=${nmhsysconf}"
-eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
-+eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
++eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
eval "nmhman=${mandir}"
echo "
@@ -68,24 +46,24 @@ diff -udr ../nmh-0.18.ORIG/configure.in ./configure.in
config files install path : ${nmhsysconf2}
man page install path : ${nmhman}"
echo ""
-diff -udr ../nmh-0.18.ORIG/support/general/Makefile.in ./support/general/Makefile.in
---- ../nmh-0.18.ORIG/support/general/Makefile.in Sat Jul 26 06:40:55 1997
-+++ ./support/general/Makefile.in Sun Dec 28 12:23:55 1997
-@@ -14,11 +14,13 @@
+diff -udr ../nmh-0.19.ORIG/support/general/Makefile.in ./support/general/Makefile.in
+--- ../nmh-0.19.ORIG/support/general/Makefile.in Tue Dec 23 14:05:49 1997
++++ ./support/general/Makefile.in Mon Jan 5 20:22:42 1998
+@@ -13,11 +13,12 @@
+ prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
- libdir = @libdir@
+-libdir = @libdir@
+libexecdir = @libexecdir@
etcdir = @sysconfdir@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
- INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_DATA = @INSTALL_DATA@
# Path to search for programs to display content
- # for mhn. Used to create mhn.defaults
-@@ -77,9 +79,9 @@
+@@ -77,9 +78,9 @@
done
install-scripts:
@@ -97,7 +75,7 @@ diff -udr ../nmh-0.18.ORIG/support/general/Makefile.in ./support/general/Makefil
done
uninstall: uninstall-files uninstall-scripts
-@@ -91,7 +93,7 @@
+@@ -91,7 +92,7 @@
uninstall-scripts:
for script in $(SCRIPTS); do \
@@ -106,18 +84,19 @@ diff -udr ../nmh-0.18.ORIG/support/general/Makefile.in ./support/general/Makefil
done
# ========== DEPENDENCIES FOR CLEANUP ==========
-diff -udr ../nmh-0.18.ORIG/uip/Makefile.in ./uip/Makefile.in
---- ../nmh-0.18.ORIG/uip/Makefile.in Thu Dec 4 02:16:04 1997
-+++ ./uip/Makefile.in Sun Dec 28 12:29:13 1997
-@@ -14,6 +14,7 @@
+diff -udr ../nmh-0.19.ORIG/uip/Makefile.in ./uip/Makefile.in
+--- ../nmh-0.19.ORIG/uip/Makefile.in Thu Dec 4 02:16:04 1997
++++ ./uip/Makefile.in Mon Jan 5 20:29:16 1998
+@@ -13,7 +13,7 @@
+ prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
- libdir = @libdir@
+-libdir = @libdir@
+libexecdir = @libexecdir@
etcdir = @sysconfdir@
CC = @CC@
-@@ -235,9 +236,9 @@
+@@ -235,9 +235,9 @@
# install misc support binaries
install-misc:
@@ -129,7 +108,7 @@ diff -udr ../nmh-0.18.ORIG/uip/Makefile.in ./uip/Makefile.in
done
uninstall:
-@@ -248,7 +249,7 @@
+@@ -248,7 +248,7 @@
rm -f $(bindir)/$$lcmd; \
done
for misc in $(MISC); do \
diff --git a/mail/nmh/files/patch-ac b/mail/nmh/files/patch-ac
new file mode 100644
index 00000000000..cddb57397fe
--- /dev/null
+++ b/mail/nmh/files/patch-ac
@@ -0,0 +1,37 @@
+--- ../nmh-0.19.ORIG/configure Sun Dec 28 12:19:27 1997
++++ configure Mon Jan 5 20:34:08 1998
+@@ -967,6 +967,8 @@
+ # It thinks the first close brace ends the variable substitution.
+ test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
+
++test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 755'
++
+ test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
+ # Extract the first word of "ranlib", so it can be a program name with args.
+ set dummy ranlib; ac_word=$2
+@@ -3449,6 +3451,7 @@
+ s%@CC@%$CC%g
+ s%@SET_MAKE@%$SET_MAKE%g
+ s%@INSTALL_PROGRAM@%$INSTALL_PROGRAM%g
++s%@INSTALL_SCRIPT@%$INSTALL_SCRIPT%g
+ s%@INSTALL_DATA@%$INSTALL_DATA%g
+ s%@RANLIB@%$RANLIB%g
+ s%@AWK@%$AWK%g
+@@ -3692,7 +3695,7 @@
+
+ eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
+ eval "nmhsysconf=${sysconfdir}"; eval "nmhsysconf2=${nmhsysconf}"
+-eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
++eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
+ eval "nmhman=${mandir}"
+
+ echo "
+@@ -3705,7 +3708,7 @@
+ linker flags : ${LDFLAGS}
+ source code location : ${srcdir}
+ binary install path : ${nmhbin2}
+-libary install path : ${nmhlib2}
++libexec install path : ${nmhlib2}
+ config files install path : ${nmhsysconf2}
+ man page install path : ${nmhman}"
+ echo ""
diff --git a/mail/nmh/pkg-install b/mail/nmh/pkg-install
index b691411eeaf..f03793f1d2a 100644
--- a/mail/nmh/pkg-install
+++ b/mail/nmh/pkg-install
@@ -1,4 +1,4 @@
-#! /bin/sh
+#!/bin/sh
case "$2" in
""|POST-INSTALL) cat <<EOF
diff --git a/mail/nmh/pkg-plist b/mail/nmh/pkg-plist
index 24d9e261a73..2dbea3e4251 100644
--- a/mail/nmh/pkg-plist
+++ b/mail/nmh/pkg-plist
@@ -41,6 +41,7 @@ etc/nmh/mhl.digest
etc/nmh/mhl.format
etc/nmh/mhl.forward
etc/nmh/mhl.headers
+etc/nmh/mhl.reply
etc/nmh/mhn.defaults
etc/nmh/mts.conf
etc/nmh/rcvdistcomps
2006-10-09 03:20:28 +0800'>2006-10-091-0/+131 * . Use a mutex to make the resolver functions thread safe on FreeBSD 4.xglewis2006-10-091-0/+110 * Tune the port a little finer:mi2006-10-083-2/+18 * - update to 1.4 (a bugs fix release)sem2006-10-082-6/+5 * Make fetchable again by updating to 1.14.0.lawrance2006-10-082-4/+4 * Upgrade from 1.7.1 to 3.1.0, thanks largely to the diffs supplied by ijliaomi2006-10-074-383/+86 * . Update distinfo for re-rolled amd64 tarballs. Fixes problem with noglewis2006-10-062-6/+6 * Update to 1.34 release.ale2006-10-052-4/+4 * . Update to 1.5.0_07-b01.glewis2006-10-034-20/+20 * - Update to 1.0.3.stefan2006-09-282-5/+5 * Update to 1.2.0.stefan2006-09-282-6/+6 * Upgrade to 5.2.des2006-09-263-1164/+10 * . Cross reference manvm(1).glewis2006-09-201-0/+1 * amd64 distinfo does not exist, restrict to i386kris2006-09-171-1/+1 * . Diablo is no longer restricted to i386, so allow it to be a possibleglewis2006-09-142-8/+4 * . Note that FreeBSD 5.x/amd64 isn't support (6.x/amd64 is). [1]glewis2006-09-112-6/+6 * . Prevent problems opening RandomAccessFile with "rws" as the mode byglewis2006-09-094-2/+44 * Update to 4.2.1vs2006-09-082-10/+10 * Remove stale files.olgeni2006-09-074-2/+8 * Remove stale files and use JAVA_HOME.olgeni2006-09-076-3/+24 * Replace NO_CDROM and NO_PACKAGE with RESTRICTEDkris2006-09-043-6/+3 * Allow package buildskris2006-09-031-1/+1 * Allow package buildskris2006-09-0314-14/+14 * NO_CDROM is superfluous herekris2006-09-031-2/+1 * NO_CDROM and NO_PACKAGE are superfluouskris2006-09-031-2/+0 * NO_PACKAGE and NO_CDROM are superfluouskris2006-09-031-3/+1 * NO_CDROM and NO_PACKAGE are not appropriate; use RESTRICTED here insteadkris2006-09-031-2/+1 * NO_CDROM and NO_PACKAGE are superfluouskris2006-09-031-2/+0 * Schedule these forbidden ports for termination on 2006-12-01kris2006-09-033-0/+6 * Schedule these broken ports for termination on 2006-12-01kris2006-09-032-0/+4 * BROKEN: Size mismatchkris2006-09-011-0/+2 * Fix the build by copying needed JAR files at post-extract stagehq2006-08-231-1/+6 * * Add registervm and unregistervm [1]maho2006-08-172-8/+12 * Make portlint(1) happylioux2006-08-161-1/+1 * New port eclipse-jad version 3.1: Jad Java decompiler plugin forlioux2006-08-164-0/+47 * - s,INSTALLS_SHLIB,USE_LDCONFIG,gclsung2006-08-152-2/+2 * - Update to 1.1.8.stefan2006-08-134-1415/+642 * Update java/castor from 1.0.1 to 1.0.2 (latest upstream stable release)itetcu2006-08-112-4/+4 * Unbreak, port fetches just fine.tmclaugh2006-08-091-2/+0 * Remove java/fastjar. We already have as archivers/fastjar...maho2006-08-081-1/+0 * Remve java/fastjar port. we already have as archivers/fastjar...maho2006-08-084-36/+0 * Add fastjar. FastJar is an free and fast alternative ofmaho2006-08-085-0/+37 * Add files in pkg-plist.maho2006-08-072-1/+3 * Add sun.boot.class.path as default bootclasspath for gcj,maho2006-08-043-1/+34 * Add gcj41, gij41 etc as gcj, gij, etc respectively,maho2006-08-032-1/+9 * Use gcj instead of ecj, and bump portrevision.maho2006-08-032-10/+3 * The JDT Core Batch Compiler (stand alone verison of the Eclipsemaho2006-08-038-0/+194 * . Fix a segfault caused by fonts with illegal glyph names or glyph namesglewis2006-08-024-2/+36 * . Space out the arguments to OPTIONS with tabs rather than spaces.glewis2006-08-022-8/+14 * Fix java.c Now we can invoke gij by typing java.maho2006-07-292-0/+13 * Add java-gcj-compat. With scripts and symlinks, now gcj installation actsmaho2006-07-297-0/+106 * . Take account of the MFC or the *_r functions to RELENG_6.glewis2006-07-201-18/+32 * Update to 1.33 release:ale2006-07-194-38/+24 * . Bump PORTREVISION.glewis2006-07-192-2/+2 * . On amd64 the plugin should look for the Server VM, since there is noglewis2006-07-196-0/+90 * . Properly deal with error cases in transferTo0().glewis2006-07-192-0/+76 * . Convert to using OPTIONS.glewis2006-07-194-96/+96 * Mark broken: unfetchable.linimon2006-07-161-0/+2 * This plug-in for IBM's Eclipse platform integrates features from theitetcu2006-07-125-0/+58 * Remove zero-sized files.erwin2006-07-111-0/+0 * . The new Diablo JDK release doesn't need -XX:+UseMembar.glewis2006-07-061-2/+0 * . Update to 1.5.0_07-b00.glewis2006-07-066-154/+151 * . Update to 1.5.0_07-b00.glewis2006-07-066-1307/+1077 * . Update to 1.13.6.glewis2006-06-272-4/+4 * . Update to 0.51glewis2006-06-242-6/+4 * Update to 1.0.1.kib2006-06-242-4/+4 * Update to 1.0.1hq2006-06-192-4/+4 * . Bump PORTREVISION for the last three changes.glewis2006-06-172-0/+2 * . Work around a thread cache problem that caused javah to crash with anglewis2006-06-172-0/+32 * . Filter out corrupt environment variables with no name.glewis2006-06-172-0/+44 * . Increase the default stack size on amd64.glewis2006-06-172-0/+26 * . Try to fix the build on FreeBSD-CURRENT, which now defines gethostent_rglewis2006-06-171-0/+83 * . Update to 1.13.5.glewis2006-06-153-5/+5 * . Update to 3.0.2.glewis2006-06-1514-652/+656 * . Update to 1.5.0_07.glewis2006-06-146-10/+20 * . Update to 1.4.2_12.glewis2006-06-143-5/+15 * . Update to 4.0.4.glewis2006-06-146-22/+24 * - Update to bsd.java.mk 2.0hq2006-06-132-169/+22 * - Update to bsd.java.mk 2.0hq2006-06-132-4/+4 * . Add manvm(1). This is similar to javavm(1), but allows one to view theglewis2006-06-134-175/+362 * Defining $MASTER_SITES for your infoormation may confusing distfile survey.kuriyama2006-06-091-1/+1 * . Introduce the JAVAVM_DRYRUN variable. If this is set, then javavm willglewis2006-06-093-6/+50 * Update to 1.3.stefan2006-06-093-47/+7 * . Revert previous commit. It was my recollection that javac needed theglewis2006-06-082-2/+1 * Update to 0.51-pre1stefan2006-06-083-11/+6 * . Diablo's javac also needs -XX:+UseMembar.glewis2006-06-072-1/+2 * . Restrict the -XX:+UseMembar option to the java(1) programme to prevent itglewis2006-06-062-1/+2 * . ! -z -> -n for clarity.glewis2006-06-041-25/+25 * . Allow the setting up of command line options to be passed to theglewis2006-06-048-13/+236 * - Update to bsd.java.mk 2.0hq2006-06-023-6/+7 * Update to 4.1.2hq2006-05-292-10/+10 * - Renamed port graphics/libart_lgpl2 -> graphics/libart_lgplpav2006-05-281-1/+1 * Add a note for BROKEN linemaho2006-05-281-1/+1 * - Update to bsd.java.mk 2.0hq2006-05-242-6/+7 * Distfile rerolled without LICENSE file.ale2006-05-243-11/+9 * - Update to bsd.java.mk 2.0hq2006-05-244-14/+17 * Upgrade from 0.50.1 to 0.50.2mi2006-05-232-4/+4 * BROKEN on !i386: Broken dependencykris2006-05-221-1/+7 * Solve JDK 1.5 incompatibility.stefan2006-05-212-2/+33 * - Update to 3.8.2hq2006-05-202-5/+4 * JDE's stable code does not properly detect the version of newer versions of C...vs2006-05-172-0/+49 * Update to 3.2hq2006-05-162-6/+4 * - Update to 1.1hq2006-05-162-40/+15 * - Update to 0.90itetcu2006-05-143-26/+174 * Remove whitespace from line endings in pkg-plist files.vd2006-05-121-11/+11 * - Update to 0.50.1stefan2006-05-114-33/+29 * Update to 3.0.1 release.ale2006-05-102-4/+4 * Chase gmp library and bump PORTREVISION.ale2006-05-10