aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kdenlive
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-11-02 10:40:35 +0800
committeravilla <avilla@FreeBSD.org>2011-11-02 10:40:35 +0800
commit45c13797edb0b1b0ea8afd6ebe6dd08f656e7b2b (patch)
tree846572b215f6850cbe5978a280553d386c4b4f72 /multimedia/kdenlive
parent7317d6ec6e915e38b1b1f3935f1b0d51b516e581 (diff)
downloadfreebsd-ports-graphics-45c13797edb0b1b0ea8afd6ebe6dd08f656e7b2b.tar.gz
freebsd-ports-graphics-45c13797edb0b1b0ea8afd6ebe6dd08f656e7b2b.tar.zst
freebsd-ports-graphics-45c13797edb0b1b0ea8afd6ebe6dd08f656e7b2b.zip
- Update to 0.8.2.
Diffstat (limited to 'multimedia/kdenlive')
-rw-r--r--multimedia/kdenlive/Makefile40
-rw-r--r--multimedia/kdenlive/distinfo4
-rw-r--r--multimedia/kdenlive/files/patch-src__CMakeLists.txt45
-rw-r--r--multimedia/kdenlive/pkg-descr10
-rw-r--r--multimedia/kdenlive/pkg-plist98
5 files changed, 118 insertions, 79 deletions
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index fc66ffd7763..0108e80c71b 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -5,60 +5,66 @@
# $FreeBSD$
PORTNAME= kdenlive
-PORTVERSION= 0.7.8
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= multimedia kde
MASTER_SITES= SF
MAINTAINER= avilla@FreeBSD.org
-COMMENT= A professional quality non-linear video editing suite for KDE
+COMMENT= KDE professional quality non-linear video editing suite
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= mlt.3:${PORTSDIR}/multimedia/mlt
+LIB_DEPENDS= mlt.4:${PORTSDIR}/multimedia/mlt \
+ qjson.0:${PORTSDIR}/devel/qjson
USE_GETTEXT= yes
-USE_KDE4= automoc4 kdehier kdelibs kdeprefix sharedmime
+USE_KDE4= kdehier kdelibs kdeprefix automoc4 sharedmime
USE_QT_VER= 4
-QT_COMPONENTS= dbus gui network svg xml \
+QT_COMPONENTS= dbus gui network opengl script svg xml \
moc_build qmake_build rcc_build uic_build
-MAKE_JOBS_SAFE= yes
+USE_XORG= x11
USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
MAN1= kdenlive.1 kdenlive_render.1
OPTIONS= DVD "DVD creation with cdrtools and dvdauthor" on \
- FREI0R "Frei0r plugins" on \
+ FREI0R "frei0r plugins" on \
LADSPA "LADSPA plugins" on \
- SCREENGRAB "Screen capture with recordMyDesktop" on
+ SCREENGRAB "Screen capture with recordMyDesktop" on \
+ XINE "DVD preview with xine" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef(WITH_DVD)
+.ifndef(WITHOUT_DVD)
USE_CDRTOOLS= yes
RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor
.endif
-.ifdef(WITH_FREI0R)
+.ifndef(WITHOUT_FREI0R)
RUN_DEPENDS+= frei0r-plugins>=0:${PORTSDIR}/graphics/frei0r-plugins
.endif
-.ifdef(WITH_LADSPA)
+.ifndef(WITHOUT_LADSPA)
RUN_DEPENDS+= swhplugins>=0:${PORTSDIR}/audio/swhplugins
.endif
-.ifdef(WITH_SCREENGRAB)
+.ifndef(WITHOUT_SCREENGRAB)
RUN_DEPENDS+= recordmydesktop:${PORTSDIR}/multimedia/recordmydesktop
.endif
+.ifndef(WITHOUT_XINE)
+RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
+.endif
+
post-patch:
- @${REINPLACE_CMD} -E -e '/${PORTNAME}.(menu|xpm)/d' \
+ ${REINPLACE_CMD} -E -e '/${PORTNAME}.(menu|xpm)/ d' \
${PATCH_WRKSRC}/data/CMakeLists.txt
- @${REINPLACE_CMD} -e '/^update_xdg_mimetypes/d; /SharedMimeInfo/d' \
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d' \
${PATCH_WRKSRC}/src/mimetypes/CMakeLists.txt
post-install:
@-update-mime-database ${PREFIX}/share/mime
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/kdenlive/distinfo b/multimedia/kdenlive/distinfo
index 3a7e58bfc0d..80fcb700f1a 100644
--- a/multimedia/kdenlive/distinfo
+++ b/multimedia/kdenlive/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kdenlive-0.7.8.tar.gz) = 7d57f455480b1657db2c12c61c5a20efe7e68fa54523fc6dc0abfd3920ac7c81
-SIZE (kdenlive-0.7.8.tar.gz) = 3232442
+SHA256 (kdenlive-0.8.2.tar.gz) = db3247b63c997371c898641590e9febe4ec89df8eb3f6e0b3a66b6f613d063d7
+SIZE (kdenlive-0.8.2.tar.gz) = 5113854
diff --git a/multimedia/kdenlive/files/patch-src__CMakeLists.txt b/multimedia/kdenlive/files/patch-src__CMakeLists.txt
deleted file mode 100644
index f651c84aa80..00000000000
--- a/multimedia/kdenlive/files/patch-src__CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
---- ./src/CMakeLists.txt.orig 2010-10-01 09:29:39.366437142 +0200
-+++ ./src/CMakeLists.txt 2010-10-01 09:32:48.832414261 +0200
-@@ -3,21 +3,6 @@
-
- macro_optional_find_package(Nepomuk)
-
--if (Nepomuk_FOUND)
-- INCLUDE_DIRECTORIES(NEPOMUK_INCLUDES )
-- set( optional_libs ${NEPOMUK_LIBRARIES} )
-- add_definitions(-DNEPOMUK)
--endif (Nepomuk_FOUND)
--
--if (Q_WS_X11)
-- include_directories (${X11_Xlib_INCLUDE_PATH} )
--endif (Q_WS_X11)
--
--if (APPLE)
-- find_package(OpenGL)
-- set(QT_USE_QTOPENGL TRUE)
--endif (APPLE)
--
- include_directories (
- ${KDE4_INCLUDE_DIR}
- ${KDE4_INCLUDE_DIR}/KDE
-@@ -38,7 +23,20 @@
- ${optional_libs}
- )
-
-+if (Nepomuk_FOUND)
-+ INCLUDE_DIRECTORIES(NEPOMUK_INCLUDES )
-+ set( optional_libs ${NEPOMUK_LIBRARIES} )
-+ add_definitions(-DNEPOMUK)
-+endif (Nepomuk_FOUND)
-+
-+if (Q_WS_X11)
-+ include_directories (${X11_Xlib_INCLUDE_PATH} )
-+endif (Q_WS_X11)
-
-+if (APPLE)
-+ find_package(OpenGL)
-+ set(QT_USE_QTOPENGL TRUE)
-+endif (APPLE)
-
- kde4_add_ui_files(kdenlive_UI
- widgets/timeline_ui.ui
diff --git a/multimedia/kdenlive/pkg-descr b/multimedia/kdenlive/pkg-descr
index 09e955e7145..37e010bcc34 100644
--- a/multimedia/kdenlive/pkg-descr
+++ b/multimedia/kdenlive/pkg-descr
@@ -1,7 +1,7 @@
-Kdenlive is a non-linear video editor for GNU/Linux, Mac OS X and FreeBSD,
-which supports DV, AVCHD (experimental support) and HDV editing. Kdenlive
-relies on several other open source projects, such as FFmpeg and the MLT
-video framework. It was designed to answer all needs, from basic video
-editing to semi-professional work.
+Kdenlive is a non-linear video editor for GNU/Linux, Mac OS X and
+FreeBSD, which supports DV, AVCHD (experimental support) and HDV
+editing. Kdenlive relies on several other open source projects, such
+as FFmpeg and the MLT video framework. It was designed to answer all
+needs, from basic video editing to semi-professional work.
WWW: http://www.kdenlive.org
diff --git a/multimedia/kdenlive/pkg-plist b/multimedia/kdenlive/pkg-plist
index a72f3b06c6e..5d4b3fc390e 100644
--- a/multimedia/kdenlive/pkg-plist
+++ b/multimedia/kdenlive/pkg-plist
@@ -8,6 +8,7 @@ share/apps/kdenlive/blacklisted_effects.txt
share/apps/kdenlive/blacklisted_transitions.txt
share/apps/kdenlive/effects/audiobalance.xml
share/apps/kdenlive/effects/audiopan.xml
+share/apps/kdenlive/effects/audiowave.xml
share/apps/kdenlive/effects/automask.xml
share/apps/kdenlive/effects/boxblur.xml
share/apps/kdenlive/effects/brightness.xml
@@ -16,6 +17,7 @@ share/apps/kdenlive/effects/charcoal.xml
share/apps/kdenlive/effects/chroma.xml
share/apps/kdenlive/effects/chroma_hold.xml
share/apps/kdenlive/effects/crop.xml
+share/apps/kdenlive/effects/dust.xml
share/apps/kdenlive/effects/fade_from_black.xml
share/apps/kdenlive/effects/fade_to_black.xml
share/apps/kdenlive/effects/fadein.xml
@@ -25,50 +27,74 @@ share/apps/kdenlive/effects/frei0r_alpha0ps.xml
share/apps/kdenlive/effects/frei0r_alphagrad.xml
share/apps/kdenlive/effects/frei0r_alphaspot.xml
share/apps/kdenlive/effects/frei0r_balanc0r.xml
+share/apps/kdenlive/effects/frei0r_baltan.xml
+share/apps/kdenlive/effects/frei0r_bezier_curves.xml
share/apps/kdenlive/effects/frei0r_brightness.xml
share/apps/kdenlive/effects/frei0r_c0rners.xml
+share/apps/kdenlive/effects/frei0r_cartoon.xml
+share/apps/kdenlive/effects/frei0r_cluster.xml
share/apps/kdenlive/effects/frei0r_coloradj_rgb.xml
share/apps/kdenlive/effects/frei0r_colordistance.xml
share/apps/kdenlive/effects/frei0r_contrast0r.xml
share/apps/kdenlive/effects/frei0r_curves.xml
+share/apps/kdenlive/effects/frei0r_d90stairsteppingfix.xml
share/apps/kdenlive/effects/frei0r_defish0r.xml
+share/apps/kdenlive/effects/frei0r_delay0r.xml
+share/apps/kdenlive/effects/frei0r_delaygrab.xml
share/apps/kdenlive/effects/frei0r_distort0r.xml
+share/apps/kdenlive/effects/frei0r_edgeglow.xml
+share/apps/kdenlive/effects/frei0r_equaliz0r.xml
+share/apps/kdenlive/effects/frei0r_facebl0r.xml
+share/apps/kdenlive/effects/frei0r_facedetect.xml
+share/apps/kdenlive/effects/frei0r_flippo.xml
share/apps/kdenlive/effects/frei0r_glow.xml
+share/apps/kdenlive/effects/frei0r_hqdn3d.xml
share/apps/kdenlive/effects/frei0r_hueshift0r.xml
share/apps/kdenlive/effects/frei0r_lenscorrection.xml
+share/apps/kdenlive/effects/frei0r_letterb0xed.xml
share/apps/kdenlive/effects/frei0r_levels.xml
+share/apps/kdenlive/effects/frei0r_lightgraffiti.xml
+share/apps/kdenlive/effects/frei0r_luminance.xml
+share/apps/kdenlive/effects/frei0r_mask0mate.xml
+share/apps/kdenlive/effects/frei0r_nervous.xml
+share/apps/kdenlive/effects/frei0r_nosync0r.xml
share/apps/kdenlive/effects/frei0r_pixeliz0r.xml
share/apps/kdenlive/effects/frei0r_pr0be.xml
share/apps/kdenlive/effects/frei0r_pr0file.xml
+share/apps/kdenlive/effects/frei0r_primaries.xml
+share/apps/kdenlive/effects/frei0r_rgbparade.xml
share/apps/kdenlive/effects/frei0r_saturat0r.xml
share/apps/kdenlive/effects/frei0r_scale0tilt.xml
+share/apps/kdenlive/effects/frei0r_scanline0r.xml
share/apps/kdenlive/effects/frei0r_select0r.xml
+share/apps/kdenlive/effects/frei0r_sharpness.xml
+share/apps/kdenlive/effects/frei0r_sobel.xml
share/apps/kdenlive/effects/frei0r_sopsat.xml
share/apps/kdenlive/effects/frei0r_squareblur.xml
+share/apps/kdenlive/effects/frei0r_tehroxx0r.xml
share/apps/kdenlive/effects/frei0r_three_point_balance.xml
+share/apps/kdenlive/effects/frei0r_threelay0r.xml
share/apps/kdenlive/effects/frei0r_threshold0r.xml
share/apps/kdenlive/effects/frei0r_tint0r.xml
+share/apps/kdenlive/effects/frei0r_twolay0r.xml
+share/apps/kdenlive/effects/frei0r_vectorscope.xml
share/apps/kdenlive/effects/frei0r_vertigo.xml
+share/apps/kdenlive/effects/frei0r_vignette.xml
share/apps/kdenlive/effects/gain.xml
share/apps/kdenlive/effects/gamma.xml
+share/apps/kdenlive/effects/grain.xml
share/apps/kdenlive/effects/greyscale.xml
share/apps/kdenlive/effects/invert.xml
-share/apps/kdenlive/effects/ladspa_declipper.xml
-share/apps/kdenlive/effects/ladspa_equalizer.xml
-share/apps/kdenlive/effects/ladspa_limiter.xml
-share/apps/kdenlive/effects/ladspa_phaser.xml
-share/apps/kdenlive/effects/ladspa_pitch.xml
-share/apps/kdenlive/effects/ladspa_pitch_scale.xml
-share/apps/kdenlive/effects/ladspa_rate_scale.xml
-share/apps/kdenlive/effects/ladspa_reverb.xml
-share/apps/kdenlive/effects/ladspa_room_reverb.xml
-share/apps/kdenlive/effects/ladspa_vinyl.xml
share/apps/kdenlive/effects/mirror.xml
share/apps/kdenlive/effects/mute.xml
share/apps/kdenlive/effects/normalise.xml
share/apps/kdenlive/effects/obscure.xml
+share/apps/kdenlive/effects/oldfilm.xml
share/apps/kdenlive/effects/pan_zoom.xml
share/apps/kdenlive/effects/rotation.xml
+share/apps/kdenlive/effects/rotation_keyframable.xml
+share/apps/kdenlive/effects/rotoscoping.xml
+share/apps/kdenlive/effects/scratchlines.xml
share/apps/kdenlive/effects/sepia.xml
share/apps/kdenlive/effects/sox_band.xml
share/apps/kdenlive/effects/sox_bass.xml
@@ -79,10 +105,19 @@ share/apps/kdenlive/effects/sox_phaser.xml
share/apps/kdenlive/effects/sox_stretch.xml
share/apps/kdenlive/effects/speed.xml
share/apps/kdenlive/effects/swapchannels.xml
+share/apps/kdenlive/effects/tcolor.xml
share/apps/kdenlive/effects/threshold.xml
+share/apps/kdenlive/effects/update/frei0r.balanc0r.js
+share/apps/kdenlive/effects/update/frei0r.cartoon.js
+share/apps/kdenlive/effects/update/frei0r.curves.js
+share/apps/kdenlive/effects/update/frei0r.levels.js
+share/apps/kdenlive/effects/update/frei0r.lightgraffiti.js
+share/apps/kdenlive/effects/update/frei0r.sopsat.js
+share/apps/kdenlive/effects/update/frei0r.vertigo.js
share/apps/kdenlive/effects/vignette.xml
share/apps/kdenlive/effects/volume.xml
share/apps/kdenlive/effects/wave.xml
+share/apps/kdenlive/encodingprofiles.rc
share/apps/kdenlive/export/profiles.xml
share/apps/kdenlive/icons/hicolor/128x128/actions/kdenlive-select-all.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-add-clip.png
@@ -258,6 +293,41 @@ share/config/kdenlive_titles.knsrc
share/config/kdenlive_wipes.knsrc
share/config/kdenliveeffectscategory.rc
share/config/kdenlivetranscodingrc
+share/doc/HTML/da/kdenlive/common
+share/doc/HTML/da/kdenlive/index.cache.bz2
+share/doc/HTML/da/kdenlive/index.docbook
+share/doc/HTML/en/kdenlive/Kdenlive-Quickstart-Add-Last-Clip.png
+share/doc/HTML/en/kdenlive/Kdenlive-Quickstart-Add-Transition.png
+share/doc/HTML/en/kdenlive/Kdenlive-Quickstart-EffectStack.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Add-Clips.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Add-Effect.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Effect-Flag.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Fadeout.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Folder-Structure.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Keyframes.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Mainwindow.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-New-Project.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Overlap-Clips.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Renderer.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Rendering.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Resize-Marker.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Save-Project.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-Timeline-Clips.png
+share/doc/HTML/en/kdenlive/Kdenlive_Quickstart-TimelineCursor.png
+share/doc/HTML/en/kdenlive/common
+share/doc/HTML/en/kdenlive/index.cache.bz2
+share/doc/HTML/en/kdenlive/index.docbook
+share/doc/HTML/fr/kdenlive/common
+share/doc/HTML/fr/kdenlive/index.cache.bz2
+share/doc/HTML/fr/kdenlive/index.docbook
+share/doc/HTML/nl/kdenlive/common
+share/doc/HTML/nl/kdenlive/index.cache.bz2
+share/doc/HTML/nl/kdenlive/index.docbook
+share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-Add-Clips_uk.png
+share/doc/HTML/uk/kdenlive/Kdenlive_Quickstart-New-Project_uk.png
+share/doc/HTML/uk/kdenlive/common
+share/doc/HTML/uk/kdenlive/index.cache.bz2
+share/doc/HTML/uk/kdenlive/index.docbook
share/icons/hicolor/128x128/mimetypes/application-x-kdenlivetitle.png
share/icons/hicolor/32x32/apps/kdenlive.png
share/icons/hicolor/32x32/mimetypes/application-x-kdenlivetitle.png
@@ -296,10 +366,17 @@ share/locale/sl/LC_MESSAGES/kdenlive.mo
share/locale/tr/LC_MESSAGES/kdenlive.mo
share/locale/uk/LC_MESSAGES/kdenlive.mo
share/locale/zh/LC_MESSAGES/kdenlive.mo
+share/locale/zh_CN/LC_MESSAGES/kdenlive.mo
+share/locale/zh_TW/LC_MESSAGES/kdenlive.mo
share/mime/packages/kdenlive.xml
share/mime/packages/westley.xml
@dirrmtry share/mime/packages
@dirrmtry share/mime
+@dirrm share/doc/HTML/uk/kdenlive
+@dirrm share/doc/HTML/nl/kdenlive
+@dirrm share/doc/HTML/fr/kdenlive
+@dirrm share/doc/HTML/en/kdenlive
+@dirrm share/doc/HTML/da/kdenlive
@dirrm share/apps/kdenlive/titles
@dirrm share/apps/kdenlive/lumas
@dirrm share/apps/kdenlive/icons/oxygen/scalable/actions
@@ -334,6 +411,7 @@ share/mime/packages/westley.xml
@dirrm share/apps/kdenlive/icons/hicolor
@dirrm share/apps/kdenlive/icons
@dirrm share/apps/kdenlive/export
+@dirrm share/apps/kdenlive/effects/update
@dirrm share/apps/kdenlive/effects
@dirrm share/apps/kdenlive
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true