aboutsummaryrefslogtreecommitdiffstats
path: root/net/icqnix/Makefile
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>1999-08-28 10:36:03 +0800
committerjim <jim@FreeBSD.org>1999-08-28 10:36:03 +0800
commita95b6c32ae83247f0ef2dcc96f1caf8a1452743f (patch)
tree7696ece14094d982f9c35e196e1b6123dc3b3bc8 /net/icqnix/Makefile
parent4ea1177771960cdf6cbcee78db1b8afa6d678858 (diff)
downloadfreebsd-ports-graphics-a95b6c32ae83247f0ef2dcc96f1caf8a1452743f.tar.gz
freebsd-ports-graphics-a95b6c32ae83247f0ef2dcc96f1caf8a1452743f.tar.zst
freebsd-ports-graphics-a95b6c32ae83247f0ef2dcc96f1caf8a1452743f.zip
Import of icqnix.
ICQnix is an ICQ client for X that is designed to look and feel as much like the Mirabilis ICQ client as possible. PR: 13428 Submitted by: Yin-Jieh Chen <yinjieh@Crazyman.Dorm13.NCTU.edu.tw>
Diffstat (limited to 'net/icqnix/Makefile')
-rw-r--r--net/icqnix/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/icqnix/Makefile b/net/icqnix/Makefile
new file mode 100644
index 00000000000..1016d4d24cf
--- /dev/null
+++ b/net/icqnix/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: icqnix
+# Version required: b1
+# Date created: 27 Aug 1999
+# Whom: Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+DISTNAME= icqnix-beta1
+PKGNAME= icqnix-b1
+CATEGORIES= net
+MASTER_SITES= http://icqnix.linuxbox.com/
+
+MAINTAINER= yinjieh@csie.nctu.edu.tw
+
+LIB_DEPENDS= qt.2:${PORTSDIR}/x11-toolkits/qt142
+RUN_DEPENDS= esdplay:${PORTSDIR}/audio/esound
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-install:
+ @strip ${PREFIX}/bin/icqnix
+ @strip ${PREFIX}/bin/icqnix.install
+
+.include <bsd.port.mk>