aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-19 23:09:35 +0800
committermarino <marino@FreeBSD.org>2015-02-19 23:09:35 +0800
commitc91993da33303faf36cbbdeba03bf38dae4b7707 (patch)
treeb583f1239a32ec65dfdd5f0fbd6cccccdb6766ae /net
parent4cc361a5c314676af865c8a3f46e19a1cf5de031 (diff)
downloadfreebsd-ports-graphics-c91993da33303faf36cbbdeba03bf38dae4b7707.tar.gz
freebsd-ports-graphics-c91993da33303faf36cbbdeba03bf38dae4b7707.tar.zst
freebsd-ports-graphics-c91993da33303faf36cbbdeba03bf38dae4b7707.zip
net/xmlrpc-c*: Respect CXXFLAGS (PHB 12.9)
The main program did respect cflags, but the cpp example program did not. Approved by: blanket
Diffstat (limited to 'net')
-rw-r--r--net/xmlrpc-c-devel/files/patch-examples_cpp_Makefile11
-rw-r--r--net/xmlrpc-c/files/patch-examples_cpp_Makefile11
2 files changed, 22 insertions, 0 deletions
diff --git a/net/xmlrpc-c-devel/files/patch-examples_cpp_Makefile b/net/xmlrpc-c-devel/files/patch-examples_cpp_Makefile
new file mode 100644
index 00000000000..ad1df3c46f6
--- /dev/null
+++ b/net/xmlrpc-c-devel/files/patch-examples_cpp_Makefile
@@ -0,0 +1,11 @@
+--- examples/cpp/Makefile.orig 2013-10-23 00:09:37 UTC
++++ examples/cpp/Makefile
+@@ -15,7 +15,7 @@ include $(BLDDIR)/config.mk
+
+ default: all
+
+-CXXFLAGS = $(CFLAGS_PERSONAL) $(CADD)
++CXXFLAGS+= $(CFLAGS_PERSONAL) $(CADD)
+ LDFLAGS += $(LADD)
+
+ # If this were a real application, working from an installed copy of
diff --git a/net/xmlrpc-c/files/patch-examples_cpp_Makefile b/net/xmlrpc-c/files/patch-examples_cpp_Makefile
new file mode 100644
index 00000000000..bc0bd873c84
--- /dev/null
+++ b/net/xmlrpc-c/files/patch-examples_cpp_Makefile
@@ -0,0 +1,11 @@
+--- examples/cpp/Makefile.orig 2013-03-29 06:38:36 UTC
++++ examples/cpp/Makefile
+@@ -15,7 +15,7 @@ include $(BLDDIR)/config.mk
+
+ default: all
+
+-CXXFLAGS = $(CFLAGS_PERSONAL) $(CADD)
++CXXFLAGS+= $(CFLAGS_PERSONAL) $(CADD)
+ LDFLAGS += $(LADD)
+
+ # If this were a real application, working from an installed copy of