aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2007-01-29 20:13:01 +0800
committersem <sem@FreeBSD.org>2007-01-29 20:13:01 +0800
commit3b817c959a0def78f3ec0f7272094b6478d5679e (patch)
tree3e6f1e90fc01210ad0364b3eb2a2aef2b201a3a0 /shells
parent148648ad778c16e31a2a1feeec6fe8400776af5c (diff)
downloadfreebsd-ports-graphics-3b817c959a0def78f3ec0f7272094b6478d5679e.tar.gz
freebsd-ports-graphics-3b817c959a0def78f3ec0f7272094b6478d5679e.tar.zst
freebsd-ports-graphics-3b817c959a0def78f3ec0f7272094b6478d5679e.zip
- Install examples. [1]
- Add dependancy on devel/p5-ReadLine-Perl. It enables autocompletion feature. [2] - Butify COMMENT. - Pass to perl@ Submitted by: az [1], [2]
Diffstat (limited to 'shells')
-rw-r--r--shells/p5-Term-ShellUI/Makefile24
-rw-r--r--shells/p5-Term-ShellUI/pkg-plist12
2 files changed, 34 insertions, 2 deletions
diff --git a/shells/p5-Term-ShellUI/Makefile b/shells/p5-Term-ShellUI/Makefile
index 68b8b5f33c1..1d0fc8086b8 100644
--- a/shells/p5-Term-ShellUI/Makefile
+++ b/shells/p5-Term-ShellUI/Makefile
@@ -7,17 +7,37 @@
PORTNAME= Term-ShellUI
PORTVERSION= 0.85
+PORTREVISION= 1
CATEGORIES= shells perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Term/BRONSON
PKGNAMEPREFIX= p5-
-MAINTAINER= sem@FreeBSD.org
-COMMENT= Term::ShellUI - A fully-featured shell-like command line environment
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A fully-featured shell-like command line environment
+
+RUN_DEPENDS= ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
PERL_CONFIGURE= yes
+SAMPLESDIR= ${WRKSRC}/examples
+
MAN3= Term::ShellUI.3 \
Text::Shellwords::Cursor.3
+post-install:
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}/RPC
+ @${MKDIR} ${EXAMPLESDIR}/Term
+ @${INSTALL_DATA} ${SAMPLESDIR}/RPC/Connection.pm ${EXAMPLESDIR}/RPC
+ @${INSTALL_DATA} ${SAMPLESDIR}/Term/ExprUI.pm ${EXAMPLESDIR}/Term
+ @${INSTALL_DATA} ${SAMPLESDIR}/README ${EXAMPLESDIR}
+.for file in fileman-example psh synopsys synopsys-old tui-sample xmlexer
+ @${INSTALL_SCRIPT} ${SAMPLESDIR}/${file} ${EXAMPLESDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/shells/p5-Term-ShellUI/pkg-plist b/shells/p5-Term-ShellUI/pkg-plist
index 8062c05c94a..a869f69306f 100644
--- a/shells/p5-Term-ShellUI/pkg-plist
+++ b/shells/p5-Term-ShellUI/pkg-plist
@@ -1,6 +1,18 @@
%%SITE_PERL%%/Term/ShellUI.pm
%%SITE_PERL%%/Text/Shellwords/Cursor.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ShellUI/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/RPC/Connection.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Term/ExprUI.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/fileman-example
+%%PORTDOCS%%%%EXAMPLESDIR%%/psh
+%%PORTDOCS%%%%EXAMPLESDIR%%/synopsys
+%%PORTDOCS%%%%EXAMPLESDIR%%/synopsys-old
+%%PORTDOCS%%%%EXAMPLESDIR%%/tui-sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/xmlexer
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/RPC
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Term
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ShellUI
@dirrmtry %%SITE_PERL%%/Text/Shellwords
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term
00'>2012-07-181-2/+3 * - Connect ns2 to the build, which was forgotten after the ns -> ns2 repo copyswills2012-07-181-0/+1 * Provide an improved version of the "renamed file detection" patch.ehaupt2012-07-182-1/+762 * mod_ldap and mod_quotatab_ldap modules for ProFTPDmm2012-07-173-0/+34 * In the rc.d script, have ntpd start after ntpdate.naddy2012-07-172-2/+2 * Now that I'm not keeping a local cvs mirror, drop this port.wxs2012-07-171-1/+1 * - update to 1.8.14.1flo2012-07-173-99/+102 * - Upgrade to 2.2.5.kuriyama2012-07-162-4/+3 * - Update to 0.3miwi2012-07-162-3/+3 * Fix build with gcc 4.7+ / libc++kwm2012-07-132-0/+18 * Update oauth to 0.9.7 (bugfix release)johans2012-07-132-4/+3 * Update to 10.6.0flo2012-07-122-3/+3 * Update to 1.8.14.0flo2012-07-122-3/+3 * - Update to 2.42sunpoet2012-07-123-6/+9 * Reset maintainership for ports maintained by Gerrit Beine.crees2012-07-124-4/+4 * - Update to 2.00013mich2012-07-123-9/+63 * - Update to 1.121660sunpoet2012-07-112-5/+8 * Make sure not to detect mDNSResponder.marcus2012-07-092-4/+14 * Update to 10.5.2flo2012-07-072-4/+3 * Update to 1.8.13.1flo2012-07-072-4/+3 * - Update to 0.8.0sunpoet2012-07-062-4/+5 * - Update to 1.6.1.hrs2012-07-0628-198/+1969 * - Fix insecure handling of GeoIP download filescheidell2012-07-043-7/+6 * - Convert to new options frameworksunpoet2012-07-041-1/+2 * - Convert to new options frameworksunpoet2012-07-041-10/+7 * - Update to 2.6.2sunpoet2012-07-042-3/+3 * - Update to 0.2sunpoet2012-07-044-29/+39 * - Patch to handle files > 2GBscheidell2012-07-042-1/+405 * - Update to 0.1.16tota2012-07-032-3/+3 * - Update to 1.07sunpoet2012-07-032-5/+6 * Remove ^M from patches and use USE_DOS2UNIX, silence portlintgarga2012-07-033-9/+10 * Move LICENSE to right place to silence portlintgarga2012-07-031-2/+2 * - re-order, include bsd.port.pre.mk so SRC_BASE is defined before referencedjgh2012-07-022-4/+3 * - re-order, include bsd.port.pre.mk so SRC_BASE is defined before referencedjgh2012-07-022-4/+3 * - re-order, include bsd.port.pre.mk so SRC_BASE is defined before referencedjgh2012-07-021-1/+3 * Update to 1.8.0. Seemarcus2012-07-013-22/+8 * -Fix mod_perl2 issueaz2012-07-011-2/+2 * - Remove SITE_PERL from *_DEPENDSaz2012-07-016-10/+10 * - Remove SITE_PERL from *_DEPENDSaz2012-06-3029-96/+96 * - Remove SITE_PERL from *_DEPENDSaz2012-06-308-13/+13 * - Move to OPTIONSnggarga2012-06-302-28/+30 * - Remove SITE_PERL from *_DEPENDSaz2012-06-301-1/+1 * - Remove SITE_PERL from *_DEPENDSaz2012-06-303-6/+6 * - Remove SITE_PERL from *_DEPENDSaz2012-06-304-13/+13 * - Remove SITE_PERL from *_DEPENDSaz2012-06-303-4/+4 * - Remove SITE_PERL from *_DEPENDSaz2012-06-292-6/+6 * - Remove SITE_PERL from *_DEPENDSaz2012-06-291-1/+1 * - Remove SITE_PERL from *_DEPENDSaz2012-06-293-4/+4 * - Remove SITE_PERL from *_DEPENDSaz2012-06-291-3/+3 * - Remove SITE_PERL from *_DEPENDSaz2012-06-293-5/+5 * - Switch to use easy_install for creating safe plist while setuptools installedlwhsu2012-06-292-33/+2 * - Add support for MFC/R2 signaling using openr2 library.fjoe2012-06-282-6/+10 * - Update to 3.18003sunpoet2012-06-282-4/+3 * - update to 0.5.5rm2012-06-272-3/+3 * update math/R to 2.15.1, switch to the new options format, andbf2012-06-271-1/+1 * - update to 0.5.4rm2012-06-272-3/+3 * - Update E17 ports:makc2012-06-274-7/+8 * - Update to 0.66sunpoet2012-06-263-3/+6 * - Update to 0.1.8clsung2012-06-262-5/+3 * Upgrade, 0.10004 to 0.11001.max2012-06-262-4/+5 * - Update to 1.5.211clsung2012-06-262-3/+5 * - reset MAINTAINERdinoex2012-06-265-5/+5 * - Update to 1.9clsung2012-06-262-3/+3 * Add kld to CATEGORIES.hrs2012-06-251-1/+1 * - Migrate to new name ns2swills2012-06-252-5/+7 * Reposado is a set of tools written in Python that replicate theswills2012-06-258-0/+105 * - Update to 0.16sunpoet2012-06-252-3/+3 * Replace devel/py-sendfile with net/py-pysendfile; upstream of py-sendfilecrees2012-06-256-0/+55 * update courier-authlib to 0.64.0oliver2012-06-241-1/+0 * - Add py-port-for 0.3sunpoet2012-06-235-0/+66 * - Update to 2.28sunpoet2012-06-232-4/+3 * - Update to 2.2.1clsung2012-06-223-33/+67 * - Update to 2.006sunpoet2012-06-222-3/+3 * - since 1.1.1 upstream switched to setuptools by default,rm2012-06-222-76/+4 * - Remove -p from MKDIRsem2012-06-211-2/+2 * - Update to 0.15sunpoet2012-06-212-3/+3 * - Update to 2.35swills2012-06-2112-14/+132 * Use PERL_MODBUILD to unbreak build with Perl 5.14+.skv2012-06-212-4/+1 * Update to version 2.2.2skreuzer2012-06-212-4/+5 * - readd patch pf_enable_filter_rules.patch to fix PF_ENABLE_FILTER_RULESsperber2012-06-201-0/+11 * - Fix install on clean systemsem2012-06-201-1/+2 * Over to new maintainer.linimon2012-06-202-2/+2 * - Update to 1.9.1dhn2012-06-202-3/+3 * - adopt optionsNGjgh2012-06-201-10/+9 * - adopt optionsNGjgh2012-06-201-10/+9 * Update to 5.3.14flo2012-06-201-2/+0 * - Update to 2.18zi2012-06-193-36/+5 * Do not require specific version of pcre shared library.demon2012-06-192-2/+2 * Convert to new OPTIONS framework.demon2012-06-192-12/+22 * Update to 4.3.0.wxs2012-06-192-21/+26 * Update to 1.3.0.wxs2012-06-192-7/+16 * - Update to 1.0jgh2012-06-192-22/+21 * - Update to 0.14sunpoet2012-06-182-3/+3 * - Update to 1.8.6pav2012-06-182-4/+3 * - Update to 0.13sunpoet2012-06-182-3/+3 * - Update to 4.1-ESV-R5scheidell2012-06-182-22/+24 * - Update to 2.6.1swills2012-06-172-3/+3 * Convert to use new OPTIONS framework.ume2012-06-171-10/+9 * Define PKGBASE to stop sharing UNIQUENAME with net/freeswitchcrees2012-06-161-0/+1 * - Update to version 2.2 [1]scheidell2012-06-164-7/+43 * - Avoid += without preceeding definitionswills2012-06-161-1/+1 * - Switch to OptionsNgmartymac2012-06-151-3/+5 * Switch to OptionsNgmartymac2012-06-151-4/+6 * - Update to 1.9dhn2012-06-152-3/+6 * - Update to 0.12sunpoet2012-06-152-3/+3 * Update to 10.5.1flo2012-06-152-3/+3 * - update to 1.1.1rm2012-06-152-3/+5 * Don't override UNIQUENAME. Without this, -client slave will overwritedelphij2012-06-151-2/+1 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-153-68/+2 * - update to 2.4.10rm2012-06-152-3/+3 * - Update to 2.005sunpoet2012-06-142-3/+3 * - Update to 0.19.2scheidell2012-06-143-7/+20 * - Update to 1.2.2zi2012-06-142-5/+5 * - Update to 3.121640sunpoet2012-06-133-3/+7 * - Update to 1.121640sunpoet2012-06-132-3/+6 * - Add pecl-gupnp 1.0.0sunpoet2012-06-134-0/+32 * - Change MASTER_SITES to GNOMEsunpoet2012-06-132-9/+13 * - Update to 0.2.1sunpoet2012-06-135-17/+34 * - Update to 0.10.2sunpoet2012-06-134-10/+21 * - Update to 0.18.3sunpoet2012-06-134-19/+36 * - Update to 0.12.1sunpoet2012-06-135-34/+37 * - Import my upstream patches:avilla2012-06-125-2/+126 * - Update to 0.0.4.2culot2012-06-122-5/+4 * - Update to 12.1.0sunpoet2012-06-122-5/+5 * Update to version 0.6.3.jhay2012-06-113-3/+4 * - Update to 0.99.21zi2012-06-116-60/+80 * - cleanup now duplicate defsdinoex2012-06-111-4/+0 * - update to 1.7dinoex2012-06-113-3/+23 * - Convert all remaining instances of BUILD_DEPENDS=${RUN_DEPENDS} orswills2012-06-1139-39/+39 * - Update to 0.5.3swills2012-06-112-3/+3 * Port for package building of 6rd patched stf(4) kernel lodable modules.kuriyama2012-06-107-0/+1436 * - Fix header files integrity when X11 option is disabledpav2012-06-102-50/+61 * - Fix packagingpav2012-06-101-0/+1 * Update to version 4.2.34pawel2012-06-102-3/+3 * - Update to 2.004sunpoet2012-06-104-8/+15 * - Adjust the gsasl dependency to the current shlib version.rakuco2012-06-101-2/+2 * - Update net/usbredir to 0.4.3 .nox2012-06-105-125/+17 * - Update to 0.685miwi2012-06-093-8/+4 * Add new port net/libmediawiki:makc2012-06-095-0/+67 * Add new port net/libkvkontakte:makc2012-06-095-0/+78 * Merge changes from area51 repository (SVN commit 8197 by avilla):makc2012-06-092-56/+45 * update to 0.8.3 to fix build with KDE SC 4.8.3makc2012-06-093-5/+15 * Convert to optionsngarved2012-06-081-2/+3 * Convert to optionsNGarved2012-06-081-5/+6 * Duplicate EXTRACT_DEPENDS to FETCH_DEPENDS, to fix build undermandree2012-06-081-0/+1 * Fix lookup of png librarybapt2012-06-08