aboutsummaryrefslogtreecommitdiffstats
path: root/www/encompass/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-13 14:56:51 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-13 14:56:51 +0800
commit35d853b620d59028424bf60d7ffcfedab5f71918 (patch)
tree979169a4fbd405119df13ceb42faa00bc340bff8 /www/encompass/Makefile
parent0c01e3b2c381cd999084ae38902bbdf22153e6a3 (diff)
downloadfreebsd-ports-graphics-35d853b620d59028424bf60d7ffcfedab5f71918.tar.gz
freebsd-ports-graphics-35d853b620d59028424bf60d7ffcfedab5f71918.tar.zst
freebsd-ports-graphics-35d853b620d59028424bf60d7ffcfedab5f71918.zip
Fix breakage introduced by the gettext conversion.
Submitted by: bento
Diffstat (limited to 'www/encompass/Makefile')
-rw-r--r--www/encompass/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/encompass/Makefile b/www/encompass/Makefile
index f0ad7f2be23..a3aa69666bb 100644
--- a/www/encompass/Makefile
+++ b/www/encompass/Makefile
@@ -16,6 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
LIB_DEPENDS= neon.19:${PORTSDIR}/www/neon \
elysium.0:${PORTSDIR}/misc/libelysium
@@ -23,7 +24,9 @@ USE_GNOME= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \