aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-12-25 23:08:34 +0800
committerdirk <dirk@FreeBSD.org>2001-12-25 23:08:34 +0800
commit7998832b75cb0a69b0cc549c551835a487555857 (patch)
tree3dd77fdd6f00d04cb9e1ef86761165b4f196f3fc /www
parent0b19b5f6c9c34ec84b04543cfa54425910715c91 (diff)
downloadfreebsd-ports-graphics-7998832b75cb0a69b0cc549c551835a487555857.tar.gz
freebsd-ports-graphics-7998832b75cb0a69b0cc549c551835a487555857.tar.zst
freebsd-ports-graphics-7998832b75cb0a69b0cc549c551835a487555857.zip
Fix SybaseDB and SybaseCT after freetds upgrade:
- sybdb.0 -> sybdb.1 - include libgiconv in LIBS Reported by: Alexandr Listopad <laa@laa.zp.ua>
Diffstat (limited to 'www')
-rw-r--r--www/mod_php3/scripts/configure.php6
-rw-r--r--www/mod_php4/scripts/configure.php6
-rw-r--r--www/mod_php5/scripts/configure.php6
3 files changed, 15 insertions, 3 deletions
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index e3c87234399..67da17e25fa 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -101,8 +101,10 @@ while [ "$1" ]; do
fi
;;
\"SybaseDB\")
- echo "LIB_DEPENDS+= sybdb.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= sybdb.1:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase=\${PREFIX}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASECT" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
@@ -112,7 +114,9 @@ while [ "$1" ]; do
;;
\"SybaseCT\")
echo "LIB_DEPENDS+= ct.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase-ct=\${PREFIX}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASEDB" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 7b71120d541..ed74b8d959d 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -141,8 +141,10 @@ while [ "$1" ]; do
fi
;;
\"SybaseDB\")
- echo "LIB_DEPENDS+= sybdb.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= sybdb.1:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASECT" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
@@ -152,7 +154,9 @@ while [ "$1" ]; do
;;
\"SybaseCT\")
echo "LIB_DEPENDS+= ct.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase-ct=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASEDB" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 7b71120d541..ed74b8d959d 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -141,8 +141,10 @@ while [ "$1" ]; do
fi
;;
\"SybaseDB\")
- echo "LIB_DEPENDS+= sybdb.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= sybdb.1:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASECT" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
@@ -152,7 +154,9 @@ while [ "$1" ]; do
;;
\"SybaseCT\")
echo "LIB_DEPENDS+= ct.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase-ct=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASEDB" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc