aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-05-19 23:09:20 +0800
committerclement <clement@FreeBSD.org>2004-05-19 23:09:20 +0800
commit9eaf1363e5bb3ac5d96129ffafa719082443b2de (patch)
treea124d08c631c6e5247ec7bad8d8387060ef59eff /www
parentff0b98799ec7578f6a18019d08b34a7793055bd7 (diff)
downloadfreebsd-ports-graphics-9eaf1363e5bb3ac5d96129ffafa719082443b2de.tar.gz
freebsd-ports-graphics-9eaf1363e5bb3ac5d96129ffafa719082443b2de.tar.zst
freebsd-ports-graphics-9eaf1363e5bb3ac5d96129ffafa719082443b2de.zip
Add mod_chroot 0.2, the mod_chroot makes running Apache in a chroot
easy. PR: ports/66789 Submitted by: Alexey A.Ukhov <auk@startext.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_chroot/Makefile28
-rw-r--r--www/mod_chroot/distinfo2
-rw-r--r--www/mod_chroot/files/post-install-notes2
-rw-r--r--www/mod_chroot/pkg-descr8
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 172a872cbe5..965d38de80d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -228,6 +228,7 @@
SUBDIR += mod_bunzip2
SUBDIR += mod_cfg_ldap
SUBDIR += mod_cgi_debug
+ SUBDIR += mod_chroot
SUBDIR += mod_clamav
SUBDIR += mod_color
SUBDIR += mod_csacek
diff --git a/www/mod_chroot/Makefile b/www/mod_chroot/Makefile
new file mode 100644
index 00000000000..d1c48d0220e
--- /dev/null
+++ b/www/mod_chroot/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: mod_chroot
+# Date created: May 18, 2004
+# Whom: Alexey A.Ukhov <auk@startext.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_chroot
+PORTVERSION= 0.2
+CATEGORIES= www
+MASTER_SITES= http://core.segfault.pl/~hobbit/mod_chroot/dist/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The mod_chroot makes running Apache in a chroot easy
+
+PORTDOCS= INSTALL EAPI CAVEATS
+WANT_APACHE= 13
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/mod_chroot/distinfo b/www/mod_chroot/distinfo
new file mode 100644
index 00000000000..36046b4fc2d
--- /dev/null
+++ b/www/mod_chroot/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_chroot-0.2.tar.gz) = 85211cd8cafcfe64258e02291ea6439e
+SIZE (mod_chroot-0.2.tar.gz) = 10540
diff --git a/www/mod_chroot/files/post-install-notes b/www/mod_chroot/files/post-install-notes
new file mode 100644
index 00000000000..01cbfa1282a
--- /dev/null
+++ b/www/mod_chroot/files/post-install-notes
@@ -0,0 +1,2 @@
+Running Apache (and CGI/Perl/PHP) inside a chroot jail can be tricky.
+Read CAVEATS for known problems and solutions.
diff --git a/www/mod_chroot/pkg-descr b/www/mod_chroot/pkg-descr
new file mode 100644
index 00000000000..10e25981df4
--- /dev/null
+++ b/www/mod_chroot/pkg-descr
@@ -0,0 +1,8 @@
+mod_chroot makes running Apache in a secure chroot environment easy.
+You don't need to create a special directory hierarchy containing
+/dev, /lib, /etc...
+mod_chroot allows you to run Apache in a chroot jail with no additional files.
+The chroot() system call is performed at the end of startup procedure - when
+all libraries are loaded and log files open.
+
+WWW: http://core.segfault.pl/~hobbit/mod_chroot/