aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/qbs/Makefile15
-rw-r--r--devel/qbs/distinfo6
-rw-r--r--devel/qbs/files/patch-src_lib_corelib_tools_processutils.cpp18
-rw-r--r--devel/qbs/pkg-plist20
-rw-r--r--devel/qtcreator/Makefile17
-rw-r--r--devel/qtcreator/distinfo6
-rw-r--r--devel/qtcreator/pkg-plist161
7 files changed, 122 insertions, 121 deletions
diff --git a/devel/qbs/Makefile b/devel/qbs/Makefile
index 8af421b7cc1..3ce44c55db2 100644
--- a/devel/qbs/Makefile
+++ b/devel/qbs/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= qbs
-PORTVERSION= 1.5.2
+PORTVERSION= 1.6.0
DISTVERSIONPREFIX= src-
CATEGORIES= devel
MASTER_SITES= QT/official_releases/${PORTNAME}/${PORTVERSION}
@@ -14,7 +14,7 @@ LICENSE= GPLv3 LGPL21
LICENSE_COMB= dual
USES= compiler:c++11-lib qmake:outsource
-USE_GL= yes
+USE_GL= gl
USE_LDCONFIG= yes
USE_QT5= buildtools_build core concurrent gui network script testlib \
widgets xml
@@ -31,4 +31,15 @@ INSTALL_TARGET= install
DOCS_ALL_TARGET= docs
DOCS_INSTALL_TARGET= install_docs
+pre-configure:
+# We piggyback on QMAKE_LIBDIR_FLAGS to make sure -L${WRKSRC}/lib is passed to
+# the linker before -L/usr/local/lib. By default, the opposite happens, which
+# is a problem when a Qt port is being upgraded, since an existing library
+# would end up being picked up instead of those built in ${WRKSRC}/lib. Since
+# qmake appends the value of QMAKE_LIBDIR to QMAKE_LIBDIR_FLAGS, we can use the
+# latter to get the linker path order right. qmake is smart enough to strip
+# occurrences of ${WRKSRC}/lib from .pc and .prl files when installing them.
+# See QTBUG-40825 and ports bugs 194088, 195105 and 198720.
+ ${ECHO_CMD} 'QMAKE_LIBDIR_FLAGS = -L${WRKSRC}/lib' >> ${WRKSRC}/.qmake.cache
+
.include <bsd.port.mk>
diff --git a/devel/qbs/distinfo b/devel/qbs/distinfo
index 2d24847da15..43769235f40 100644
--- a/devel/qbs/distinfo
+++ b/devel/qbs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1467899190
-SHA256 (KDE/Qt/qbs/qbs-src-1.5.2.tar.gz) = 059b4f64c1f599379a17bbf859dd9658fafe8cb2b65b31634974ff1c381928c1
-SIZE (KDE/Qt/qbs/qbs-src-1.5.2.tar.gz) = 902972
+TIMESTAMP = 1472157751
+SHA256 (KDE/Qt/qbs/qbs-src-1.6.0.tar.gz) = ae850e957e4a811a193b02a067321722dd0e5fc50b7c370ec34273c1565e78ab
+SIZE (KDE/Qt/qbs/qbs-src-1.6.0.tar.gz) = 928684
diff --git a/devel/qbs/files/patch-src_lib_corelib_tools_processutils.cpp b/devel/qbs/files/patch-src_lib_corelib_tools_processutils.cpp
deleted file mode 100644
index 2d471ceeb0b..00000000000
--- a/devel/qbs/files/patch-src_lib_corelib_tools_processutils.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/lib/corelib/tools/processutils.cpp.orig 2016-07-08 11:54:19.708701000 +0200
-+++ src/lib/corelib/tools/processutils.cpp 2016-07-08 12:06:40.098340000 +0200
-@@ -42,12 +42,12 @@
- # include <cstdio>
- #elif defined(Q_OS_BSD4)
- # include <QFile>
--# if !defined(Q_OS_NETBSD)
--# include <sys/user.h>
--# endif
- # include <sys/cdefs.h>
- # include <sys/param.h>
- # include <sys/sysctl.h>
-+# if !defined(Q_OS_NETBSD)
-+# include <sys/user.h>
-+# endif
- #else
- # error Missing implementation of processNameByPid for this platform.
- #endif
diff --git a/devel/qbs/pkg-plist b/devel/qbs/pkg-plist
index 0e87c5ba96a..5d062d4a3ec 100644
--- a/devel/qbs/pkg-plist
+++ b/devel/qbs/pkg-plist
@@ -33,16 +33,17 @@ include/qbs/tools/qbs_export.h
include/qbs/tools/settings.h
include/qbs/tools/settingsmodel.h
include/qbs/tools/setupprojectparameters.h
+include/qbs/tools/toolchains.h
include/qbs/use_installed_corelib.pri
include/qbs/use_installed_qtprofilesetup.pri
lib/libqbscore.so
lib/libqbscore.so.1
-lib/libqbscore.so.1.5
-lib/libqbscore.so.1.5.2
+lib/libqbscore.so.1.6
+lib/libqbscore.so.1.6.0
lib/libqbsqtprofilesetup.so
lib/libqbsqtprofilesetup.so.1
-lib/libqbsqtprofilesetup.so.1.5
-lib/libqbsqtprofilesetup.so.1.5.2
+lib/libqbsqtprofilesetup.so.1.6
+lib/libqbsqtprofilesetup.so.1.6.0
lib/qbs/plugins/libqbs_cpp_scanner.so
lib/qbs/plugins/libqbs_qt_scanner.so
%%PORTDOCS%%%%DOCSDIR%%/html/android-ndk-module.html
@@ -94,6 +95,7 @@ lib/qbs/plugins/libqbs_qt_scanner.so
%%PORTDOCS%%%%DOCSDIR%%/html/jsextension-utilities.html
%%PORTDOCS%%%%DOCSDIR%%/html/jsextensions-general.html
%%PORTDOCS%%%%DOCSDIR%%/html/language-introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/lex-yacc-module.html
%%PORTDOCS%%%%DOCSDIR%%/html/list-of-builtin-services.html
%%PORTDOCS%%%%DOCSDIR%%/html/list-of-items.html
%%PORTDOCS%%%%DOCSDIR%%/html/list-of-modules.html
@@ -126,7 +128,6 @@ lib/qbs/plugins/libqbs_qt_scanner.so
%%PORTDOCS%%%%DOCSDIR%%/html/style/offline.css
%%PORTDOCS%%%%DOCSDIR%%/html/subproject-item.html
%%PORTDOCS%%%%DOCSDIR%%/html/system-requirements.html
-%%PORTDOCS%%%%DOCSDIR%%/html/transformer-item.html
%%PORTDOCS%%%%DOCSDIR%%/html/typescript-module.html
%%PORTDOCS%%%%DOCSDIR%%/html/usage.html
%%PORTDOCS%%%%DOCSDIR%%/html/wix-module.html
@@ -199,8 +200,10 @@ lib/qbs/plugins/libqbs_qt_scanner.so
%%DATADIR%%/imports/qbs/Probes/AndroidSdkProbe.qbs
%%DATADIR%%/imports/qbs/Probes/BinaryProbe.qbs
%%DATADIR%%/imports/qbs/Probes/FrameworkProbe.qbs
+%%DATADIR%%/imports/qbs/Probes/GccProbe.qbs
%%DATADIR%%/imports/qbs/Probes/IncludeProbe.qbs
%%DATADIR%%/imports/qbs/Probes/JdkProbe.qbs
+%%DATADIR%%/imports/qbs/Probes/MsvcProbe.qbs
%%DATADIR%%/imports/qbs/Probes/NodeJsProbe.qbs
%%DATADIR%%/imports/qbs/Probes/NpmProbe.qbs
%%DATADIR%%/imports/qbs/Probes/PathProbe.qbs
@@ -247,11 +250,12 @@ lib/qbs/plugins/libqbs_qt_scanner.so
%%DATADIR%%/modules/cpp/CppModule.qbs
%%DATADIR%%/modules/cpp/DarwinGCC.qbs
%%DATADIR%%/modules/cpp/GenericGCC.qbs
+%%DATADIR%%/modules/cpp/LinuxGCC.qbs
%%DATADIR%%/modules/cpp/UnixGCC.qbs
+%%DATADIR%%/modules/cpp/android-gcc.qbs
%%DATADIR%%/modules/cpp/gcc.js
%%DATADIR%%/modules/cpp/genericunix-gcc.qbs
%%DATADIR%%/modules/cpp/ios-gcc.qbs
-%%DATADIR%%/modules/cpp/linux-gcc.qbs
%%DATADIR%%/modules/cpp/macos-gcc.qbs
%%DATADIR%%/modules/cpp/msvc.js
%%DATADIR%%/modules/cpp/tvos-gcc.qbs
@@ -267,10 +271,14 @@ lib/qbs/plugins/libqbs_qt_scanner.so
%%DATADIR%%/modules/java/io/qt/qbs/ArtifactListWriter.java
%%DATADIR%%/modules/java/io/qt/qbs/ArtifactListXmlWriter.java
%%DATADIR%%/modules/java/io/qt/qbs/tools/JavaCompilerScannerTool.java
+%%DATADIR%%/modules/java/io/qt/qbs/tools/utils/ArtifactProcessor.java
+%%DATADIR%%/modules/java/io/qt/qbs/tools/utils/ArtifactScanner.java
%%DATADIR%%/modules/java/io/qt/qbs/tools/utils/JavaCompilerOptions.java
%%DATADIR%%/modules/java/io/qt/qbs/tools/utils/JavaCompilerScanner.java
%%DATADIR%%/modules/java/io/qt/qbs/tools/utils/NullFileObject.java
%%DATADIR%%/modules/java/utils.js
+%%DATADIR%%/modules/lex_yacc/lexyacc.js
+%%DATADIR%%/modules/lex_yacc/lexyacc.qbs
%%DATADIR%%/modules/nodejs/NodeJS.qbs
%%DATADIR%%/modules/nodejs/nodejs.js
%%DATADIR%%/modules/nsis/NSISModule.qbs
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 6d6117574f6..5beb470ac5b 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qtcreator
-DISTVERSION= 4.0.3
+DISTVERSION= 4.1.0
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
@@ -12,8 +12,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= C++ and QML IDE for Qt development
# depend on the split out qbs
-BUILD_DEPENDS= qbs:devel/qbs
-RUN_DEPENDS= qbs:devel/qbs
+LIB_DEPENDS= libqbscore.so:devel/qbs
USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}
USES= qmake compiler:c++11-lib
@@ -58,4 +57,16 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/bin/ant|${LOCALBASE}/bin/ant|' \
${WRKSRC}/src/plugins/android/androidsettingswidget.cpp
+pre-configure:
+# We piggyback on QMAKE_LIBDIR_FLAGS to make sure -L${WRKSRC}/lib is passed to
+# the linker before -L/usr/local/lib. By default, the opposite happens, which
+# is a problem when a Qt port is being upgraded, since an existing library
+# would end up being picked up instead of those built in ${WRKSRC}/lib. Since
+# qmake appends the value of QMAKE_LIBDIR to QMAKE_LIBDIR_FLAGS, we can use the
+# latter to get the linker path order right. qmake is smart enough to strip
+# occurrences of ${WRKSRC}/lib from .pc and .prl files when installing them.
+# See QTBUG-40825 and ports bugs 194088, 195105 and 198720.
+ ${ECHO_CMD} 'QMAKE_LIBDIR_FLAGS = -L${WRKSRC}/lib' >> ${WRKSRC}/.qmake.cache
+
+
.include <bsd.port.mk>
diff --git a/devel/qtcreator/distinfo b/devel/qtcreator/distinfo
index c91e3a36cb0..9af208494c4 100644
--- a/devel/qtcreator/distinfo
+++ b/devel/qtcreator/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1467899547
-SHA256 (KDE/Qt/qtcreator/qt-creator-opensource-src-4.0.3.tar.gz) = a213a9b66e7e0eb906036a1587256fc0f7bac33912d9ae5e6117459231f56449
-SIZE (KDE/Qt/qtcreator/qt-creator-opensource-src-4.0.3.tar.gz) = 21972901
+TIMESTAMP = 1472157703
+SHA256 (KDE/Qt/qtcreator/qt-creator-opensource-src-4.1.0.tar.gz) = 412c0223dbfd86983b39e10e2c7cb42b530995cfe2f3aa3529ea3f1b00ffb403
+SIZE (KDE/Qt/qtcreator/qt-creator-opensource-src-4.1.0.tar.gz) = 22342296
diff --git a/devel/qtcreator/pkg-plist b/devel/qtcreator/pkg-plist
index 777c1beb4d1..1ccf645dd0b 100644
--- a/devel/qtcreator/pkg-plist
+++ b/devel/qtcreator/pkg-plist
@@ -1,60 +1,60 @@
bin/qtcreator
lib/qtcreator/libAggregation.so
-lib/qtcreator/libAggregation.so.1
-lib/qtcreator/libAggregation.so.1.0
-lib/qtcreator/libAggregation.so.1.0.0
+lib/qtcreator/libAggregation.so.4
+lib/qtcreator/libAggregation.so.4.1
+lib/qtcreator/libAggregation.so.4.1.0
lib/qtcreator/libCPlusPlus.so
-lib/qtcreator/libCPlusPlus.so.1
-lib/qtcreator/libCPlusPlus.so.1.0
-lib/qtcreator/libCPlusPlus.so.1.0.0
+lib/qtcreator/libCPlusPlus.so.4
+lib/qtcreator/libCPlusPlus.so.4.1
+lib/qtcreator/libCPlusPlus.so.4.1.0
lib/qtcreator/libClangbackendipc.so
-lib/qtcreator/libClangbackendipc.so.1
-lib/qtcreator/libClangbackendipc.so.1.0
-lib/qtcreator/libClangbackendipc.so.1.0.0
+lib/qtcreator/libClangbackendipc.so.4
+lib/qtcreator/libClangbackendipc.so.4.1
+lib/qtcreator/libClangbackendipc.so.4.1.0
lib/qtcreator/libExtensionSystem.so
-lib/qtcreator/libExtensionSystem.so.1
-lib/qtcreator/libExtensionSystem.so.1.0
-lib/qtcreator/libExtensionSystem.so.1.0.0
+lib/qtcreator/libExtensionSystem.so.4
+lib/qtcreator/libExtensionSystem.so.4.1
+lib/qtcreator/libExtensionSystem.so.4.1.0
lib/qtcreator/libGLSL.so
-lib/qtcreator/libGLSL.so.1
-lib/qtcreator/libGLSL.so.1.0
-lib/qtcreator/libGLSL.so.1.0.0
+lib/qtcreator/libGLSL.so.4
+lib/qtcreator/libGLSL.so.4.1
+lib/qtcreator/libGLSL.so.4.1.0
lib/qtcreator/libLanguageUtils.so
-lib/qtcreator/libLanguageUtils.so.1
-lib/qtcreator/libLanguageUtils.so.1.0
-lib/qtcreator/libLanguageUtils.so.1.0.0
+lib/qtcreator/libLanguageUtils.so.4
+lib/qtcreator/libLanguageUtils.so.4.1
+lib/qtcreator/libLanguageUtils.so.4.1.0
lib/qtcreator/libModeling.so
-lib/qtcreator/libModeling.so.1
-lib/qtcreator/libModeling.so.1.0
-lib/qtcreator/libModeling.so.1.0.0
+lib/qtcreator/libModeling.so.4
+lib/qtcreator/libModeling.so.4.1
+lib/qtcreator/libModeling.so.4.1.0
lib/qtcreator/libQmlDebug.so
-lib/qtcreator/libQmlDebug.so.1
-lib/qtcreator/libQmlDebug.so.1.0
-lib/qtcreator/libQmlDebug.so.1.0.0
+lib/qtcreator/libQmlDebug.so.4
+lib/qtcreator/libQmlDebug.so.4.1
+lib/qtcreator/libQmlDebug.so.4.1.0
lib/qtcreator/libQmlEditorWidgets.so
-lib/qtcreator/libQmlEditorWidgets.so.1
-lib/qtcreator/libQmlEditorWidgets.so.1.0
-lib/qtcreator/libQmlEditorWidgets.so.1.0.0
+lib/qtcreator/libQmlEditorWidgets.so.4
+lib/qtcreator/libQmlEditorWidgets.so.4.1
+lib/qtcreator/libQmlEditorWidgets.so.4.1.0
lib/qtcreator/libQmlJS.so
-lib/qtcreator/libQmlJS.so.1
-lib/qtcreator/libQmlJS.so.1.0
-lib/qtcreator/libQmlJS.so.1.0.0
+lib/qtcreator/libQmlJS.so.4
+lib/qtcreator/libQmlJS.so.4.1
+lib/qtcreator/libQmlJS.so.4.1.0
lib/qtcreator/libQtcSsh.so
-lib/qtcreator/libQtcSsh.so.1
-lib/qtcreator/libQtcSsh.so.1.0
-lib/qtcreator/libQtcSsh.so.1.0.0
+lib/qtcreator/libQtcSsh.so.4
+lib/qtcreator/libQtcSsh.so.4.1
+lib/qtcreator/libQtcSsh.so.4.1.0
lib/qtcreator/libSqlite.so
-lib/qtcreator/libSqlite.so.1
-lib/qtcreator/libSqlite.so.1.0
-lib/qtcreator/libSqlite.so.1.0.0
+lib/qtcreator/libSqlite.so.4
+lib/qtcreator/libSqlite.so.4.1
+lib/qtcreator/libSqlite.so.4.1.0
lib/qtcreator/libTimeline.so
-lib/qtcreator/libTimeline.so.1
-lib/qtcreator/libTimeline.so.1.0
-lib/qtcreator/libTimeline.so.1.0.0
+lib/qtcreator/libTimeline.so.4
+lib/qtcreator/libTimeline.so.4.1
+lib/qtcreator/libTimeline.so.4.1.0
lib/qtcreator/libUtils.so
-lib/qtcreator/libUtils.so.1
-lib/qtcreator/libUtils.so.1.0
-lib/qtcreator/libUtils.so.1.0.0
+lib/qtcreator/libUtils.so.4
+lib/qtcreator/libUtils.so.4.1
+lib/qtcreator/libUtils.so.4.1.0
lib/qtcreator/plugins/libAndroid.so
lib/qtcreator/plugins/libAutoTest.so
lib/qtcreator/plugins/libAutotoolsProjectManager.so
@@ -87,6 +87,7 @@ lib/qtcreator/plugins/libIos.so
lib/qtcreator/plugins/libMacros.so
lib/qtcreator/plugins/libMercurial.so
lib/qtcreator/plugins/libModelEditor.so
+lib/qtcreator/plugins/libNim.so
lib/qtcreator/plugins/libPerforce.so
lib/qtcreator/plugins/libProjectExplorer.so
lib/qtcreator/plugins/libPythonEditor.so
@@ -97,7 +98,6 @@ lib/qtcreator/plugins/libQmlDesigner.so
lib/qtcreator/plugins/libQmlJSEditor.so
lib/qtcreator/plugins/libQmlJSTools.so
lib/qtcreator/plugins/libQmlProfiler.so
-lib/qtcreator/plugins/libQmlProfilerExtension.so
lib/qtcreator/plugins/libQmlProjectManager.so
lib/qtcreator/plugins/libQnx.so
lib/qtcreator/plugins/libQtSupport.so
@@ -150,6 +150,10 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/externaltools/qmlviewer.xml
%%DATADIR%%/externaltools/sort.xml
%%DATADIR%%/externaltools/vi.xml
+%%DATADIR%%/fonts/SourceCodePro-Bold.ttf
+%%DATADIR%%/fonts/SourceCodePro-It.ttf
+%%DATADIR%%/fonts/SourceCodePro-Regular.ttf
+%%DATADIR%%/fonts/SourceCodePro.txt
%%DATADIR%%/generic-highlighter/alert.xml
%%DATADIR%%/generic-highlighter/autoconf.xml
%%DATADIR%%/generic-highlighter/bash.xml
@@ -372,6 +376,7 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/CustomCheckBoxStyle.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/CustomComboBoxStyle.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/CustomSpinBoxStyle.qml
+%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/DoubleSpinBox.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/ExpandingSpacer.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/ExtendedFunctionButton.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/FlickableSection.qml
@@ -390,36 +395,13 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/SecondColumnLayout.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/Section.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/SectionLayout.qml
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/SliderSpinBox.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/SpinBox.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/StandardTextSection.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/Tab.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/TabView.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/ToolTipArea.qml
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/UrlChooser.qml
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentbottom-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentbottom-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentcenterh-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentcenterh-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentleft-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentleft-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentmiddle-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentmiddle-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentright-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmentright-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmenttop-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/alignmenttop-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/anchor-bottom.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/anchor-fill.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/anchor-horizontal.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/anchor-left.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/anchor-right.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/anchor-top.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/anchor-vertical.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/apply.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/bold-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/bold-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/cancel.png
+%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/checkers.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/down-arrow.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/down-arrow@2x.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/expression.png
@@ -427,16 +409,10 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/icon_color_gradient.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/icon_color_none.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/icon_color_solid.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/italic-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/italic-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/placeholder.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/placeholder@2x.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/strikeout-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/strikeout-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/submenu.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/submenu@2x.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/underline-h-icon.png
-%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/underline-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/up-arrow.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/up-arrow@2x.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/qmldir
@@ -479,8 +455,6 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/qmldesigner/statesEditorQmlSources/DesignerTextFieldStyle.qml
%%DATADIR%%/qmldesigner/statesEditorQmlSources/StatesDelegate.qml
%%DATADIR%%/qmldesigner/statesEditorQmlSources/StatesList.qml
-%%DATADIR%%/qmldesigner/statesEditorQmlSources/images/darkclose.png
-%%DATADIR%%/qmldesigner/statesEditorQmlSources/images/plus.png
%%DATADIR%%/qmlicons/Qt/16x16/BorderImage.png
%%DATADIR%%/qmlicons/Qt/16x16/BusyIndicator.png
%%DATADIR%%/qmlicons/Qt/16x16/Button.png
@@ -539,11 +513,15 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/snippets/cpp.xml
%%DATADIR%%/snippets/qml.xml
%%DATADIR%%/snippets/text.xml
+%%DATADIR%%/styles/creator-dark.xml
%%DATADIR%%/styles/dark.xml
%%DATADIR%%/styles/default.xml
%%DATADIR%%/styles/grayscale.xml
%%DATADIR%%/styles/inkpot.xml
%%DATADIR%%/styles/intellij.xml
+%%DATADIR%%/styles/modnokai_night_shift_v2.xml
+%%DATADIR%%/styles/solarized-dark.xml
+%%DATADIR%%/styles/solarized-light.xml
%%DATADIR%%/templates/qt4project/customwidgetwizard/tpl_collection.cpp
%%DATADIR%%/templates/qt4project/customwidgetwizard/tpl_collection.h
%%DATADIR%%/templates/qt4project/customwidgetwizard/tpl_plugin.pro
@@ -560,17 +538,19 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/templates/qt4project/mywidget_form.cpp
%%DATADIR%%/templates/qt4project/mywidget_form.h
%%DATADIR%%/templates/qt4project/widget.ui
-%%DATADIR%%/templates/shared/qrcdeployment.pri
%%DATADIR%%/templates/wizards/README.txt
-%%DATADIR%%/templates/wizards/autotest/auto.pro
%%DATADIR%%/templates/wizards/autotest/autotest_24.png
-%%DATADIR%%/templates/wizards/autotest/main.cpp
-%%DATADIR%%/templates/wizards/autotest/src.pro
-%%DATADIR%%/templates/wizards/autotest/tests.pro
-%%DATADIR%%/templates/wizards/autotest/tmp.pro
-%%DATADIR%%/templates/wizards/autotest/tst.pro
-%%DATADIR%%/templates/wizards/autotest/tst_src.cpp
-%%DATADIR%%/templates/wizards/autotest/wizard.xml
+%%DATADIR%%/templates/wizards/autotest/files/auto.pro
+%%DATADIR%%/templates/wizards/autotest/files/gtest_dependency.pri
+%%DATADIR%%/templates/wizards/autotest/files/main.cpp
+%%DATADIR%%/templates/wizards/autotest/files/src.pro
+%%DATADIR%%/templates/wizards/autotest/files/tests.pro
+%%DATADIR%%/templates/wizards/autotest/files/tmp.pro
+%%DATADIR%%/templates/wizards/autotest/files/tst.pro
+%%DATADIR%%/templates/wizards/autotest/files/tst_main.cpp
+%%DATADIR%%/templates/wizards/autotest/files/tst_src.cpp
+%%DATADIR%%/templates/wizards/autotest/files/tst_src.h
+%%DATADIR%%/templates/wizards/autotest/wizard.json
%%DATADIR%%/templates/wizards/classes/cpp/file.cpp
%%DATADIR%%/templates/wizards/classes/cpp/file.h
%%DATADIR%%/templates/wizards/classes/cpp/wizard.json
@@ -609,22 +589,29 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/templates/wizards/files/js/wizard.json
%%DATADIR%%/templates/wizards/files/modeling/file.qmodel
%%DATADIR%%/templates/wizards/files/modeling/wizard.json
+%%DATADIR%%/templates/wizards/files/nim/file.nim
+%%DATADIR%%/templates/wizards/files/nim/icon.png
+%%DATADIR%%/templates/wizards/files/nim/wizard.json
%%DATADIR%%/templates/wizards/files/python/file.py
%%DATADIR%%/templates/wizards/files/python/wizard.json
%%DATADIR%%/templates/wizards/files/qrc/file.qrc
%%DATADIR%%/templates/wizards/files/qrc/wizard.json
-%%DATADIR%%/templates/wizards/files/qtquick1/file.qml.tpl
-%%DATADIR%%/templates/wizards/files/qtquick1/wizard.json
%%DATADIR%%/templates/wizards/files/qtquick2/file.qml.tpl
%%DATADIR%%/templates/wizards/files/qtquick2/wizard.json
%%DATADIR%%/templates/wizards/files/scratch/file.txt
%%DATADIR%%/templates/wizards/files/scratch/wizard.json
+%%DATADIR%%/templates/wizards/files/scxml/file.scxml
+%%DATADIR%%/templates/wizards/files/scxml/wizard.json
%%DATADIR%%/templates/wizards/files/text/file.txt
%%DATADIR%%/templates/wizards/files/text/wizard.json
%%DATADIR%%/templates/wizards/global/consoleapplication.png
%%DATADIR%%/templates/wizards/global/genericfilewizard.png
%%DATADIR%%/templates/wizards/global/guiapplication.png
%%DATADIR%%/templates/wizards/projects/git.ignore
+%%DATADIR%%/templates/wizards/projects/nim/file.nimproject
+%%DATADIR%%/templates/wizards/projects/nim/icon.png
+%%DATADIR%%/templates/wizards/projects/nim/main.nim
+%%DATADIR%%/templates/wizards/projects/nim/wizard.json
%%DATADIR%%/templates/wizards/projects/plainc/CMakeLists.txt
%%DATADIR%%/templates/wizards/projects/plainc/file.pro
%%DATADIR%%/templates/wizards/projects/plainc/file.qbs
@@ -716,6 +703,8 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/templates/wizards/qtquick2-extension/wizard.xml
%%DATADIR%%/themes/dark.creatortheme
%%DATADIR%%/themes/default.creatortheme
+%%DATADIR%%/themes/flat-dark.creatortheme
+%%DATADIR%%/themes/flat-light.creatortheme
%%DATADIR%%/themes/flat.creatortheme
%%DATADIR%%/translations/qtcreator_cs.qm
%%DATADIR%%/translations/qtcreator_de.qm