aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qtcreator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qtcreator/Makefile')
-rw-r--r--devel/qtcreator/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 6d6117574f6..5beb470ac5b 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qtcreator
-DISTVERSION= 4.0.3
+DISTVERSION= 4.1.0
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
@@ -12,8 +12,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= C++ and QML IDE for Qt development
# depend on the split out qbs
-BUILD_DEPENDS= qbs:devel/qbs
-RUN_DEPENDS= qbs:devel/qbs
+LIB_DEPENDS= libqbscore.so:devel/qbs
USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}
USES= qmake compiler:c++11-lib
@@ -58,4 +57,16 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/bin/ant|${LOCALBASE}/bin/ant|' \
${WRKSRC}/src/plugins/android/androidsettingswidget.cpp
+pre-configure:
+# We piggyback on QMAKE_LIBDIR_FLAGS to make sure -L${WRKSRC}/lib is passed to
+# the linker before -L/usr/local/lib. By default, the opposite happens, which
+# is a problem when a Qt port is being upgraded, since an existing library
+# would end up being picked up instead of those built in ${WRKSRC}/lib. Since
+# qmake appends the value of QMAKE_LIBDIR to QMAKE_LIBDIR_FLAGS, we can use the
+# latter to get the linker path order right. qmake is smart enough to strip
+# occurrences of ${WRKSRC}/lib from .pc and .prl files when installing them.
+# See QTBUG-40825 and ports bugs 194088, 195105 and 198720.
+ ${ECHO_CMD} 'QMAKE_LIBDIR_FLAGS = -L${WRKSRC}/lib' >> ${WRKSRC}/.qmake.cache
+
+
.include <bsd.port.mk>