aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/galeon/Makefile10
-rw-r--r--www/galeon/distinfo2
-rw-r--r--www/galeon/files/patch-ab12
-rw-r--r--www/galeon/pkg-plist31
-rw-r--r--www/galeon2/Makefile10
-rw-r--r--www/galeon2/distinfo2
-rw-r--r--www/galeon2/files/patch-ab12
-rw-r--r--www/galeon2/pkg-plist31
-rw-r--r--www/mozilla-devel/files/patch-widget::src::gtksuperwin::gtkmozarea.c66
-rw-r--r--www/mozilla-vendor/files/patch-widget::src::gtksuperwin::gtkmozarea.c66
-rw-r--r--www/mozilla/files/patch-widget::src::gtksuperwin::gtkmozarea.c66
-rw-r--r--www/seamonkey/files/patch-widget::src::gtksuperwin::gtkmozarea.c66
-rw-r--r--www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c66
13 files changed, 366 insertions, 74 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index f18c5827c8f..fbf83d85d9f 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= galeon
-PORTVERSION= 0.10.5
+PORTVERSION= 0.10.6
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/sobomax/}
@@ -37,12 +37,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- -D_REENTRANT ${PTHREAD_CFLAGS} -fno-rtti" \
- LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS} ${GCC_R_LIB}"
-
-.if exists(/usr/lib/libgcc_r.a)
-GCC_R_LIB= -lgcc_r
-.endif
+ -D_REENTRANT ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS}"
post-extract:
.if !defined(WITH_FULL_MOZILLA)
diff --git a/www/galeon/distinfo b/www/galeon/distinfo
index 9a192b50290..0ea9f11e936 100644
--- a/www/galeon/distinfo
+++ b/www/galeon/distinfo
@@ -1 +1 @@
-MD5 (galeon-0.10.5.tar.gz) = 1368c32bd78bb730419cd4e9dd54031e
+MD5 (galeon-0.10.6.tar.gz) = eda0f7dc904298dcdff09e871825eaf7
diff --git a/www/galeon/files/patch-ab b/www/galeon/files/patch-ab
index 79e523a1f68..b13e0b2a87b 100644
--- a/www/galeon/files/patch-ab
+++ b/www/galeon/files/patch-ab
@@ -1,15 +1,18 @@
$FreeBSD$
---- src/galeon.orig Mon Apr 30 11:46:07 2001
-+++ src/galeon Thu May 3 14:37:04 2001
-@@ -1,17 +1,13 @@
+--- src/galeon.in 2001/05/15 11:38:39 1.1
++++ src/galeon.in 2001/05/15 11:42:43
+@@ -1,19 +1,15 @@
#!/bin/sh
-dist_bin=`dirname $0`
-
if test -n "$MOZILLA_FIVE_HOME"; then
MOZILLA_HOME=$MOZILLA_FIVE_HOME
+-elif [ -f @MOZILLA_HOME@/chrome/embed.jar ]; then
++elif [ -f @MOZILLA_HOME@/libgtkembedmoz.so ]; then
+ MOZILLA_HOME=@MOZILLA_HOME@
-elif [ -f /usr/local/mozilla/chrome/embed.jar ]; then
- MOZILLA_HOME=/usr/local/mozilla
-elif [ -f /usr/lib/mozilla/chrome/embed.jar ]; then
@@ -27,10 +30,11 @@ $FreeBSD$
else
echo "Cannot find mozilla installation directory. Please set MOZILLA_FIVE_HOME to your mozilla directory"
exit
-@@ -31,5 +27,5 @@
+@@ -34,6 +30,6 @@
if [ -f ./galeon-bin ]; then
exec ./galeon-bin "$@"
else
-exec $dist_bin/galeon-bin "$@"
+exec %%PREFIX%%/bin/galeon-bin "$@"
fi
+
diff --git a/www/galeon/pkg-plist b/www/galeon/pkg-plist
index 520860ac713..5bd4b281509 100644
--- a/www/galeon/pkg-plist
+++ b/www/galeon/pkg-plist
@@ -19,6 +19,7 @@ share/gnome/galeon/new_folder.xpm
share/gnome/galeon/new_item.xpm
share/gnome/galeon/new_separator.xpm
share/gnome/galeon/small-close.xpm
+share/gnome/galeon/small-detach.xpm
share/gnome/galeon/spinners/crux/001.png
share/gnome/galeon/spinners/crux/002.png
share/gnome/galeon/spinners/crux/003.png
@@ -98,35 +99,12 @@ share/gnome/galeon/spinners/pipeon/013.png
share/gnome/galeon/spinners/pipeon/014.png
share/gnome/galeon/spinners/pipeon/rest.png
share/gnome/help/galeon/C/aboutbook.html
-share/gnome/help/galeon/C/authors.html
-share/gnome/help/galeon/C/bookmarks-importing.html
-share/gnome/help/galeon/C/bookmarks-my-portal.html
-share/gnome/help/galeon/C/bookmarks-nicks.html
-share/gnome/help/galeon/C/bookmarks-smart-bookmarks.html
-share/gnome/help/galeon/C/bookmarks-temporary-bookmarks.html
-share/gnome/help/galeon/C/bookmarks-toolbars.html
-share/gnome/help/galeon/C/bookmarks-with-images.html
-share/gnome/help/galeon/C/bookmarks.html
share/gnome/help/galeon/C/browser-window.html
-share/gnome/help/galeon/C/bugs.html
-share/gnome/help/galeon/C/command-line-options.html
-share/gnome/help/galeon/C/compiling-from-source.html
-share/gnome/help/galeon/C/context-menus.html
-share/gnome/help/galeon/C/cookie-manager.html
-share/gnome/help/galeon/C/cookieman-images.html
-share/gnome/help/galeon/C/cookieman-sites.html
share/gnome/help/galeon/C/docbook.css
-share/gnome/help/galeon/C/full-screen-mode.html
share/gnome/help/galeon/C/getting-started.html
share/gnome/help/galeon/C/index.html
share/gnome/help/galeon/C/introduction.html
-share/gnome/help/galeon/C/preferences.html
-share/gnome/help/galeon/C/prefs-advanced.html
-share/gnome/help/galeon/C/prefs-gnome-url-handlers.html
-share/gnome/help/galeon/C/prefs-handlers.html
-share/gnome/help/galeon/C/prefs-rendering.html
-share/gnome/help/galeon/C/prefs-user-interface.html
-share/gnome/help/galeon/C/statusbar.html
+share/gnome/help/galeon/C/ln23.html
share/gnome/help/galeon/C/stylesheet-images/caution.gif
share/gnome/help/galeon/C/stylesheet-images/home.gif
share/gnome/help/galeon/C/stylesheet-images/important.gif
@@ -139,7 +117,6 @@ share/gnome/help/galeon/C/stylesheet-images/toc-minus.gif
share/gnome/help/galeon/C/stylesheet-images/toc-plus.gif
share/gnome/help/galeon/C/stylesheet-images/up.gif
share/gnome/help/galeon/C/stylesheet-images/warning.gif
-share/gnome/help/galeon/C/toolbar.html
share/gnome/oaf/galeon.oaf
share/gnome/pixmaps/galeon.png
share/gnome/sounds/galeon/clicked.wav
@@ -159,6 +136,7 @@ share/locale/it/LC_MESSAGES/galeon.mo
share/locale/ja/LC_MESSAGES/galeon.mo
share/locale/ko/LC_MESSAGES/galeon.mo
share/locale/lt/LC_MESSAGES/galeon.mo
+share/locale/ms/LC_MESSAGES/galeon.mo
share/locale/nl/LC_MESSAGES/galeon.mo
share/locale/no/LC_MESSAGES/galeon.mo
share/locale/pl/LC_MESSAGES/galeon.mo
@@ -170,7 +148,10 @@ share/locale/sl/LC_MESSAGES/galeon.mo
share/locale/sv/LC_MESSAGES/galeon.mo
share/locale/tr/LC_MESSAGES/galeon.mo
share/locale/uk/LC_MESSAGES/galeon.mo
+share/locale/zh_TW.Big5/LC_MESSAGES/galeon.mo
+@dirrm share/gnome/sounds/galeon
@dirrm share/gnome/help/galeon/C/stylesheet-images
+@exec mkdir -p %D/share/gnome/help/galeon/C/fig
@dirrm share/gnome/help/galeon/C/fig
@dirrm share/gnome/help/galeon/C
@dirrm share/gnome/help/galeon
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index f18c5827c8f..fbf83d85d9f 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= galeon
-PORTVERSION= 0.10.5
+PORTVERSION= 0.10.6
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/sobomax/}
@@ -37,12 +37,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- -D_REENTRANT ${PTHREAD_CFLAGS} -fno-rtti" \
- LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS} ${GCC_R_LIB}"
-
-.if exists(/usr/lib/libgcc_r.a)
-GCC_R_LIB= -lgcc_r
-.endif
+ -D_REENTRANT ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS}"
post-extract:
.if !defined(WITH_FULL_MOZILLA)
diff --git a/www/galeon2/distinfo b/www/galeon2/distinfo
index 9a192b50290..0ea9f11e936 100644
--- a/www/galeon2/distinfo
+++ b/www/galeon2/distinfo
@@ -1 +1 @@
-MD5 (galeon-0.10.5.tar.gz) = 1368c32bd78bb730419cd4e9dd54031e
+MD5 (galeon-0.10.6.tar.gz) = eda0f7dc904298dcdff09e871825eaf7
diff --git a/www/galeon2/files/patch-ab b/www/galeon2/files/patch-ab
index 79e523a1f68..b13e0b2a87b 100644
--- a/www/galeon2/files/patch-ab
+++ b/www/galeon2/files/patch-ab
@@ -1,15 +1,18 @@
$FreeBSD$
---- src/galeon.orig Mon Apr 30 11:46:07 2001
-+++ src/galeon Thu May 3 14:37:04 2001
-@@ -1,17 +1,13 @@
+--- src/galeon.in 2001/05/15 11:38:39 1.1
++++ src/galeon.in 2001/05/15 11:42:43
+@@ -1,19 +1,15 @@
#!/bin/sh
-dist_bin=`dirname $0`
-
if test -n "$MOZILLA_FIVE_HOME"; then
MOZILLA_HOME=$MOZILLA_FIVE_HOME
+-elif [ -f @MOZILLA_HOME@/chrome/embed.jar ]; then
++elif [ -f @MOZILLA_HOME@/libgtkembedmoz.so ]; then
+ MOZILLA_HOME=@MOZILLA_HOME@
-elif [ -f /usr/local/mozilla/chrome/embed.jar ]; then
- MOZILLA_HOME=/usr/local/mozilla
-elif [ -f /usr/lib/mozilla/chrome/embed.jar ]; then
@@ -27,10 +30,11 @@ $FreeBSD$
else
echo "Cannot find mozilla installation directory. Please set MOZILLA_FIVE_HOME to your mozilla directory"
exit
-@@ -31,5 +27,5 @@
+@@ -34,6 +30,6 @@
if [ -f ./galeon-bin ]; then
exec ./galeon-bin "$@"
else
-exec $dist_bin/galeon-bin "$@"
+exec %%PREFIX%%/bin/galeon-bin "$@"
fi
+
diff --git a/www/galeon2/pkg-plist b/www/galeon2/pkg-plist
index 520860ac713..5bd4b281509 100644
--- a/www/galeon2/pkg-plist
+++ b/www/galeon2/pkg-plist
@@ -19,6 +19,7 @@ share/gnome/galeon/new_folder.xpm
share/gnome/galeon/new_item.xpm
share/gnome/galeon/new_separator.xpm
share/gnome/galeon/small-close.xpm
+share/gnome/galeon/small-detach.xpm
share/gnome/galeon/spinners/crux/001.png
share/gnome/galeon/spinners/crux/002.png
share/gnome/galeon/spinners/crux/003.png
@@ -98,35 +99,12 @@ share/gnome/galeon/spinners/pipeon/013.png
share/gnome/galeon/spinners/pipeon/014.png
share/gnome/galeon/spinners/pipeon/rest.png
share/gnome/help/galeon/C/aboutbook.html
-share/gnome/help/galeon/C/authors.html
-share/gnome/help/galeon/C/bookmarks-importing.html
-share/gnome/help/galeon/C/bookmarks-my-portal.html
-share/gnome/help/galeon/C/bookmarks-nicks.html
-share/gnome/help/galeon/C/bookmarks-smart-bookmarks.html
-share/gnome/help/galeon/C/bookmarks-temporary-bookmarks.html
-share/gnome/help/galeon/C/bookmarks-toolbars.html
-share/gnome/help/galeon/C/bookmarks-with-images.html
-share/gnome/help/galeon/C/bookmarks.html
share/gnome/help/galeon/C/browser-window.html
-share/gnome/help/galeon/C/bugs.html
-share/gnome/help/galeon/C/command-line-options.html
-share/gnome/help/galeon/C/compiling-from-source.html
-share/gnome/help/galeon/C/context-menus.html
-share/gnome/help/galeon/C/cookie-manager.html
-share/gnome/help/galeon/C/cookieman-images.html
-share/gnome/help/galeon/C/cookieman-sites.html
share/gnome/help/galeon/C/docbook.css
-share/gnome/help/galeon/C/full-screen-mode.html
share/gnome/help/galeon/C/getting-started.html
share/gnome/help/galeon/C/index.html
share/gnome/help/galeon/C/introduction.html
-share/gnome/help/galeon/C/preferences.html
-share/gnome/help/galeon/C/prefs-advanced.html
-share/gnome/help/galeon/C/prefs-gnome-url-handlers.html
-share/gnome/help/galeon/C/prefs-handlers.html
-share/gnome/help/galeon/C/prefs-rendering.html
-share/gnome/help/galeon/C/prefs-user-interface.html
-share/gnome/help/galeon/C/statusbar.html
+share/gnome/help/galeon/C/ln23.html
share/gnome/help/galeon/C/stylesheet-images/caution.gif
share/gnome/help/galeon/C/stylesheet-images/home.gif
share/gnome/help/galeon/C/stylesheet-images/important.gif
@@ -139,7 +117,6 @@ share/gnome/help/galeon/C/stylesheet-images/toc-minus.gif
share/gnome/help/galeon/C/stylesheet-images/toc-plus.gif
share/gnome/help/galeon/C/stylesheet-images/up.gif
share/gnome/help/galeon/C/stylesheet-images/warning.gif
-share/gnome/help/galeon/C/toolbar.html
share/gnome/oaf/galeon.oaf
share/gnome/pixmaps/galeon.png
share/gnome/sounds/galeon/clicked.wav
@@ -159,6 +136,7 @@ share/locale/it/LC_MESSAGES/galeon.mo
share/locale/ja/LC_MESSAGES/galeon.mo
share/locale/ko/LC_MESSAGES/galeon.mo
share/locale/lt/LC_MESSAGES/galeon.mo
+share/locale/ms/LC_MESSAGES/galeon.mo
share/locale/nl/LC_MESSAGES/galeon.mo
share/locale/no/LC_MESSAGES/galeon.mo
share/locale/pl/LC_MESSAGES/galeon.mo
@@ -170,7 +148,10 @@ share/locale/sl/LC_MESSAGES/galeon.mo
share/locale/sv/LC_MESSAGES/galeon.mo
share/locale/tr/LC_MESSAGES/galeon.mo
share/locale/uk/LC_MESSAGES/galeon.mo
+share/locale/zh_TW.Big5/LC_MESSAGES/galeon.mo
+@dirrm share/gnome/sounds/galeon
@dirrm share/gnome/help/galeon/C/stylesheet-images
+@exec mkdir -p %D/share/gnome/help/galeon/C/fig
@dirrm share/gnome/help/galeon/C/fig
@dirrm share/gnome/help/galeon/C
@dirrm share/gnome/help/galeon
diff --git a/www/mozilla-devel/files/patch-widget::src::gtksuperwin::gtkmozarea.c b/www/mozilla-devel/files/patch-widget::src::gtksuperwin::gtkmozarea.c
new file mode 100644
index 00000000000..25b708dd049
--- /dev/null
+++ b/www/mozilla-devel/files/patch-widget::src::gtksuperwin::gtkmozarea.c
@@ -0,0 +1,66 @@
+Patch that fixes a bug with Galeon. Should go after 0.9. Obtained from
+http://bugzilla.mozilla.org/show_bug.cgi?id=79022.
+
+$FreeBSD$
+
+--- widget/src/gtksuperwin/gtkmozarea.c.orig Thu May 3 07:11:01 2001
++++ widget/src/gtksuperwin/gtkmozarea.c Tue May 22 13:46:58 2001
+@@ -25,6 +25,7 @@
+ static void gtk_mozarea_unrealize (GtkWidget *widget);
+ static void gtk_mozarea_size_allocate (GtkWidget *widget,
+ GtkAllocation *allocation);
++static void gtk_mozarea_destroy (GtkObject *object);
+
+ static void
+ attach_toplevel_listener(GtkMozArea *mozarea);
+@@ -85,6 +86,8 @@
+ widget_class->unrealize = gtk_mozarea_unrealize;
+ widget_class->size_allocate = gtk_mozarea_size_allocate;
+
++ object_class->destroy = gtk_mozarea_destroy;
++
+ parent_class = gtk_type_class(gtk_widget_get_type());
+
+ /* set up our signals */
+@@ -112,6 +115,7 @@
+ {
+ mozarea->superwin = NULL;
+ mozarea->toplevel_focus = FALSE;
++ mozarea->toplevel_window = NULL;
+ }
+
+ static void
+@@ -179,6 +183,22 @@
+ }
+ }
+
++static void
++gtk_mozarea_destroy(GtkObject *object)
++{
++ GtkMozArea *mozarea;
++
++ g_return_if_fail(GTK_IS_MOZAREA(object));
++
++ mozarea = GTK_MOZAREA(object);
++
++ /* remove the filter on the toplevel window */
++ gdk_window_remove_filter(mozarea->toplevel_window, toplevel_window_filter,
++ mozarea);
++
++ GTK_OBJECT_CLASS(parent_class)->destroy(object);
++}
++
+ GtkWidget*
+ gtk_mozarea_new (GdkWindow *parent_window)
+ {
+@@ -220,6 +240,10 @@
+ automatically be removed. */
+
+ gdk_window_add_filter(gdk_window, toplevel_window_filter, mozarea);
++
++ /* save it so that we can remove the filter later */
++
++ mozarea->toplevel_window = gdk_window;
+ }
+
+ /* this function will try to find the real toplevel for a gdk window. */
diff --git a/www/mozilla-vendor/files/patch-widget::src::gtksuperwin::gtkmozarea.c b/www/mozilla-vendor/files/patch-widget::src::gtksuperwin::gtkmozarea.c
new file mode 100644
index 00000000000..25b708dd049
--- /dev/null
+++ b/www/mozilla-vendor/files/patch-widget::src::gtksuperwin::gtkmozarea.c
@@ -0,0 +1,66 @@
+Patch that fixes a bug with Galeon. Should go after 0.9. Obtained from
+http://bugzilla.mozilla.org/show_bug.cgi?id=79022.
+
+$FreeBSD$
+
+--- widget/src/gtksuperwin/gtkmozarea.c.orig Thu May 3 07:11:01 2001
++++ widget/src/gtksuperwin/gtkmozarea.c Tue May 22 13:46:58 2001
+@@ -25,6 +25,7 @@
+ static void gtk_mozarea_unrealize (GtkWidget *widget);
+ static void gtk_mozarea_size_allocate (GtkWidget *widget,
+ GtkAllocation *allocation);
++static void gtk_mozarea_destroy (GtkObject *object);
+
+ static void
+ attach_toplevel_listener(GtkMozArea *mozarea);
+@@ -85,6 +86,8 @@
+ widget_class->unrealize = gtk_mozarea_unrealize;
+ widget_class->size_allocate = gtk_mozarea_size_allocate;
+
++ object_class->destroy = gtk_mozarea_destroy;
++
+ parent_class = gtk_type_class(gtk_widget_get_type());
+
+ /* set up our signals */
+@@ -112,6 +115,7 @@
+ {
+ mozarea->superwin = NULL;
+ mozarea->toplevel_focus = FALSE;
++ mozarea->toplevel_window = NULL;
+ }
+
+ static void
+@@ -179,6 +183,22 @@
+ }
+ }
+
++static void
++gtk_mozarea_destroy(GtkObject *object)
++{
++ GtkMozArea *mozarea;
++
++ g_return_if_fail(GTK_IS_MOZAREA(object));
++
++ mozarea = GTK_MOZAREA(object);
++
++ /* remove the filter on the toplevel window */
++ gdk_window_remove_filter(mozarea->toplevel_window, toplevel_window_filter,
++ mozarea);
++
++ GTK_OBJECT_CLASS(parent_class)->destroy(object);
++}
++
+ GtkWidget*
+ gtk_mozarea_new (GdkWindow *parent_window)
+ {
+@@ -220,6 +240,10 @@
+ automatically be removed. */
+
+ gdk_window_add_filter(gdk_window, toplevel_window_filter, mozarea);
++
++ /* save it so that we can remove the filter later */
++
++ mozarea->toplevel_window = gdk_window;
+ }
+
+ /* this function will try to find the real toplevel for a gdk window. */
diff --git a/www/mozilla/files/patch-widget::src::gtksuperwin::gtkmozarea.c b/www/mozilla/files/patch-widget::src::gtksuperwin::gtkmozarea.c
new file mode 100644
index 00000000000..25b708dd049
--- /dev/null
+++ b/www/mozilla/files/patch-widget::src::gtksuperwin::gtkmozarea.c
@@ -0,0 +1,66 @@
+Patch that fixes a bug with Galeon. Should go after 0.9. Obtained from
+http://bugzilla.mozilla.org/show_bug.cgi?id=79022.
+
+$FreeBSD$
+
+--- widget/src/gtksuperwin/gtkmozarea.c.orig Thu May 3 07:11:01 2001
++++ widget/src/gtksuperwin/gtkmozarea.c Tue May 22 13:46:58 2001
+@@ -25,6 +25,7 @@
+ static void gtk_mozarea_unrealize (GtkWidget *widget);
+ static void gtk_mozarea_size_allocate (GtkWidget *widget,
+ GtkAllocation *allocation);
++static void gtk_mozarea_destroy (GtkObject *object);
+
+ static void
+ attach_toplevel_listener(GtkMozArea *mozarea);
+@@ -85,6 +86,8 @@
+ widget_class->unrealize = gtk_mozarea_unrealize;
+ widget_class->size_allocate = gtk_mozarea_size_allocate;
+
++ object_class->destroy = gtk_mozarea_destroy;
++
+ parent_class = gtk_type_class(gtk_widget_get_type());
+
+ /* set up our signals */
+@@ -112,6 +115,7 @@
+ {
+ mozarea->superwin = NULL;
+ mozarea->toplevel_focus = FALSE;
++ mozarea->toplevel_window = NULL;
+ }
+
+ static void
+@@ -179,6 +183,22 @@
+ }
+ }
+
++static void
++gtk_mozarea_destroy(GtkObject *object)
++{
++ GtkMozArea *mozarea;
++
++ g_return_if_fail(GTK_IS_MOZAREA(object));
++
++ mozarea = GTK_MOZAREA(object);
++
++ /* remove the filter on the toplevel window */
++ gdk_window_remove_filter(mozarea->toplevel_window, toplevel_window_filter,
++ mozarea);
++
++ GTK_OBJECT_CLASS(parent_class)->destroy(object);
++}
++
+ GtkWidget*
+ gtk_mozarea_new (GdkWindow *parent_window)
+ {
+@@ -220,6 +240,10 @@
+ automatically be removed. */
+
+ gdk_window_add_filter(gdk_window, toplevel_window_filter, mozarea);
++
++ /* save it so that we can remove the filter later */
++
++ mozarea->toplevel_window = gdk_window;
+ }
+
+ /* this function will try to find the real toplevel for a gdk window. */
diff --git a/www/seamonkey/files/patch-widget::src::gtksuperwin::gtkmozarea.c b/www/seamonkey/files/patch-widget::src::gtksuperwin::gtkmozarea.c
new file mode 100644
index 00000000000..25b708dd049
--- /dev/null
+++ b/www/seamonkey/files/patch-widget::src::gtksuperwin::gtkmozarea.c
@@ -0,0 +1,66 @@
+Patch that fixes a bug with Galeon. Should go after 0.9. Obtained from
+http://bugzilla.mozilla.org/show_bug.cgi?id=79022.
+
+$FreeBSD$
+
+--- widget/src/gtksuperwin/gtkmozarea.c.orig Thu May 3 07:11:01 2001
++++ widget/src/gtksuperwin/gtkmozarea.c Tue May 22 13:46:58 2001
+@@ -25,6 +25,7 @@
+ static void gtk_mozarea_unrealize (GtkWidget *widget);
+ static void gtk_mozarea_size_allocate (GtkWidget *widget,
+ GtkAllocation *allocation);
++static void gtk_mozarea_destroy (GtkObject *object);
+
+ static void
+ attach_toplevel_listener(GtkMozArea *mozarea);
+@@ -85,6 +86,8 @@
+ widget_class->unrealize = gtk_mozarea_unrealize;
+ widget_class->size_allocate = gtk_mozarea_size_allocate;
+
++ object_class->destroy = gtk_mozarea_destroy;
++
+ parent_class = gtk_type_class(gtk_widget_get_type());
+
+ /* set up our signals */
+@@ -112,6 +115,7 @@
+ {
+ mozarea->superwin = NULL;
+ mozarea->toplevel_focus = FALSE;
++ mozarea->toplevel_window = NULL;
+ }
+
+ static void
+@@ -179,6 +183,22 @@
+ }
+ }
+
++static void
++gtk_mozarea_destroy(GtkObject *object)
++{
++ GtkMozArea *mozarea;
++
++ g_return_if_fail(GTK_IS_MOZAREA(object));
++
++ mozarea = GTK_MOZAREA(object);
++
++ /* remove the filter on the toplevel window */
++ gdk_window_remove_filter(mozarea->toplevel_window, toplevel_window_filter,
++ mozarea);
++
++ GTK_OBJECT_CLASS(parent_class)->destroy(object);
++}
++
+ GtkWidget*
+ gtk_mozarea_new (GdkWindow *parent_window)
+ {
+@@ -220,6 +240,10 @@
+ automatically be removed. */
+
+ gdk_window_add_filter(gdk_window, toplevel_window_filter, mozarea);
++
++ /* save it so that we can remove the filter later */
++
++ mozarea->toplevel_window = gdk_window;
+ }
+
+ /* this function will try to find the real toplevel for a gdk window. */
diff --git a/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c b/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c
new file mode 100644
index 00000000000..25b708dd049
--- /dev/null
+++ b/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c
@@ -0,0 +1,66 @@
+Patch that fixes a bug with Galeon. Should go after 0.9. Obtained from
+http://bugzilla.mozilla.org/show_bug.cgi?id=79022.
+
+$FreeBSD$
+
+--- widget/src/gtksuperwin/gtkmozarea.c.orig Thu May 3 07:11:01 2001
++++ widget/src/gtksuperwin/gtkmozarea.c Tue May 22 13:46:58 2001
+@@ -25,6 +25,7 @@
+ static void gtk_mozarea_unrealize (GtkWidget *widget);
+ static void gtk_mozarea_size_allocate (GtkWidget *widget,
+ GtkAllocation *allocation);
++static void gtk_mozarea_destroy (GtkObject *object);
+
+ static void
+ attach_toplevel_listener(GtkMozArea *mozarea);
+@@ -85,6 +86,8 @@
+ widget_class->unrealize = gtk_mozarea_unrealize;
+ widget_class->size_allocate = gtk_mozarea_size_allocate;
+
++ object_class->destroy = gtk_mozarea_destroy;
++
+ parent_class = gtk_type_class(gtk_widget_get_type());
+
+ /* set up our signals */
+@@ -112,6 +115,7 @@
+ {
+ mozarea->superwin = NULL;
+ mozarea->toplevel_focus = FALSE;
++ mozarea->toplevel_window = NULL;
+ }
+
+ static void
+@@ -179,6 +183,22 @@
+ }
+ }
+
++static void
++gtk_mozarea_destroy(GtkObject *object)
++{
++ GtkMozArea *mozarea;
++
++ g_return_if_fail(GTK_IS_MOZAREA(object));
++
++ mozarea = GTK_MOZAREA(object);
++
++ /* remove the filter on the toplevel window */
++ gdk_window_remove_filter(mozarea->toplevel_window, toplevel_window_filter,
++ mozarea);
++
++ GTK_OBJECT_CLASS(parent_class)->destroy(object);
++}
++
+ GtkWidget*
+ gtk_mozarea_new (GdkWindow *parent_window)
+ {
+@@ -220,6 +240,10 @@
+ automatically be removed. */
+
+ gdk_window_add_filter(gdk_window, toplevel_window_filter, mozarea);
++
++ /* save it so that we can remove the filter later */
++
++ mozarea->toplevel_window = gdk_window;
+ }
+
+ /* this function will try to find the real toplevel for a gdk window. */