aboutsummaryrefslogtreecommitdiffstats
path: root/games/umark/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/umark/files/Makefile')
-rw-r--r--games/umark/files/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/games/umark/files/Makefile b/games/umark/files/Makefile
new file mode 100644
index 00000000000..561e4ce178c
--- /dev/null
+++ b/games/umark/files/Makefile
@@ -0,0 +1,24 @@
+#
+# $FreeBSD$
+#
+
+BIN= umark
+
+INCS= `pkg-config gtk+-2.0 --cflags`
+DEFS= -DPACKAGE_DATA_DIR=\"${PREFIX}/share\" -DPACKAGE=\"${BIN}\"
+LIBS= `pkg-config gtk+-2.0 --libs`
+
+OBJS = \
+ callbacks.o \
+ interface.o \
+ main.o \
+ support.o \
+
+.c.o:
+ ${CC} ${CFLAGS} ${DEFS} ${INCS} -c $< -o $*.o
+
+all: ${OBJS}
+ ${CC} ${CFLAGS} -o ${BIN} ${OBJS} ${LIBS}
+
+clean:
+ -rm -f *.o *.core