aboutsummaryrefslogtreecommitdiffstats
path: root/games/umark/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/umark/files')
-rw-r--r--games/umark/files/Makefile24
-rw-r--r--games/umark/files/pkg-message.in22
2 files changed, 46 insertions, 0 deletions
diff --git a/games/umark/files/Makefile b/games/umark/files/Makefile
new file mode 100644
index 00000000000..561e4ce178c
--- /dev/null
+++ b/games/umark/files/Makefile
@@ -0,0 +1,24 @@
+#
+# $FreeBSD$
+#
+
+BIN= umark
+
+INCS= `pkg-config gtk+-2.0 --cflags`
+DEFS= -DPACKAGE_DATA_DIR=\"${PREFIX}/share\" -DPACKAGE=\"${BIN}\"
+LIBS= `pkg-config gtk+-2.0 --libs`
+
+OBJS = \
+ callbacks.o \
+ interface.o \
+ main.o \
+ support.o \
+
+.c.o:
+ ${CC} ${CFLAGS} ${DEFS} ${INCS} -c $< -o $*.o
+
+all: ${OBJS}
+ ${CC} ${CFLAGS} -o ${BIN} ${OBJS} ${LIBS}
+
+clean:
+ -rm -f *.o *.core
diff --git a/games/umark/files/pkg-message.in b/games/umark/files/pkg-message.in
new file mode 100644
index 00000000000..bb8725c0def
--- /dev/null
+++ b/games/umark/files/pkg-message.in
@@ -0,0 +1,22 @@
+
+Before running this software, you'll need to configure it first. This is
+best to be done with `install_umark_data.sh' script, which is installed
+here:
+
+ %%DATADIR%%/install_umark_data.sh
+
+It should be run from %%DATADIR%%.
+
+If you want to manually configure the UT200x install paths, you may edit
+your ~/.umarkrc file. The ~/.umarkrc file format is as follows (in order):
+
+BuildNumber|/UT2003/Retail/install/path
+BuildNumber|/UT2004/Retail/install/path
+BuildNumber|/UT2003/Demo/install/path
+BuildNumber|/UT2004/Demo/install/path
+
+If one of the lines says "n/a|n/a", it means that `install_umark_data.sh'
+did not find where the respective version of the game is installed. In this
+case, you should manually enter the game build number and root installation
+path.
+