aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/ehnt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/ehnt/Makefile')
-rw-r--r--net-mgmt/ehnt/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-mgmt/ehnt/Makefile b/net-mgmt/ehnt/Makefile
index 6bd26da01fb..3338782d645 100644
--- a/net-mgmt/ehnt/Makefile
+++ b/net-mgmt/ehnt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ehnt
PORTVERSION= 0.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,6 +17,12 @@ COMMENT= A simple Cisco NetFlow data collector
USE_PERL5= yes
+PLIST_FILES= bin/ehnt etc/rc.d/ehntserv.sh.sample \
+ sbin/ehntserv share/ehnt/asnc.txt
+PLIST_DIRS+= share/ehnt
+
+PORTDOCS= README
+
MAN1= ehnt.1
MAN8= ehntserv.8
@@ -29,11 +35,11 @@ do-install:
${INSTALL_SCRIPT} ${FILESDIR}/ehntserv.sh.sample ${PREFIX}/etc/rc.d/
${INSTALL_MAN} ${WRKSRC}/ehnt.1 ${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/ehntserv.8 ${PREFIX}/man/man8/
- ${MKDIR} ${PREFIX}/share/ehnt
- ${INSTALL_DATA} ${WRKSRC}/asnc.txt ${PREFIX}/share/ehnt/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/asnc.txt ${DATADIR}/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ehnt
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ehnt/
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
.endif
.include <bsd.port.mk>