aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ehnt/Makefile16
-rw-r--r--net-mgmt/ehnt/files/patch-ehnt.h14
-rw-r--r--net-mgmt/ehnt/files/patch-ehnt__display.c14
-rw-r--r--net-mgmt/ehnt/files/patch-ehnt__processflow.c11
-rw-r--r--net-mgmt/ehnt/pkg-plist7
5 files changed, 49 insertions, 13 deletions
diff --git a/net-mgmt/ehnt/Makefile b/net-mgmt/ehnt/Makefile
index 6bd26da01fb..3338782d645 100644
--- a/net-mgmt/ehnt/Makefile
+++ b/net-mgmt/ehnt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ehnt
PORTVERSION= 0.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,6 +17,12 @@ COMMENT= A simple Cisco NetFlow data collector
USE_PERL5= yes
+PLIST_FILES= bin/ehnt etc/rc.d/ehntserv.sh.sample \
+ sbin/ehntserv share/ehnt/asnc.txt
+PLIST_DIRS+= share/ehnt
+
+PORTDOCS= README
+
MAN1= ehnt.1
MAN8= ehntserv.8
@@ -29,11 +35,11 @@ do-install:
${INSTALL_SCRIPT} ${FILESDIR}/ehntserv.sh.sample ${PREFIX}/etc/rc.d/
${INSTALL_MAN} ${WRKSRC}/ehnt.1 ${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/ehntserv.8 ${PREFIX}/man/man8/
- ${MKDIR} ${PREFIX}/share/ehnt
- ${INSTALL_DATA} ${WRKSRC}/asnc.txt ${PREFIX}/share/ehnt/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/asnc.txt ${DATADIR}/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ehnt
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ehnt/
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/ehnt/files/patch-ehnt.h b/net-mgmt/ehnt/files/patch-ehnt.h
new file mode 100644
index 00000000000..01c7f6df9ae
--- /dev/null
+++ b/net-mgmt/ehnt/files/patch-ehnt.h
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ehnt.h.orig Thu Oct 4 22:18:29 2001
++++ ehnt.h Thu May 20 16:07:24 2004
+@@ -93,7 +93,7 @@
+ int ProcessFlow(struct flow_ver5_rec *, struct in_addr *, struct ehnt_struct *);
+ int Init_ASN_Lookups(void);
+ char * ASN_Lookup(int);
+-char * prettybytes(int);
++char * prettybytes(unsigned);
+ void DisplayReport(time_t, struct ehnt_data *);
+
+ /* these EM_ defines are for the mode config variable */
diff --git a/net-mgmt/ehnt/files/patch-ehnt__display.c b/net-mgmt/ehnt/files/patch-ehnt__display.c
new file mode 100644
index 00000000000..a88d3358633
--- /dev/null
+++ b/net-mgmt/ehnt/files/patch-ehnt__display.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ehnt_display.c.orig Thu Oct 4 22:18:29 2001
++++ ehnt_display.c Thu May 20 16:06:07 2004
+@@ -246,7 +246,7 @@
+
+ static char str[100];
+
+-char * prettybytes(int bytes) {
++char * prettybytes(unsigned bytes) {
+
+ if (bytes < 1024) sprintf(str,"%4d", bytes);
+ else if (bytes < (1024*1024)) sprintf(str,"%4dK",(bytes/1024));
diff --git a/net-mgmt/ehnt/files/patch-ehnt__processflow.c b/net-mgmt/ehnt/files/patch-ehnt__processflow.c
index 7441034b9ce..c89c2a04641 100644
--- a/net-mgmt/ehnt/files/patch-ehnt__processflow.c
+++ b/net-mgmt/ehnt/files/patch-ehnt__processflow.c
@@ -2,7 +2,7 @@
$FreeBSD$
--- ehnt_processflow.c.orig Thu Oct 4 22:18:29 2001
-+++ ehnt_processflow.c Thu Nov 14 22:17:18 2002
++++ ehnt_processflow.c Fri May 21 11:22:02 2004
@@ -218,7 +218,7 @@
dstip.s_addr=rec->dstaddr;
nexthop.s_addr=rec->nexthop;
@@ -12,3 +12,12 @@ $FreeBSD$
printf("%d:%s:%d:",
rec->input_index,
inet_ntoa(srcip),
+@@ -228,7 +228,7 @@
+ inet_ntoa(dstip),
+ rec->dstport);
+
+- printf("%d:%d:%d:",rec->dOctets,rec->dPkts,rec->prot);
++ printf("%u:%d:%d:",rec->dOctets,rec->dPkts,rec->prot);
+ printf("%d:%d\n",rec->src_as,rec->dst_as);
+
+ if (e_flt->big) {
diff --git a/net-mgmt/ehnt/pkg-plist b/net-mgmt/ehnt/pkg-plist
deleted file mode 100644
index f9c8a00996b..00000000000
--- a/net-mgmt/ehnt/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/ehnt
-etc/rc.d/ehntserv.sh.sample
-sbin/ehntserv
-%%PORTDOCS%%%%DOCSDIR%%/README
-share/ehnt/asnc.txt
-@dirrm share/ehnt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%