aboutsummaryrefslogtreecommitdiffstats
path: root/print/latex-timing/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/latex-timing/Makefile')
-rw-r--r--print/latex-timing/Makefile77
1 files changed, 77 insertions, 0 deletions
diff --git a/print/latex-timing/Makefile b/print/latex-timing/Makefile
new file mode 100644
index 00000000000..cdd006a7fc1
--- /dev/null
+++ b/print/latex-timing/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: latex-timing
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-timing
+PORTVERSION= 1.0.19940515
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/timing
+DISTFILES= ${DOC_FILES} ${CLASS_FILES} ${MF_FILES} ${PK_FILES} ${TFM_FILES}
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= #empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package for drawing timing diagrams
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= YES
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+PLIST_SUB+= MFDIR=${MFDIR} TFMDIR=${TFMDIR} PKDIR=${PKDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+MFDIR= ${TEXMFLOCAL}/fonts/source/public/${PORTNAME:S/^latex-//}
+TFMDIR= ${TEXMFLOCAL}/fonts/tfm/${PORTNAME:S/^latex-//}
+PKDIR= ${TEXMFLOCAL}/fonts/pk/${PORTNAME:S/^latex-//}
+
+DOC_FILES= read.me
+DOC_FILES+= timing.dvi
+DOC_FILES+= timing.tex
+DOC_FILES+= prozt1.tex
+DOC_FILES+= tim0594.upl
+
+CLASS_FILES= timing.sty
+
+MF_FILES= timing.mf
+MF_FILES+= timing1.mf
+MF_FILES+= timing1s.mf
+MF_FILES+= timing2.mf
+MF_FILES+= timing2s.mf
+
+PK_FILES= timing1.pk
+PK_FILES+= timing1s.pk
+PK_FILES+= timing2.pk
+PK_FILES+= timing2s.pk
+
+TFM_FILES= timing1.tfm
+TFM_FILES+= timing1s.tfm
+TFM_FILES+= timing2.tfm
+TFM_FILES+= timing2s.tfm
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${PREFIX}/${CLASSDIR}
+ ${MKDIR} ${PREFIX}/${MFDIR}
+ ${INSTALL_DATA} ${MF_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${PREFIX}/${MFDIR}
+ ${MKDIR} ${PREFIX}/${TFMDIR}
+ ${INSTALL_DATA} ${TFM_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${PREFIX}/${TFMDIR}
+ ${MKDIR} ${PREFIX}/${PKDIR}
+ ${INSTALL_DATA} ${PK_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${PREFIX}/${PKDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
support.itetcu2007-04-191-28/+7 * Add OPTIONS support.itetcu2007-04-191-32/+8 * - De-4.x-ify most of my ports to save gnats from excessive abusesat2007-04-184-11/+5 * - Update to 3.17.1miwi2007-04-182-6/+6 * - Update to 4.2miwi2007-04-183-24/+52 * Add port x11-toolkits/p5-Tk-DKW:sat2007-04-176-0/+88 * Add port x11-toolkits/p5-Tk-FontDialog:sat2007-04-175-0/+42 * Add port x11-toolkits/p5-Tk-Contrib:sat2007-04-175-0/+46 * - added contents of x11-toolkits/tk-wrapper (missing in previous commit)mm2007-04-162-0/+17 * - move tk-wrapper from lang to x11-toolkitsmm2007-04-161-0/+1 * Fix recorded prefix in pkgconfig file.lofi2007-04-151-1/+3 * Change my email address to trasz@FreeBSD.org.trasz2007-04-131-1/+1 * - fixed pkgIndex.tcl for threadsmm2007-04-126-9/+15 * Explicitly add some more dependencies which were previously generationaltmclaugh2007-04-121-2/+3 * update xfce to 4.4.1oliver2007-04-123-4/+5 * Update to 2.18.2.marcus2007-04-112-4/+4 * Update to 2.18.1.marcus2007-04-112-4/+4 * Update to 0.16.1ahze2007-04-103-2790/+4 * Update to 1.16.2ahze2007-04-102-4/+4 * Remove file that was missed when the rest of the port waserwin2007-04-061-29/+0 * - Remove old Perl support from unmaintained ports in categories startinggabor2007-04-066-39/+5 * - updated maintainer e-mail addressmm2007-04-059-11/+11 * - Use a static PORTEPOCH for a while. We have a problem with the variablestas2007-04-051-1/+1 * - Give maintainership to Araujo since he takes care for other fox andrafan2007-04-041-1/+1 * - Update to latest version (3.3M6)clsung2007-04-044-53/+27 * - Update ruby to 1.8.6stas2007-04-042-1030/+1034 * - Convert existing ports to a new bsd.tcl.mk orderpav2007-04-035-16/+9 * Fix handling of overlong UTF8 sequences in Qt and kdelibs, which, unpatched,lofi2007-03-312-0/+102 * - Remove ruby-fox and rudy-fox-devel. They are renamed torafan2007-03-307-325/+0 * Update to 0.7.3.mezz2007-03-302-4/+4 * - Fix after objformat removalpav2007-03-291-2/+2 * - Update to 1.9.14nivit2007-03-293-13/+77 * - Trasnfer maintainership from alecn2002@yandex.ru torafan2007-03-294-29/+28 * - define OPTIONS only for master portrafan2007-03-291-0/+2 * Add fxscintilla-fox14 , a Fox toolkit reimplementation of Scintillarafan2007-03-292-0/+14 * Rename ruby-fox* for supporting multiple fox library versionrafan2007-03-291-2/+2 * - Chase x11-toolkits/fxscintilla updaterafan2007-03-292-5/+9 * - Update to 1.71rafan2007-03-293-11/+17 * - Fix after objformat removalpav2007-03-294-16/+6 * - Change my email.stas2007-03-282-2/+2 * - Mark CONFLICTS with qwt-develpav2007-03-272-0/+8 * - Remove support for lang/tcl-tk-wrappermiwi2007-03-276-42/+12 * PyQt4 is a set of Python bindings for Trolltech's Qt4 application framework.miwi2007-03-276-0/+406 * - Update to 20070220miwi2007-03-272-7/+7 * Portlint:mezz2007-03-272-2/+2 * - Update to 1.144clsung2007-03-262-4/+4 * - Fix buildpav2007-03-251-1/+0 * Update to 4.2.3lofi2007-03-253-8/+8 * Clean up the lines that has been disable the workaround of SSE2 bug for aboutmezz2007-03-252-18/+0 * - bsd.efl.mk is now in ports/Mkpav2007-03-243-10/+2 * Sync vte with GNOME SVN to fix quite a few outstanding problems. Inmarcus2007-03-242-1/+2787 * - Fix build: remove USE_GMAKE, since recently p5-Glib2 is BSD make friendlypav2007-03-223-3/+0 * GtkUnique is a library to facilitate programming single instance applications -pav2007-03-225-0/+88 * Use the ports libtool to not build the static libraryarved2007-03-211-1/+0 * Fix build with gcc41 (on amd64)lofi2007-03-211-0/+11 * Update to 3.3.8lofi2007-03-218-43/+257 * - Update to 1.3acm2007-03-215-57/+114 * - Fix buildmiwi2007-03-213-0/+12 * Adds a new way of working with threaded versions andmiwi2007-03-203-32/+49 * Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOMEmarcus2007-03-1950-199/+370 * - Update to 1.6.21rafan2007-03-192-4/+4 * - Update to snapshot r5746rafan2007-03-193-4/+5 * Remove the special handing of WITH_DEBUG since this is taken care of inmarcus2007-03-192-56/+2 * n -CURRENT, bsdtar will preserve the attributes of the archive automaticallymarcus2007-03-191-0/+2 * Fix build after objformat removalarved2007-03-181-1/+6 * Second try at fixing the plistarved2007-03-181-0/+3 * Don't build gtk1 support per defaultarved2007-03-181-2/+2 * Fix pkg-plist after objformat removalarved2007-03-181-0/+1 * - Update to 1.4.1pav2007-03-173-5/+5 * - Update to 4.50.97pav2007-03-173-40/+4 * Update to 1.2.3tmclaugh2007-03-172-6/+6 * Remove 4.X cruft.linimon2007-03-171-4/+0 * - Aadds a new way of working with threaded versions andmiwi2007-03-1710-72/+124