aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-01-24 13:09:48 +0800
committerlinimon <linimon@FreeBSD.org>2019-01-24 13:09:48 +0800
commitfe75b475a6f7bf46fca5415aeb922dfe779ce980 (patch)
treefa89a75b73956428bc897f157b427c0be996064d /net-p2p
parent7d44a24992ac1c8f3e1d347d873f56ca1e3e358f (diff)
downloadfreebsd-ports-gnome-fe75b475a6f7bf46fca5415aeb922dfe779ce980.tar.gz
freebsd-ports-gnome-fe75b475a6f7bf46fca5415aeb922dfe779ce980.tar.zst
freebsd-ports-gnome-fe75b475a6f7bf46fca5415aeb922dfe779ce980.zip
Conditionalize the dependence of libunwind to x86-only to allow building
these ports on !x86. libunwind is only available for x86; lang/ruby* already expresses this correctly. Some of the rubygems did not: for the ones that already had USE_RUBY, the dependency was overspecified in the first place. Tested for no-harm on amd64. While here, pet portlint where appropriate. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero-cli/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 9e07fb1ac5c6..b80a4f987e84 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -35,7 +35,6 @@ LIB_DEPENDS= \
libpgm.so:net/openpgm \
libsodium.so:security/libsodium \
libunbound.so:dns/unbound \
- libunwind.so:devel/libunwind \
libzmq.so:net/libzmq4
BUILD_DEPENDS= ${LOCALBASE}/include/rapidjson/document.h:devel/rapidjson \
${LOCALBASE}/include/zmq.hpp:net/cppzmq
@@ -80,6 +79,11 @@ CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
.endif
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
CMAKE_ARGS+= -DMANUAL_SUBMODULES:BOOL=ON
USE_RC_SUBR= monerod