aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero-cli/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 9e07fb1ac5c6..b80a4f987e84 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -35,7 +35,6 @@ LIB_DEPENDS= \
libpgm.so:net/openpgm \
libsodium.so:security/libsodium \
libunbound.so:dns/unbound \
- libunwind.so:devel/libunwind \
libzmq.so:net/libzmq4
BUILD_DEPENDS= ${LOCALBASE}/include/rapidjson/document.h:devel/rapidjson \
${LOCALBASE}/include/zmq.hpp:net/cppzmq
@@ -80,6 +79,11 @@ CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
.endif
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
CMAKE_ARGS+= -DMANUAL_SUBMODULES:BOOL=ON
USE_RC_SUBR= monerod