aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-20 03:17:45 +0800
committerRong-En Fan <rafan@FreeBSD.org>2006-07-20 03:17:45 +0800
commit499887a1231954c188aa042b8b51601ca33b125c (patch)
treeeef69893877410a743c52d3da1a6db3ef6322f42
parentec97c639b24667e8d95419a71a09e2fa59289754 (diff)
downloadfreebsd-ports-499887a1231954c188aa042b8b51601ca33b125c.tar.gz
freebsd-ports-499887a1231954c188aa042b8b51601ca33b125c.tar.zst
freebsd-ports-499887a1231954c188aa042b8b51601ca33b125c.zip
- Update to 1.01
- Respect PREFIX PR: ports/100566 Submitted by: KATO Tsuguru
Notes
Notes: svn path=/head/; revision=168264
-rw-r--r--www/twhttpd/Makefile18
-rw-r--r--www/twhttpd/distinfo6
-rw-r--r--www/twhttpd/files/patch-ab16
-rw-r--r--www/twhttpd/files/patch-ad11
-rw-r--r--www/twhttpd/files/patch-cfg_functions.c15
-rw-r--r--www/twhttpd/files/patch-cfg_parser.y14
-rw-r--r--www/twhttpd/files/patch-config.h (renamed from www/twhttpd/files/patch-aa)2
-rw-r--r--www/twhttpd/files/patch-httplog.c16
-rw-r--r--www/twhttpd/files/patch-twhttpd.c (renamed from www/twhttpd/files/patch-ac)18
-rw-r--r--www/twhttpd/files/pkg-message.in (renamed from www/twhttpd/pkg-message)4
10 files changed, 73 insertions, 47 deletions
diff --git a/www/twhttpd/Makefile b/www/twhttpd/Makefile
index 194862a14472..8454ff674ee6 100644
--- a/www/twhttpd/Makefile
+++ b/www/twhttpd/Makefile
@@ -6,23 +6,25 @@
#
PORTNAME= twhttpd
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.01
CATEGORIES= www
MASTER_SITES= http://www.geocities.com/samngms/twhttpd/download/
-DISTNAME= twhttpd-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Secure HTTP Proxy
-GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:213
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-lmd"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
+ @${REINPLACE_CMD} -e 's| md5\.o | |g' ${WRKSRC}/Makefile.in
do-install:
- @${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
- @${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
- @${INSTALL} -o root -g wheel -m 0700 ${WRKSRC}/twhttpd.cfg ${PREFIX}/etc/twhttpd.cfg.sample
+ ${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
+ ${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
+ ${INSTALL} -o root -g wheel -m 0700 ${WRKSRC}/twhttpd.cfg ${PREFIX}/etc/twhttpd.cfg.sample
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/twhttpd/distinfo b/www/twhttpd/distinfo
index 7ddf0463f1cb..e06e54adb90b 100644
--- a/www/twhttpd/distinfo
+++ b/www/twhttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (twhttpd-1.0.tar.gz) = 09b49b470e689fc1e5917b9503cea71d
-SHA256 (twhttpd-1.0.tar.gz) = 181f4e52ac93db12dc7016a1596147fdcbbc2c11683572ab30a4ceb2aa990e1a
-SIZE (twhttpd-1.0.tar.gz) = 99836
+MD5 (twhttpd-1.01.tar.gz) = 315b5687f74f863517370ad2fcbf296f
+SHA256 (twhttpd-1.01.tar.gz) = 3924847d6ef5667c18ce2221b296e30279e382fe2d76fad06439c988709ebd85
+SIZE (twhttpd-1.01.tar.gz) = 104312
diff --git a/www/twhttpd/files/patch-ab b/www/twhttpd/files/patch-ab
deleted file mode 100644
index 21c2a4f895ab..000000000000
--- a/www/twhttpd/files/patch-ab
+++ /dev/null
@@ -1,16 +0,0 @@
---- httplog.c.orig Sat Dec 8 15:15:44 2001
-+++ httplog.c Wed Sep 25 12:02:28 2002
-@@ -40,6 +40,7 @@
- #include <time.h>
- #include <stdio.h>
- #include <syslog.h>
-+#include <arpa/inet.h>
- #include <netinet/in.h>
- #include <sys/time.h>
- #include <sys/socket.h>
-@@ -151,4 +152,4 @@
- }
- }
- }
--}
-+}
diff --git a/www/twhttpd/files/patch-ad b/www/twhttpd/files/patch-ad
deleted file mode 100644
index 3d5ace1c5058..000000000000
--- a/www/twhttpd/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in.orig Wed Sep 25 12:41:35 2002
-+++ configure.in Wed Sep 25 12:41:44 2002
-@@ -8,7 +8,7 @@
- AC_PROG_LEX
-
- dnl Checks for libraries.
--AC_CHECK_LIB(pwdb, crypt)
-+AC_CHECK_LIB(crypt, crypt)
- AC_CHECK_LIB(socket, bind)
- AC_CHECK_LIB(nsl, gethostbyname)
-
diff --git a/www/twhttpd/files/patch-cfg_functions.c b/www/twhttpd/files/patch-cfg_functions.c
new file mode 100644
index 000000000000..66582b18b385
--- /dev/null
+++ b/www/twhttpd/files/patch-cfg_functions.c
@@ -0,0 +1,15 @@
+--- cfg_functions.c.orig Tue Feb 12 23:29:15 2002
++++ cfg_functions.c Mon Jun 26 02:38:18 2006
+@@ -29,10 +29,10 @@
+ #include <regex.h>
+ #include <syslog.h>
+ #include <unistd.h>
+-#include <arpa/inet.h>
+-#include <sys/socket.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+
+ #include "y.tab.h"
+ #include "twhttpd.h"
diff --git a/www/twhttpd/files/patch-cfg_parser.y b/www/twhttpd/files/patch-cfg_parser.y
new file mode 100644
index 000000000000..2ed4a34a4168
--- /dev/null
+++ b/www/twhttpd/files/patch-cfg_parser.y
@@ -0,0 +1,14 @@
+--- cfg_parser.y.orig Sat Aug 31 12:41:16 2002
++++ cfg_parser.y Mon Jun 26 02:40:51 2006
+@@ -27,10 +27,10 @@
+ #include <regex.h>
+ #include <errno.h>
+ #include <stdio.h>
+-#include <arpa/inet.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+
+ #include "config.h"
+ #include "cfg_functions.h"
diff --git a/www/twhttpd/files/patch-aa b/www/twhttpd/files/patch-config.h
index 919d055e56f1..a473487d2c78 100644
--- a/www/twhttpd/files/patch-aa
+++ b/www/twhttpd/files/patch-config.h
@@ -5,7 +5,7 @@
#define DEFAULT_CACHE_DIR ".cache"
#define DEFAULT_COOKIE_DIR ".cookie"
-#define DEFAULT_CONFIG_FILE "/etc/twhttpd.cfg"
-+#define DEFAULT_CONFIG_FILE "/usr/local/etc/twhttpd.cfg"
++#define DEFAULT_CONFIG_FILE "%%PREFIX%%/etc/twhttpd.cfg"
#define SOCKET_TIMEOUT 45 /* socket timeout value */
#define CONNECT_TIMEOUT 15 /* connect timeout value */
diff --git a/www/twhttpd/files/patch-httplog.c b/www/twhttpd/files/patch-httplog.c
new file mode 100644
index 000000000000..21e7853b9f2d
--- /dev/null
+++ b/www/twhttpd/files/patch-httplog.c
@@ -0,0 +1,16 @@
+--- httplog.c.orig Sat Dec 8 23:15:44 2001
++++ httplog.c Mon Jun 26 02:36:09 2006
+@@ -40,10 +40,11 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <syslog.h>
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <sys/time.h>
+-#include <sys/socket.h>
+-#include <sys/types.h>
+
+ #include "config.h"
+ #include "structs.h"
diff --git a/www/twhttpd/files/patch-ac b/www/twhttpd/files/patch-twhttpd.c
index c138d0cf6444..51c81f763d04 100644
--- a/www/twhttpd/files/patch-ac
+++ b/www/twhttpd/files/patch-twhttpd.c
@@ -1,15 +1,21 @@
---- twhttpd.c.orig Sat Aug 31 05:16:35 2002
-+++ twhttpd.c Wed Sep 25 12:02:49 2002
-@@ -33,7 +33,7 @@
+--- twhttpd.c.orig Tue Apr 1 13:06:08 2003
++++ twhttpd.c Mon Jun 26 02:47:58 2006
+@@ -33,10 +33,11 @@
#include <signal.h>
#include <time.h>
#include <unistd.h>
-#include <wait.h>
+-#include <netinet/in.h>
+-#include <sys/socket.h>
+#include <sys/wait.h>
- #include <netinet/in.h>
- #include <sys/socket.h>
#include <sys/types.h>
-@@ -3882,7 +3882,7 @@
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+
+@@ -4014,7 +4015,7 @@
lz_flush(hd->fd, &hd->fd_lzb);
}
syslog(LOG_ERR, "Exiting Testing Server\n");
diff --git a/www/twhttpd/pkg-message b/www/twhttpd/files/pkg-message.in
index 92e87913862d..aed58788d127 100644
--- a/www/twhttpd/pkg-message
+++ b/www/twhttpd/files/pkg-message.in
@@ -1,5 +1,5 @@
***************************************************************************
-twhttpd is installed in /usr/local/sbin/
-Now copy /usr/local/etc/twhttpd.cfg.sample to twhttpd.cfg,
+twhttpd is installed in %%PREFIX%%/sbin/
+Now copy %%PREFIX%%/etc/twhttpd.cfg.sample to twhttpd.cfg,
and edit it.
***************************************************************************