aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2008-11-19 04:07:53 +0800
committernox <nox@FreeBSD.org>2008-11-19 04:07:53 +0800
commita9122019270e4ef4151b77ff149023f6f047559e (patch)
tree239681bafc3cc6964ec7767d9d8c88cc7ce4ccb0
parentab1ab2ffa003bfb5ba3407d7f87bde2a4769b33e (diff)
downloadfreebsd-ports-a9122019270e4ef4151b77ff149023f6f047559e.tar.gz
freebsd-ports-a9122019270e4ef4151b77ff149023f6f047559e.tar.zst
freebsd-ports-a9122019270e4ef4151b77ff149023f6f047559e.zip
Fix build in unusual environments:
- CFLAGS containing commas [1] - Missing /usr/bin/perl symlink [2] Requested by: Denis Kozadaev <denis@tambov.ru> [1] Requested by: Michal Bartkowiak <michal@bartkowiak.biz> [2]
-rw-r--r--emulators/qemu-devel/Makefile11
-rw-r--r--emulators/qemu/Makefile11
2 files changed, 14 insertions, 8 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 841502d644c2..76670169dcff 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -118,13 +118,16 @@ post-patch:
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
.endif
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile.target
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing -I.," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing -I.|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E \
+ -e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
+ ${WRKSRC}/texi2pod.pl
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index d9cb1d2439c4..a3216aacc018 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -102,13 +102,16 @@ post-patch:
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
.endif
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile.target
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing -I.," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing -I.|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E \
+ -e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
+ ${WRKSRC}/texi2pod.pl
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc