aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-Tie-DNS/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 14:01:21 +0800
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 14:01:21 +0800
commitcf233d7b9730728684a41e18e4cfdd987d536da6 (patch)
tree43aa8cd8613e00670a1c7212e72c21e8352c8243 /dns/p5-Tie-DNS/Makefile
parent8b26a03f66fe20e94f25c9c9bdf11df7173b62e5 (diff)
downloadfreebsd-ports-cf233d7b9730728684a41e18e4cfdd987d536da6.tar.gz
freebsd-ports-cf233d7b9730728684a41e18e4cfdd987d536da6.tar.zst
freebsd-ports-cf233d7b9730728684a41e18e4cfdd987d536da6.zip
add p5-Tie-DNS 0.41
Tie interface to p5-Net-DNS PR: 34282 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Notes
Notes: svn path=/head/; revision=61991
Diffstat (limited to 'dns/p5-Tie-DNS/Makefile')
-rw-r--r--dns/p5-Tie-DNS/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/dns/p5-Tie-DNS/Makefile b/dns/p5-Tie-DNS/Makefile
new file mode 100644
index 000000000000..d01865bedb54
--- /dev/null
+++ b/dns/p5-Tie-DNS/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Tie::DNS
+# Date created: 25 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-DNS
+PORTVERSION= 0.41
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
+PERL_CONFIGURE= yes
+
+MAN3= Tie::DNS.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/eg/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>