aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-zstandard/Makefile23
-rw-r--r--archivers/py-zstandard/distinfo3
-rw-r--r--archivers/py-zstandard/pkg-descr13
4 files changed, 40 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 4ef331936310..3a115820926e 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -191,6 +191,7 @@
SUBDIR += py-rjsmin
SUBDIR += py-warctools
SUBDIR += py-xopen
+ SUBDIR += py-zstandard
SUBDIR += py-zstd
SUBDIR += qpress
SUBDIR += quazip
diff --git a/archivers/py-zstandard/Makefile b/archivers/py-zstandard/Makefile
new file mode 100644
index 000000000000..eb501e8d994c
--- /dev/null
+++ b/archivers/py-zstandard/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= zstandard
+DISTVERSION= 0.8.1
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Zstandard bindings for Python, a full-featured version
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.8.0:devel/py-cffi@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+#PYDISTUTILS_BUILDARGS= --system-zstd # The next release is going to allow to unbind zstd
+
+post-install:
+ @cd ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} && ${STRIP_CMD} zstd.so _zstd_cffi.so
+
+.include <bsd.port.mk>
diff --git a/archivers/py-zstandard/distinfo b/archivers/py-zstandard/distinfo
new file mode 100644
index 000000000000..6fb2d95abf94
--- /dev/null
+++ b/archivers/py-zstandard/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515564528
+SHA256 (zstandard-0.8.1.tar.gz) = d8df3b40fed5c0a5d15b36e698b0286323170086b2034e5d52465fa3c1ce2429
+SIZE (zstandard-0.8.1.tar.gz) = 463785
diff --git a/archivers/py-zstandard/pkg-descr b/archivers/py-zstandard/pkg-descr
new file mode 100644
index 000000000000..3f7e9a9561cc
--- /dev/null
+++ b/archivers/py-zstandard/pkg-descr
@@ -0,0 +1,13 @@
+This project provides Python bindings for interfacing with the Zstandard
+compression library. A C extension and CFFI interface are provided.
+
+Zstd, short for Zstandard, is a new lossless compression algorithm,
+which provides both good compression ratio and speed for standard
+compression needs. "Standard" translates into everyday situations
+which neither look for highest possible ratio (which LZMA and ZPAQ
+cover) nor extreme speeds (which LZ4 covers).
+
+Please note that a simple python binding to Zstandard is also
+available: archivers/py-zstd.
+
+WWW: https://github.com/indygreg/python-zstandard