aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/py-zstandard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/py-zstandard/Makefile')
-rw-r--r--archivers/py-zstandard/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/archivers/py-zstandard/Makefile b/archivers/py-zstandard/Makefile
new file mode 100644
index 000000000000..eb501e8d994c
--- /dev/null
+++ b/archivers/py-zstandard/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= zstandard
+DISTVERSION= 0.8.1
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Zstandard bindings for Python, a full-featured version
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.8.0:devel/py-cffi@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+#PYDISTUTILS_BUILDARGS= --system-zstd # The next release is going to allow to unbind zstd
+
+post-install:
+ @cd ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} && ${STRIP_CMD} zstd.so _zstd_cffi.so
+
+.include <bsd.port.mk>