aboutsummaryrefslogtreecommitdiffstats
path: root/devel/dbus-qt3
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-11-01 01:31:43 +0800
committeralepulver <alepulver@FreeBSD.org>2006-11-01 01:31:43 +0800
commita7502c576f5feb85baeeb42ed007c33fea9d99ca (patch)
tree8d6b9579f2fbe63a8f330c51e4c862c04b857038 /devel/dbus-qt3
parentbbb4c67780fe69fce28e3896ed62127a3e054225 (diff)
downloadfreebsd-ports-gnome-a7502c576f5feb85baeeb42ed007c33fea9d99ca.tar.gz
freebsd-ports-gnome-a7502c576f5feb85baeeb42ed007c33fea9d99ca.tar.zst
freebsd-ports-gnome-a7502c576f5feb85baeeb42ed007c33fea9d99ca.zip
Qt3 bindings for the D-BUS interprocess messaging system.
WWW: http://www.freedesktop.org/wiki/Software_2fDBusBindings PR: ports/104547 Submitted by: Maxim Samsonov <xors at sendmail.ru>
Diffstat (limited to 'devel/dbus-qt3')
-rw-r--r--devel/dbus-qt3/Makefile31
-rw-r--r--devel/dbus-qt3/distinfo3
-rw-r--r--devel/dbus-qt3/pkg-descr3
-rw-r--r--devel/dbus-qt3/pkg-plist8
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/dbus-qt3/Makefile b/devel/dbus-qt3/Makefile
new file mode 100644
index 000000000000..52aa6fc892cb
--- /dev/null
+++ b/devel/dbus-qt3/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: dbus-qt3
+# Date created: 2006-10-18
+# Whom: Maxim Samsonov <xors@sendmail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbus
+PORTVERSION= 0.70
+CATEGORIES= devel kde
+MASTER_SITES= ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+PKGNAMESUFFIX= -qt3
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= xors@sendmail.ru
+COMMENT= Qt3 bindings for the D-BUS messaging system
+
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus \
+ qt-mt:${PORTSDIR}/x11-toolkits/qt33
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ENV= QTDIR=${X11BASE} CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+PLIST_SUB= VERSION="1.0"
+
+.include <bsd.port.mk>
diff --git a/devel/dbus-qt3/distinfo b/devel/dbus-qt3/distinfo
new file mode 100644
index 000000000000..775058454047
--- /dev/null
+++ b/devel/dbus-qt3/distinfo
@@ -0,0 +1,3 @@
+MD5 (dbus-qt3-0.70.tar.bz2) = 9a8d4a4d560b49fb5ad034abfd3e3db5
+SHA256 (dbus-qt3-0.70.tar.bz2) = d86531f106f8172a635d57ef35b7856cb54885c50f175bd1bff374c0e5a5f5ed
+SIZE (dbus-qt3-0.70.tar.bz2) = 220305
diff --git a/devel/dbus-qt3/pkg-descr b/devel/dbus-qt3/pkg-descr
new file mode 100644
index 000000000000..665080ecf95f
--- /dev/null
+++ b/devel/dbus-qt3/pkg-descr
@@ -0,0 +1,3 @@
+Qt3 bindings for the D-BUS interprocess messaging system.
+
+WWW: http://www.freedesktop.org/wiki/Software_2fDBusBindings
diff --git a/devel/dbus-qt3/pkg-plist b/devel/dbus-qt3/pkg-plist
new file mode 100644
index 000000000000..9fc66062c3ec
--- /dev/null
+++ b/devel/dbus-qt3/pkg-plist
@@ -0,0 +1,8 @@
+include/dbus-%%VERSION%%/dbus/connection.h
+include/dbus-%%VERSION%%/dbus/dbus-qt.h
+include/dbus-%%VERSION%%/dbus/message.h
+include/dbus-%%VERSION%%/dbus/server.h
+lib/libdbus-qt-1.a
+lib/libdbus-qt-1.la
+lib/libdbus-qt-1.so
+lib/libdbus-qt-1.so.1
pan> * games/super_methane_brothers: unbreak after r450353jbeich2017-09-271-1/+1 * - Update to 92.5amdmi32017-09-272-6/+5 * - Update to 1.4amdmi32017-09-272-3/+4 * devel/boost-*: update to 1.65.1jbeich2017-09-2536-36/+38 * games/stuntrally: switch to C++11 for Boostjbeich2017-09-252-3/+7 * devel/boost-*: enable C++11 featuresjbeich2017-09-2535-33/+37 * devel/icu: update to 59.1jbeich2017-09-255-4/+5 * Reset maintainership on Dominic Fandrey's ports.adamw2017-09-249-9/+9 * remove games/ember. It is a) BROKEN and b) no longer developed since 2014.oliver2017-09-2310-2170/+0 * Cleanup after removal of libexecinfo from ports.mat2017-09-224-14/+4 * Remove USES=execinfo.mat2017-09-2215-20/+16 * Use the MASTER_SITES macros correctly.mat2017-09-222-2/+2 * games/simutrans: regen patches via "make makepatch"jbeich2017-09-223-12/+11 * games/simutrans: unbreak with libc++ 5.0jbeich2017-09-221-0/+12 * - Fix build failure with new boot version 1.65madpilot2017-09-185-13/+24 * update games/wtf to 20170918 snapshot from NetBSDlifanov2017-09-182-4/+4 * games/crossfire-client: Update to 1.72.0swills2017-09-183-15/+58 * Update to 3.7ehaupt2017-09-172-4/+4 * update games/wtf to 20170915 snapshot from NetBSDlifanov2017-09-162-4/+4 * Reset kami's ports to his personal email address.adamw2017-09-169-9/+9 * Fix license information for portgs that use "the same license as Perl".mat2017-09-155-5/+5 * new port: games/nxenginelifanov2017-09-158-0/+536 * Update patch with better one provided upstream.madpilot2017-09-152-6/+25 * games/gzdoom: create portswills2017-09-158-0/+194 * Connect sdlpop to buildswills2017-09-151-0/+1 * games/sdlpop: create portswills2017-09-155-0/+1176 * Update distinfo as jonof-jfaudiolib was rerolled upstreammartymac2017-09-141-3/+3 * - Update to 3.1.2amdmi32017-09-133-5/+5 * - Add LICENSEamdmi32017-09-126-30/+33 * lang/tcl84, x11-toolkits/tk84: deprecate Tcl/Tk 8.4 and dependentsgahr2017-09-111-0/+4 * games/openbor: simplify initialization of sysctl valuesjbeich2017-09-114-12/+8 * - Add NO_ARCHamdmi32017-09-111-4/+5 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-1193-70/+93 * - Update WWWamdmi32017-09-101-1/+1 * Convert USES of tcl or tk from 84,85 to 85gahr2017-09-071-1/+2 * - Update WWWamdmi32017-09-051-1/+1 * - Update WWWamdmi32017-09-041-1/+1 * games/manaplus: update to 1.7.9.2jbeich2017-09-043-6/+119 * - Update to 20170825amdmi32017-09-012-5/+5 * - Add games/epiphany-gameamdmi32017-08-314-0/+52 * - Fix shebangsamdmi32017-08-311-7/+10 * - Add games/aklabethamdmi32017-08-294-0/+49 * - Backport commits 0ba2ac31 and 1ad2bf44 (fixes for CVE-2017-13709)martymac2017-08-283-1/+130 * An open-source re-implementation of RollerCoaster Tycoon 2. A construction andamdmi32017-08-257-0/+116 * - Fix build with gcc7amdmi32017-08-251-0/+20 * - Fix built with gcc6amdmi32017-08-241-0/+11 * Remove expired ports:rene2017-08-2315-733/+0 * Schedule games/opensurge for removal on 2017-11-01, it depends onrene2017-08-231-0/+3 * update games/wtf to 20170822 snapshot from NetBSDlifanov2017-08-222-4/+4 * Update GNUstep core libraries.theraven2017-08-2115-18/+48 * - Update to 0.9.8amdmi32017-08-212-4/+4 * - Update to 0.9.8amdmi32017-08-213-16/+4 * - Update to 1.3.4amdmi32017-08-213-10/+8 * Update RUN_DEPENDS: use newer twistedsunpoet2017-08-201-2/+4 * - Update to 1.1.1amdmi32017-08-203-6/+5 * - Update to 1.2.3amdmi32017-08-203-6/+6 * - Update to 2.1.1amdmi32017-08-203-6/+5 * - Update to 92.1amdmi32017-08-202-5/+5 * games/moonlight-embedded: Update to 2.4.3tobik2017-08-182-4/+4 * Update devel/protobuf to 3.4.0sunpoet2017-08-163-2/+3 * Bump PORTREVISION after r447874.rakuco2017-08-131-1/+1 * Add patch to fix a wrong assignment in the code.rakuco2017-08-131-0/+14 * update games/wtf to 20170811 snapshot from NetBSDlifanov2017-08-122-4/+4 * Fix build errors with clang and GCC 6.rakuco2017-08-124-2/+101 * games/OpenTomb: Update to 2017.08.05.atobik2017-08-122-4/+4 * Remove Perl core modulessunpoet2017-08-111-2/+1 * - Update WWWamdmi32017-08-092-6/+8 * games/manaplus: update to 1.7.8.5jbeich2017-08-092-4/+4 * - Update The Glorious Glasgow Haskell Compiler to version 8.0.2tcberner2017-08-092-3/+4 * Build with -std=gnu++11 when OPENMP is on.rakuco2017-08-051-0/+4 * Update to 1.2.5jhale2017-08-042-6/+5 * - Update to 0.7.0acm2017-08-044-13/+23 * New port: games/moonlight-embeddedtobik2017-08-049-0/+195 * Belatedly update `games/slade' to version 3.1.1.5, the latest stable release.danfe2017-08-032-5/+4 * games/ags: Fix build on CURRENTtobik2017-08-031-0/+34 * Update of LLVM components in -head to version 5.0.0 apparently had brokendanfe2017-08-031-0/+13 * Update WWW line in pkg-descr.madpilot2017-08-021-1/+1 * * Updated to 1.7.7.22ultima2017-08-023-6/+7 * Remove expired ports:rene2017-08-018-171/+0 * - Update games/0ad to Alpha 22 Venustas (0.0.22)madpilot2017-07-3110-25/+95 * Update to upstream version 1.2.1riggs2017-07-314-6/+15 * Set MAKEINFO to the full path of makeinfo when USES=makeinfo is set.jkim2017-07-291-1/+1 * Release maintainership.tijl2017-07-291-1/+1 * - Update to 4.2culot2017-07-283-14/+5 * - Unsilence installation, switch to NO_BUILDamdmi32017-07-281-16/+15 * Update to 3.6ehaupt2017-07-273-26/+4 * Regular USE_GITHUB cleanup.mat2017-07-271-3/+1 * - Update to 92.0amdmi32017-07-272-6/+7 * Remove USES=ncurses, this never uses libncurses from portsamdmi32017-07-271-2/+0 * games/openmw: Update to 0.42.0tobik2017-07-274-42/+6 * games/super_methane_brothers: unbreak runtime on non-x86 after r446663jbeich2017-07-273-25/+100 * - Unbreak: this fetches fineamdmi32017-07-251-8/+8 * - Add games/stuntrally: 3D racing gameamdmi32017-07-258-0/+166 * - Bump after devel/bullet updateamdmi32017-07-252-2/+2 * follow permanent redirect of http -> httpslifanov2017-07-251-1/+1 * multimedia/assimp: rebuild consumers after r446390jbeich2017-07-222-2/+2 * games/pioneer: unbreak after r446390jbeich2017-07-222-0/+5 * Deprecate ports BROKEN for more than 6 monthsantoine2017-07-223-0/+6 * Bump to 05.05.2017 release version.sbruno2017-07-192-6/+5 * Update to 3.5ehaupt2017-07-173-5/+28 * - Clarify LICENSEpawel2017-07-171-2/+2 * Update to Crafty 25.2johans2017-07-164-44/+41 * - Update WWWamdmi32017-07-152-3/+3 * - Update WWWamdmi32017-07-141-1/+1 * - Pet portlintamdmi32017-07-147-19/+19 * - Pet portlintamdmi32017-07-142-3/+4 * - Update WWWamdmi32017-07-141-1/+1 * - Update to 1.0.0amdmi32017-07-117-71/+28 * games/manaplus: update to 1.7.7.8jbeich2017-07-102-4/+4 * - Add LICENSEamdmi32017-07-101-30/+20 * games/rubygem-vimgolf: create portswills2017-07-085-0/+30 * Add mrboom 3.4, 8 players Bomberman clone.ehaupt2017-07-074-0/+49 * Add ballerburg 1.2.0, two players, two castles, and a hill in between.ehaupt2017-07-077-0/+83 * * Updated maintainer email addressultima2017-07-061-2/+2 * Update to Freeciv 2.5.7 (minor bugfix release)johans2017-07-062-5/+4 * games/dunelegacy: update to 0.96.4swills2017-07-056-57/+46 * games/tome4: get rid of http mirror as it's a redirect nowlifanov2017-07-041-1/+0 * update games/stonesoup, games/stonesoup-sdl to 0.20.1lifanov2017-07-032-4/+4 * - Add missing depends after update to b19amdmi32017-07-031-5/+5 * Add missing dependency to libudevmartymac2017-07-032-2/+14 * - Update to 1.5.8amdmi32017-07-023-12/+15 * - Update to 1.5.8amdmi32017-07-022-81/+81 * - Update to 0.5.2amdmi32017-07-022-6/+6 * - Update to 0.5.2amdmi32017-07-022-4/+4 * Update games/lgeneral to 1.3.2madpilot2017-06-303-12/+10 * - Fix build on CURRENT after ino64 mergeamdmi32017-06-292-1/+15 * - Fix LICENSEamdmi32017-06-291-6/+7 * games/aquaria: drop tinyxml2 5.0.0 workaround after r444478jbeich2017-06-292-25/+1 * - Update to 9.4gamdmi32017-06-285-34/+100 * Update devel/readline to 7.0 patch 3sunpoet2017-06-277-5/+7 * games/manaplus: update to 1.7.6.24jbeich2017-06-273-4/+11 * Scrub one more usage of pc98.linimon2017-06-271-1/+1 * games/xscavenger: fix font mapping with Clang or GCC 7.*jbeich2017-06-272-0/+13 * Scrub mention of armv6hf from ARCHS. It was never in a released version.linimon2017-06-271-1/+1 * Update to 4.1.0sunpoet2017-06-273-3/+16 * - Switch to options helpersamdmi32017-06-262-3/+5 * Fix WWWsunpoet2017-06-261-1/+1 * Fix WWWsunpoet2017-06-261-1/+1 * games/aquaria: unbreak after r443975jbeich2017-06-261-0/+24 * Make ninja opt-out in cmake.mktcberner2017-06-266-6/+6 * Fix WWWsunpoet2017-06-261-1/+1 * Fix WWWsunpoet2017-06-261-1/+1 * Fix WWWsunpoet2017-06-261-1/+1 * Remove expired ports:rene2017-06-265-55/+0 * Begin deorbit burn of ia64. We have not attempted to build packages forlinimon2017-06-251-4/+0 * Remove Perl core modulessunpoet2017-06-231-4/+5 * Broken along with balazar_brothers.linimon2017-06-221-0/+1 * - Update games/widelands to build19madpilot2017-06-206-32/+117 * Update textproc/tinyxml2 to 5.0.0sunpoet2017-06-201-0/+1 * * Updated to 20170614 (r6180)ultima2017-06-203-8/+19 * Update libgnome-games-support to 1.2.2.kwm2017-06-194-5/+8 * - Update to 4.12.1danilo2017-06-183-12/+36 * Pentobi is a computer opponent for the board game Blokus.amdmi32017-06-166-0/+156 * - Update to 20170606amdmi32017-06-162-6/+12 * - Update to 2.14.7amdmi32017-06-166-55/+17 * update games/wtf to 20170614 snapshot from NetBSDlifanov2017-06-152-4/+4 * - Add LICENSEamdmi32017-06-152-5/+13 * Update OpenTTD to version 1.7.1.danfe2017-06-152-4/+4 * - Switch to options helpersamdmi32017-06-141-1/+3 * games/openbor: update to 4515jbeich2017-06-142-6/+6 * Mark BROKEN: conflicting dependenciesantoine2017-06-111-0/+2 * games/openra: update GeoLite2 to June snapshotjbeich2017-06-112-3/+4 * - Update WWWamdmi32017-06-111-1/+1 * Update distinfo and unbreak this portsunpoet2017-06-112-3/+4 * Remove no-op WX_UNICODEsunpoet2017-06-106-6/+0 * - Update to 0.3.3amdmi32017-06-094-21/+22 * - Fix key file installationamdmi32017-06-091-3/+2 * New port: games/OpenTombtobik2017-06-098-0/+295 * Update to 1.51tobik2017-06-092-5/+4 * Add explicit libpng dependency to fix the build of games/opensonictobik2017-06-091-1/+2 * Add NO_ARCHsunpoet2017-06-081-0/+1 * - Update to 0.4.16amdmi32017-06-073-5/+5 * - Update to 0.4.16amdmi32017-06-075-18/+16 * - Add games/auralquizamdmi32017-06-076-0/+86 * Convert every usage of https://github.com/.../archive/xxx to USE_GITHUB.mat2017-06-076-41/+29 * Use MAKE_CMD instead of MAKE in pre-build.rakuco2017-06-061-1/+1 * Switch to an out-of-source CMake build.rakuco2017-06-062-6/+2 * Change from USES=twisted to devel/py-twistedsunpoet2017-06-051-2/+3 * Change from USES=twisted to devel/py-twistedsunpoet2017-06-051-2/+3 * - Update to 3.0.1amdmi32017-06-052-4/+4 * games/openra: update to 20170527jbeich2017-06-052-5/+4 * Apply some patches from OpenSUSE to fix some issues, including the build on r...bar2017-06-0415-16/+300 * Fix shebangs.tcberner2017-06-031-5/+19 * Mark some ports failing on powerpc64. These ports are either newlinimon2017-06-021-0/+2 * Convert to options helpersunpoet2017-06-022-14/+11 * Convert to options target helpersunpoet2017-06-023-6/+6 * update games/wtf to 20170529 snapshot from NetBSDlifanov2017-05-312-4/+4 * games/stonesoup: actually commit patch to sound.hlifanov2017-05-311-0/+19 * games/stonesoup, games/stonesoup-sdl: update to 0.20.0lifanov2017-05-318-79/+25 * Fix OpenAL dependencytobik2017-05-311-3/+2 * Remove ALSA dependency. It's not required.tobik2017-05-312-8/+8 * Register dependency on groffantoine2017-05-291-1/+1 * Fix options helpersunpoet2017-05-291-5/+5 * Register dependency on groffantoine2017-05-291-1/+1 * Mark some ports failing on armv6, for errors classified as "linker_error".linimon2017-05-281-0/+2 * Mark some ports failing on armv6, for errors classified as "coredump".linimon2017-05-284-0/+10 * Mark some ports failing on armv6, for errors classified as "clang_werror".linimon2017-05-281-4/+4 * Mark some ports failing on armv6, for errors classified as "clang".linimon2017-05-271-2/+3 * Mark some ports failing on armv6, for errors classified as "bad C++ code".linimon2017-05-272-2/+5 * Mark some ports failing on armv6, for errors classified as "???".linimon2017-05-273-5/+8 * Also fails on armv6. Convert to NOT_FOR.linimon2017-05-271-1/+2 * update games/tome4 to 1.5.5lifanov2017-05-242-5/+4 * - Switch to options helpersamdmi32017-05-242-3/+5 * games/manaplus: update to 1.7.5.14jbeich2017-05-242-5/+4 * Revision bump of all ports with USE_GL after consolidation of mesa-libsrezny2017-05-23