aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/mame
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-12-16 09:34:39 +0800
committeralepulver <alepulver@FreeBSD.org>2007-12-16 09:34:39 +0800
commit0153612e4f8f507a78cf83a7306668174002ea94 (patch)
treead28f90f9bc5ca6fe3d9b3aeee5eab44288a059e /emulators/mame
parent660a1ad24bcc599557db56549e4140d9c39865ad (diff)
downloadfreebsd-ports-gnome-0153612e4f8f507a78cf83a7306668174002ea94.tar.gz
freebsd-ports-gnome-0153612e4f8f507a78cf83a7306668174002ea94.tar.zst
freebsd-ports-gnome-0153612e4f8f507a78cf83a7306668174002ea94.zip
- Use GCC 4.2 in FreeBSD 5.x since base system one fails (internal compiler
error), and using 3.4 from ports requires hacks to confuse bsd.gcc.mk. Reported by: pointyhat (via pav)
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index e533322fe0ee..d6a571494c1d 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -43,4 +43,13 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
+.if ${OSVERSION} < 600000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>