aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/mame
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index e533322fe0ee..d6a571494c1d 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -43,4 +43,13 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
+.if ${OSVERSION} < 600000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>